summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Balistreri <brain@gentoo.org>2003-04-29 09:35:59 +0000
committerMichele Balistreri <brain@gentoo.org>2003-04-29 09:35:59 +0000
commit03bf9609258e38ff5d1f060dc33d4c72c7f38154 (patch)
treeda4540411bf5435c52de99bcbb29a5227bb43ef6
parentVersion bump (diff)
downloadgentoo-2-03bf9609258e38ff5d1f060dc33d4c72c7f38154.tar.gz
gentoo-2-03bf9609258e38ff5d1f060dc33d4c72c7f38154.tar.bz2
gentoo-2-03bf9609258e38ff5d1f060dc33d4c72c7f38154.zip
Version bump
-rw-r--r--dev-python/sip/ChangeLog7
-rw-r--r--dev-python/sip/Manifest4
-rw-r--r--dev-python/sip/files/digest-sip-3.61
-rw-r--r--dev-python/sip/files/license-3.6.diff34
-rw-r--r--dev-python/sip/sip-3.6.ebuild50
5 files changed, 93 insertions, 3 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index 986d9999fb75..25f3bcc8a57a 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/sip
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.12 2003/04/04 01:21:34 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.13 2003/04/29 09:35:43 brain Exp $
+
+*sip-3.6 (29 Apr 2003)
+
+ 29 Apr 2003; Michele Balistreri <brain@gentoo.org> sip-3.6.ebuild :
+ Version bump
*sip-3.5 (14 Dec 2002)
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index 9c4b87233e5b..1d5496528d8a 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1,6 +1,6 @@
-MD5 4684defc77151f0e2483eedb9f1d4076 ChangeLog 1597
+MD5 8646e695bcf38b5be5bfe77987597df2 ChangeLog 1595
MD5 0566b1536262d34d232c555ce994dcbc sip-3.5.ebuild 1146
-MD5 3c4a5f3f9efa66889bcf60d480634959 sip-3.6.ebuild 1152
+MD5 963d7093eac72cf59bc3f2403328c2a3 sip-3.6.ebuild 1150
MD5 3d3910def0f161c87391dd758512fc18 files/license-3.6.diff 1037
MD5 02beeecfef8cd92555d0a20b8d331fa6 files/digest-sip-3.5 67
MD5 ea94cf729c92330a5d8a6d508361fd1c files/license-3.5.diff 1052
diff --git a/dev-python/sip/files/digest-sip-3.6 b/dev-python/sip/files/digest-sip-3.6
new file mode 100644
index 000000000000..30f99e2c5773
--- /dev/null
+++ b/dev-python/sip/files/digest-sip-3.6
@@ -0,0 +1 @@
+MD5 f8593ad47f9b5edf789887b619b43a6a sip-x11-gpl-3.6.tar.gz 174084
diff --git a/dev-python/sip/files/license-3.6.diff b/dev-python/sip/files/license-3.6.diff
new file mode 100644
index 000000000000..c6b8b8edff52
--- /dev/null
+++ b/dev-python/sip/files/license-3.6.diff
@@ -0,0 +1,34 @@
+--- build.py.orig 2003-04-26 16:51:47.000000000 +0200
++++ build.py 2003-04-29 11:24:28.000000000 +0200
+@@ -574,31 +574,6 @@
+ licType = "GPL"
+ licname = "GNU General Public License"
+
+- inform("This is the %s version of SIP and is licensed under the %s." % (licType,licname),0)
+-
+- print
+- print "Type 'L' to view the license."
+- print "Type 'yes' to accept the terms of the license."
+- print "Type 'no' to decline the terms of the license."
+- print
+-
+- while 1:
+- try:
+- resp = raw_input("Do you accept the terms of the license? ")
+- except:
+- resp = ""
+-
+- resp = string.lower(string.strip(resp))
+-
+- if resp == "yes":
+- break
+-
+- if resp == "no":
+- sys.exit(0)
+-
+- if resp == "l":
+- os.system("more LICENSE")
+-
+ inform("Building the %s version of SIP 3.6 for Python %s on %s." % (licType,pyFullVers,sys.platform))
+
+ # We can't be sure that we can run programs under Windows (because it might
diff --git a/dev-python/sip/sip-3.6.ebuild b/dev-python/sip/sip-3.6.ebuild
new file mode 100644
index 000000000000..368692c18d89
--- /dev/null
+++ b/dev-python/sip/sip-3.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-3.6.ebuild,v 1.1 2003/04/29 09:35:43 brain Exp $
+
+IUSE=""
+
+inherit eutils distutils
+
+MY_P="${PN}-x11-gpl-${PV}"
+DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
+SRC_URI="http://www.river-bank.demon.co.uk/download/sip/${MY_P}.tar.gz"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/sip/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND="virtual/glibc
+ x11-libs/qt
+ >=dev-lang/python-2.2.1"
+
+S=${WORKDIR}/${MY_P}
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/license-${PV}.diff
+}
+
+src_compile(){
+ distutils_python_version
+
+ chmod +x build.py
+ dodir /usr/bin
+ dodir /usr/lib/python${PYVER}/site-packages
+ python build.py -l qt-mt \
+ -b ${D}/usr/bin \
+ -d ${D}/usr/lib/python${PYVER}/site-packages \
+ -e ${D}/usr/include/python${PYVER}
+
+ make || die
+}
+
+src_install() {
+ distutils_python_version
+ dodir /usr/include/python${PYVER}
+ make DESTDIR=${D} install || die
+ dodoc NEWS README THANKS
+}