summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-08-23 07:32:13 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-08-23 07:32:13 +0000
commit05a997ac1464df6a3072839c63e02044df9add63 (patch)
tree9c577e2a6fb0e3000b5cd2eed75d4d9206dc51a3
parentremoved /bin/su; we use the one from sys-apps/shadow (diff)
downloadgentoo-2-05a997ac1464df6a3072839c63e02044df9add63.tar.gz
gentoo-2-05a997ac1464df6a3072839c63e02044df9add63.tar.bz2
gentoo-2-05a997ac1464df6a3072839c63e02044df9add63.zip
more build image fixes
-rw-r--r--files/bootstrap-1.0_rc6.packages2
-rw-r--r--files/build-1.0_rc6.packages2
-rw-r--r--profiles/package.mask3
-rw-r--r--sys-apps/baselayout/baselayout-1.6-r1.ebuild62
-rw-r--r--sys-apps/sh-utils/sh-utils-2.0j-r3.ebuild66
-rw-r--r--sys-devel/gcc/gcc-2.95.3-r2.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.2.4-r1.ebuild4
7 files changed, 46 insertions, 97 deletions
diff --git a/files/bootstrap-1.0_rc6.packages b/files/bootstrap-1.0_rc6.packages
index ad61fce2745d..f4dff9278010 100644
--- a/files/bootstrap-1.0_rc6.packages
+++ b/files/bootstrap-1.0_rc6.packages
@@ -1,5 +1,5 @@
./sys-apps/portage/portage-1.5.4.ebuild
./sys-libs/glibc/glibc-2.2.4-r1.ebuild
./sys-devel/binutils/binutils-2.11.90.0.7.ebuild
-./sys-devel/gcc/gcc-2.95.3-r2.ebuild
+./sys-devel/gcc/gcc-2.95.3-r1.ebuild
./sys-devel/gettext/gettext-0.10.39.ebuild
diff --git a/files/build-1.0_rc6.packages b/files/build-1.0_rc6.packages
index a058f110645a..f3836f7b1d16 100644
--- a/files/build-1.0_rc6.packages
+++ b/files/build-1.0_rc6.packages
@@ -18,7 +18,7 @@
./sys-devel/binutils/binutils-2.11.90.0.7.ebuild
./sys-devel/bison/bison-1.28-r3.ebuild
./sys-devel/flex/flex-2.5.4a-r4.ebuild
-./sys-devel/gcc/gcc-2.95.3-r2.ebuild
+./sys-devel/gcc/gcc-2.95.3-r1.ebuild
./sys-devel/make/make-3.79.1-r3.ebuild
./sys-devel/patch/patch-2.5.4-r3.ebuild
./sys-devel/spython/spython-2.0-r7.ebuild
diff --git a/profiles/package.mask b/profiles/package.mask
index 05d08abc1b25..5eaa2c78c6e4 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -1,3 +1,6 @@
+#this gcc's new atexit() fix that is supposed to be wonderful, doesn't work....
+=sys-devel/gcc-2.95.3-r2
+
#experimental objprelink, used by qt/kde, may be unstable
dev-util/objprelink
diff --git a/sys-apps/baselayout/baselayout-1.6-r1.ebuild b/sys-apps/baselayout/baselayout-1.6-r1.ebuild
index 5d54cb60dc11..fc5c78aa8d4a 100644
--- a/sys-apps/baselayout/baselayout-1.6-r1.ebuild
+++ b/sys-apps/baselayout/baselayout-1.6-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: System Team <system@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.6-r1.ebuild,v 1.7 2001/08/22 21:18:13 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.6-r1.ebuild,v 1.8 2001/08/23 07:32:13 drobbins Exp $
SV=1.1.3
S=${WORKDIR}/rc-scripts-${SV}
@@ -15,6 +15,16 @@ src_compile() {
gcc ${CFLAGS} runscript.c -o runscript
}
+#adds ".keep" files so that dirs aren't auto-cleaned
+keepdir() {
+ dodir $*
+ local x
+ for x in $*
+ do
+ touch ${D}/${x}/.keep
+ done
+}
+
src_install()
{
local foo
@@ -27,24 +37,24 @@ src_install()
echo '!!! installed versions. We will have an automated update system shortly.'
exit 1
fi
- dodir /sbin
+ keepdir /sbin
exeinto /sbin
doexe ${T}/runscript
- dodir /usr
- dodir /usr/bin
- dodir /usr/lib
- dodir /usr/sbin
+ keepdir /usr
+ keepdir /usr/bin
+ keepdir /usr/lib
+ keepdir /usr/sbin
dosbin ${S}/sbin/MAKEDEV ${S}/sbin/run-crons ${S}/sbin/update-modules
- dodir /var /var/run /var/lock/subsys
+ keepdir /var /var/run /var/lock/subsys
dosym ../var/tmp /usr/tmp
if [ -z "`use bootcd`" ]
then
- dodir /boot
+ keepdir /boot
dosym . /boot/boot
- dodir /home
- dodir /usr/include /usr/src /usr/portage /usr/X11R6/include/GL
+ keepdir /home
+ keepdir /usr/include /usr/src /usr/portage /usr/X11R6/include/GL
dosym ../X11R6/include/X11 /usr/include/X11
dosym ../X11R6/include/GL /usr/include/GL
@@ -55,12 +65,12 @@ src_install()
#the currently-installed includes in /usr/src and copies them to /usr/include/linux and
#/usr/include/asm. This is the recommended approach so that kernel includes can remain
#constant. The kernel includes should really only be upgraded when you upgrade glibc.
- dodir /usr/include/linux /usr/include/asm
- dodir /usr/share/man /usr/share/info /usr/share/doc /usr/share/misc
+ keepdir /usr/include/linux /usr/include/asm
+ keepdir /usr/share/man /usr/share/info /usr/share/doc /usr/share/misc
for foo in games lib sbin share bin share/doc share/man src
do
- dodir /usr/local/${foo}
+ keepdir /usr/local/${foo}
done
#local FHS compat symlinks
dosym share/man /usr/local/man
@@ -70,14 +80,14 @@ src_install()
dosym share/man /usr/man
dosym share/doc /usr/doc
dosym share/info /usr/info
- dodir /usr/X11R6/share
+ keepdir /usr/X11R6/share
dosym ../../share/info /usr/X11R6/share/info
#end FHS compatibility symlinks stuff
doman ${FILESDIR}/MAKEDEV.8
dodoc ${FILESDIR}/copyright ${FILESDIR}/changelog.Debian
- dodir /usr/X11R6/lib /usr/X11R6/man
- dodir /var/log/news
+ keepdir /usr/X11R6/lib /usr/X11R6/man
+ keepdir /var/log/news
#supervise stuff depreciated
#dodir /var/lib/supervise
@@ -85,7 +95,7 @@ src_install()
#install -d -m0750 -o root -g wheel ${D}/var/lib/supervise/services
#end supervise stuff
- dodir /opt
+ keepdir /opt
# It makes sense to move these to the PAM package.
# dodir /etc/pam.d
@@ -97,12 +107,14 @@ src_install()
touch ${D}/var/log/lastlog
touch ${D}/var/run/utmp
touch ${D}/var/log/wtmp
- dodir /var/db/pkg /var/spool /var/tmp /var/lib/misc
+ #the .keep file messes up Portage when looking in /var/db/pkg
+ dodir /var/db/pkg
+ keepdir /var/spool /var/tmp /var/lib/misc
chmod 1777 ${D}/var/tmp
- dodir /root /proc
+ keepdir /root /proc
chmod go-rx ${D}/root
- dodir /tmp
+ keepdir /tmp
chmod 1777 ${D}/tmp
chmod 1777 ${D}/var/tmp
chown root.uucp ${D}/var/lock
@@ -113,7 +125,7 @@ src_install()
ln -s ../proc/filesystems ${D}/etc/filesystems
for foo in hourly daily weekly monthly
do
- dodir /etc/cron.${foo}
+ keepdir /etc/cron.${foo}
done
for foo in ${S}/etc/*
do
@@ -122,16 +134,16 @@ src_install()
done
chmod go-rwx ${D}/etc/shadow
- dodir /lib /proc /mnt/floppy /mnt/cdrom
+ keepdir /lib /proc /mnt/floppy /mnt/cdrom
chmod go-rwx ${D}/mnt/floppy ${D}/mnt/cdrom
# dosbin rc-update
# insinto /usr/bin
# insopts -m0755
# doins colors
- dodir /dev
- dodir /dev-state
- dodir /dev/pts /dev/shm
+ keepdir /dev
+ keepdir /dev-state
+ keepdir /dev/pts /dev/shm
dosym /usr/sbin/MAKEDEV /dev/MAKEDEV
cd ${D}/dev
#These devices are also needed by many people and should be included
diff --git a/sys-apps/sh-utils/sh-utils-2.0j-r3.ebuild b/sys-apps/sh-utils/sh-utils-2.0j-r3.ebuild
deleted file mode 100644
index bb3c840b78c0..000000000000
--- a/sys-apps/sh-utils/sh-utils-2.0j-r3.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sh-utils/sh-utils-2.0j-r3.ebuild,v 1.3 2001/08/11 05:30:57 drobbins Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="Your standard GNU shell utilities"
-SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${A}"
-
-DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )"
-
-RDEPEND="virtual/glibc"
-
-src_unpack() {
-
- unpack ${A}
- cd ${S}
- patch -p0 < ${FILESDIR}/${P}-src-sys2.h-gentoo.diff
-}
-
-src_compile() {
-
- local myconf
- if [ -z "`use nls`" ]
- then
- myconf="--disable-nls"
- fi
-
- try CFLAGS="${CFLAGS}" ./configure --host=${CHOST} --build=${CHOST} \
- --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info \
- --without-included-regex ${myconf}
-
- if [ -z "`use static`" ]
- then
- try make ${MAKEOPTS}
- else
- try make ${MAKEOPTS} LDFLAGS=-static
- fi
-}
-
-src_install() {
-
- try make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
- rm -rf ${D}/usr/lib
- dodir /bin
- cd ${D}/usr/bin
- mv date echo false pwd stty su true uname ${D}/bin
-
- if [ -z "`use build`" ]
- then
- # We must use hostname from net-base
- rm hostname
- cd ${S}
- dodoc AUTHORS COPYING ChangeLog ChangeLog.0 \
- NEWS README THANKS TODO
- else
- rm -rf ${D}/usr/lib ${D}/usr/share/man ${D}/usr/share/info
- fi
-
-}
-
-
-
diff --git a/sys-devel/gcc/gcc-2.95.3-r2.ebuild b/sys-devel/gcc/gcc-2.95.3-r2.ebuild
index 061d6b3873c2..7efa4b433969 100644
--- a/sys-devel/gcc/gcc-2.95.3-r2.ebuild
+++ b/sys-devel/gcc/gcc-2.95.3-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r2.ebuild,v 1.2 2001/08/21 02:55:51 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r2.ebuild,v 1.3 2001/08/23 07:32:13 drobbins Exp $
SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/${P}/${P}.tar.gz
@@ -43,7 +43,7 @@ src_unpack() {
cd ${S}
# A patch for the atexit problem occured with glibc-2.2.3
- # patch -l -p0 < ${FILESDIR}/${P}-atexit.diff
+ patch -l -p0 < ${FILESDIR}/${P}-atexit.diff
# The previous patch has been replaced with this patch:
patch -l -p1 < ${FILESDIR}/${P}-destructor-atexit.diff
diff --git a/sys-libs/glibc/glibc-2.2.4-r1.ebuild b/sys-libs/glibc/glibc-2.2.4-r1.ebuild
index d214092ef2c8..f0821d5e6ed7 100644
--- a/sys-libs/glibc/glibc-2.2.4-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.2.4-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.4-r1.ebuild,v 1.1 2001/08/22 21:36:53 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.4-r1.ebuild,v 1.2 2001/08/23 07:32:13 drobbins Exp $
S=${WORKDIR}/${P}
DESCRIPTION="GNU libc6 (also called glibc2) C library"
@@ -13,7 +13,7 @@ HOMEPAGE="http://www.gnu.org/software/libc/libc.html"
#Specific Linux headers are now required so that we build from a stable "base"
#We need gcc-2.95.3-r2 because it includes a special fix for this glibc version (2.2.4)
-DEPEND=">=sys-devel/gcc-2.95.3-r2 ~sys-kernel/linux-headers-2.4.8.8 nls? ( sys-devel/gettext ) gd? ( media-libs/libgd )"
+DEPEND="~sys-kernel/linux-headers-2.4.8.8 nls? ( sys-devel/gettext ) gd? ( media-libs/libgd )"
if [ -z "`use bootstrap`" ] && [ -z "`use bootcd`" ] && [ -z "`use build`" ]
then