summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-27 02:27:33 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-27 02:27:33 +0000
commit0d08e4aa22122db2762e21028b41c55727d09892 (patch)
treef2e30c69d2531ebf692fa4b6b82af0a80ba16c8f
parentmanifest... (diff)
downloadgentoo-2-0d08e4aa22122db2762e21028b41c55727d09892.tar.gz
gentoo-2-0d08e4aa22122db2762e21028b41c55727d09892.tar.bz2
gentoo-2-0d08e4aa22122db2762e21028b41c55727d09892.zip
add back in since .3 is broken on hppa
-rw-r--r--sys-devel/binutils/binutils-2.15.90.0.1.1.ebuild179
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.15.90.0.1.12
2 files changed, 181 insertions, 0 deletions
diff --git a/sys-devel/binutils/binutils-2.15.90.0.1.1.ebuild b/sys-devel/binutils/binutils-2.15.90.0.1.1.ebuild
new file mode 100644
index 000000000000..834cbaed22d5
--- /dev/null
+++ b/sys-devel/binutils/binutils-2.15.90.0.1.1.ebuild
@@ -0,0 +1,179 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.15.90.0.1.1.ebuild,v 1.7 2004/04/27 02:27:33 vapier Exp $
+
+# NOTE to Maintainer: ChangeLog states that it no longer use perl to build
+# the manpages, but seems this is incorrect ....
+
+inherit eutils libtool flag-o-matic
+
+PATCHVER="1.0"
+
+DESCRIPTION="Tools necessary to build programs"
+HOMEPAGE="http://sources.redhat.com/binutils/"
+SRC_URI="mirror://kernel/linux/devel/binutils/${P}.tar.bz2
+ mirror://kernel/linux/devel/binutils/test/${P}.tar.bz2
+ mirror://gentoo/${PN}-2.15.90.0.1-patches-${PATCHVER}.tar.bz2"
+
+LICENSE="GPL-2 | LGPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa ~amd64"
+IUSE="nls bootstrap build"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ !build? ( !bootstrap? ( dev-lang/perl ) )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # The prescott patch is not ready yet.
+ mkdir ${WORKDIR}/patch/skip
+ mv ${WORKDIR}/patch/05* ${WORKDIR}/patch/skip/
+
+ epatch ${WORKDIR}/patch
+
+
+ # Libtool is broken (Redhat).
+ for x in ${S}/opcodes/Makefile.{am,in}
+ do
+ cp ${x} ${x}.orig
+ gawk '
+ {
+ if ($0 ~ /LIBADD/)
+ gsub("../bfd/libbfd.la", "-L../bfd/.libs ../bfd/libbfd.la")
+
+ print
+ }' ${x}.orig > ${x}
+ rm -rf ${x}.orig
+ done
+}
+
+src_compile() {
+ # Generate borked binaries. Bug #6730
+ filter-flags "-fomit-frame-pointer -fssa"
+
+ local myconf=
+ [ ! -z "${CBUILD}" ] && myconf="--build=${CBUILD}"
+ use nls \
+ && myconf="${myconf} --without-included-gettext" \
+ || myconf="${myconf} --disable-nls"
+
+ # Filter CFLAGS=".. -O2 .." on arm
+ use arm && replace-flags -O? -O
+
+ # GCC 3.4 miscompiles binutils unless CFLAGS are conservative. See
+ # bug #47581 for more information.
+ # Travis Tilley <lv@gentoo.org>
+ has_version "=sys-devel/gcc-3.4*" && CFLAGS="-O2"
+
+
+ # Fix /usr/lib/libbfd.la
+ elibtoolize --portage
+
+ ./configure \
+ --enable-shared \
+ --enable-64-bit-bfd \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ ${myconf} \
+ || die
+
+ make configure-bfd || die
+ make headers -C bfd || die
+ emake tooldir="${ROOT}/usr/bin" all || die
+
+ if ! use build
+ then
+ if ! use bootstrap
+ then
+ # Nuke the manpages to recreate them (only use this if we have perl)
+ find . -name '*.1' -exec rm -f {} \; || :
+ fi
+ # Make the info pages (makeinfo included with gcc is used)
+ make info || die
+ fi
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ insinto /usr/include
+ doins include/libiberty.h
+
+ # c++filt is included with gcc -- what are these GNU people thinking?
+ # but not the manpage, so leave that!
+# We install it now, as gcc-3.3 do not have it any longer ...
+# rm -f ${D}/usr/bin/c++filt #${D}/usr/share/man/man1/c++filt*
+
+ # By default strip has a symlink going from /usr/${CHOST}/bin/strip to
+ # /usr/bin/strip we should reverse it:
+
+ rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
+ # The strip symlink gets created in the loop below
+
+ # By default ar, as, ld, nm, ranlib and strip are in two places; create
+ # symlinks. This will reduce the size of the tbz2 significantly. We also
+ # move all the stuff in /usr/bin to /usr/${CHOST}/bin and create the
+ # appropriate symlinks. Things are cleaner that way.
+ cd ${D}/usr/bin
+ local x=
+ for x in * strip
+ do
+ if [ ! -e ../${CHOST}/bin/${x} ]
+ then
+ mv ${x} ../${CHOST}/bin/${x}
+ else
+ rm -f ${x}
+ fi
+ ln -s ../${CHOST}/bin/${x} ${x}
+ done
+
+ if [ -n "${PROFILE_ARCH}" ] && \
+ [ "${PROFILE_ARCH/64}" != "${PROFILE_ARCH}" ]
+ then
+ dosym ${CHOST} /usr/${CHOST/-/64-}
+
+ for x in `ls ${D}/usr/${CHOST}/bin/`
+ do
+ [ ! -e "${D}/usr/bin/${CHOST}-${x}" ] && \
+ dosym ../${CHOST}/bin/${x} /usr/bin/${CHOST}-${x}
+ dosym ../${CHOST}/bin/${x} /usr/bin/${CHOST/-/64-}-${x}
+ done
+ fi
+
+ cd ${S}
+ if ! use build
+ then
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install-info || die
+
+ dodoc COPYING* README
+ docinto bfd
+ dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
+ docinto binutils
+ dodoc binutils/ChangeLog binutils/NEWS binutils/README
+ docinto gas
+ dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
+ docinto gprof
+ dodoc gprof/ChangeLog* gprof/TEST gprof/TODO
+ docinto ld
+ dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
+ docinto libiberty
+ dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
+ docinto opcodes
+ dodoc opcodes/ChangeLog*
+ # Install pre-generated manpages .. currently we do not ...
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+}
diff --git a/sys-devel/binutils/files/digest-binutils-2.15.90.0.1.1 b/sys-devel/binutils/files/digest-binutils-2.15.90.0.1.1
new file mode 100644
index 000000000000..895701018ef4
--- /dev/null
+++ b/sys-devel/binutils/files/digest-binutils-2.15.90.0.1.1
@@ -0,0 +1,2 @@
+MD5 d0427772ccbe68eefd40995d26ca4a78 binutils-2.15.90.0.1.1.tar.bz2 11068225
+MD5 5341c40010faa1684a0a497f479b9fa4 binutils-2.15.90.0.1-patches-1.0.tar.bz2 15329