summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-12-12 02:41:44 +0000
committerDaniel Goller <morfic@gentoo.org>2004-12-12 02:41:44 +0000
commit19975101b82b9cd627d36916b9d3689a6c38c4fb (patch)
tree8b020777363bb72e217778bdc16c01697e8077a6
parentversion bump which fixed gcc-3.4 compile. No need to patch any more. (Manifes... (diff)
downloadgentoo-2-19975101b82b9cd627d36916b9d3689a6c38c4fb.tar.gz
gentoo-2-19975101b82b9cd627d36916b9d3689a6c38c4fb.tar.bz2
gentoo-2-19975101b82b9cd627d36916b9d3689a6c38c4fb.zip
quicker fixer upper
-rw-r--r--dev-libs/boost/ChangeLog5
-rw-r--r--dev-libs/boost/boost-1.32.0.ebuild32
2 files changed, 18 insertions, 19 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 8b2bc4757f39..b6c6bcd01086 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.27 2004/12/11 19:22:34 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.28 2004/12/12 02:41:44 morfic Exp $
+
+ 11 Dec 2004; Daniel Goller <morfic@gentoo.org> boost-1.32.0.ebuild:
+ Cleanup + maintenance
11 Dec 2004; Daniel Goller <morfic@gentoo.org> boost-1.32.0.ebuild:
Removed trailing space
diff --git a/dev-libs/boost/boost-1.32.0.ebuild b/dev-libs/boost/boost-1.32.0.ebuild
index c0bd1007534e..aeb4047723d6 100644
--- a/dev-libs/boost/boost-1.32.0.ebuild
+++ b/dev-libs/boost/boost-1.32.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.32.0.ebuild,v 1.5 2004/12/11 19:22:34 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.32.0.ebuild,v 1.6 2004/12/12 02:41:44 morfic Exp $
# This ebuild was generated by Ebuilder v0.4.
@@ -17,37 +17,33 @@ IUSE="icc"
DEPEND="sys-devel/gcc
dev-lang/python"
KEYWORDS="~x86 ~ppc ~amd64 ~sparc ~ppc64"
+PYTHON_VERSION=$(/usr/bin/python -V 2>&1 | sed 's/Python \([0-9][0-9]*\.[0-9][0-9]*\)\..*/\1/')
-src_compile() {
- local PYTHON_VERSION=$(/usr/bin/python -V 2>&1 | sed 's/Python \([0-9][0-9]*\.[0-9][0-9]*\)\..*/\1/')
- local arch
-
- if [ "${ARCH}" == "amd64" ]; then
- arch=
- else
- arch=${ARCH}
- fi
+if [ "${ARCH}" == "amd64" ]; then
+ arch=
+else
+ arch=${ARCH}
+fi
- # Build bjam, a jam variant, which is used instead of make
+src_compile() {
cd ${S}/tools/build/jam_src
./build.sh || die "Failed to build bjam"
cd ${S}
# actual build
./tools/build/jam_src/bin.linux${arch}/bjam \
- -sBOOST_ROOT=${S} \
- -sPYTHON_ROOT=/usr \
- -sPYTHON_VERSION=${PYTHON_VERSION} \
- -sTOOLS=gcc \
+ -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYTHON_VERSION} \
+ -sTOOLS=gcc \
--prefix=${D}/usr \
--layout=system \
stage
+
}
src_install () {
- local PYTHON_VERSION=$(/usr/bin/python -V 2>&1 | sed 's/Python \([0-9][0-9]*\.[0-9][0-9]*\)\..*/\1/')
-
- ./tools/build/jam_src/bin.linux${arch}/bjam ${MAKEOPTS} \
+ /tools/build/jam_src/bin.linux${arch}/bjam ${MAKEOPTS} \
-sBOOST_ROOT=${S} \
-sPYTHON_ROOT=/usr \
-sPYTHON_VERSION=${PYTHON_VERSION} \