summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Rickard <frogger@gentoo.org>2003-04-11 05:35:52 +0000
committerMatt Rickard <frogger@gentoo.org>2003-04-11 05:35:52 +0000
commit1ba84a0d7b332c47cf9b5a28b23ef44247ab78f1 (patch)
treecd7ac0801fe3f83f075d79d4753e2e35b32224f3
parentMoving back to protector-4 (diff)
downloadgentoo-2-1ba84a0d7b332c47cf9b5a28b23ef44247ab78f1.tar.gz
gentoo-2-1ba84a0d7b332c47cf9b5a28b23ef44247ab78f1.tar.bz2
gentoo-2-1ba84a0d7b332c47cf9b5a28b23ef44247ab78f1.zip
Moving back to protector-4
-rw-r--r--sys-devel/gcc/ChangeLog8
-rw-r--r--sys-devel/gcc/files/3.2.2/protector.patch71
-rw-r--r--sys-devel/gcc/gcc-3.2.2-r3.ebuild4
-rw-r--r--sys-devel/gcc/manifest4
4 files changed, 20 insertions, 67 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 88c630d2fc53..f3ee1667a5f3 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.88 2003/04/10 18:54:53 frogger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.89 2003/04/11 05:35:39 frogger Exp $
24 Mar 2003; Martin Schlemmer <azarah@gentoo.org> :
- Fix latest ebuild to only build static if we are just building the C
@@ -36,6 +36,12 @@
*gcc-3.2.2-r3 (03 Mar 2003)
+ 11 Apr 2003; Matthew Rickard <frogger@gentoo.org> gcc-3.2.2-r3.ebuild,
+ manifest, files/3.2.2/protector.patch:
+ Downgraded ProPolice to protector-4. With Protector-5 GCC seems to
+ die on bootstrap with 1.4-rc4. It also seems to be the source of the
+ unresolved symbols seen previously. We'll stay with -4 for now.
+
10 Apr 2003; Matthew Rickard <frogger@gentoo.org> gcc-3.2.2-r3.ebuild,
manifest:
Removing -fstack-protector from ALLOWED_FLAGS. This leads
diff --git a/sys-devel/gcc/files/3.2.2/protector.patch b/sys-devel/gcc/files/3.2.2/protector.patch
index 4f86a0192a69..dba0941458e3 100644
--- a/sys-devel/gcc/files/3.2.2/protector.patch
+++ b/sys-devel/gcc/files/3.2.2/protector.patch
@@ -6,23 +6,6 @@ retrieving revision 1.1.1.12.2.1
diff -c -3 -p -r1.1.1.12 -r1.1.1.12.2.1
*** gcc/Makefile.in 2003/02/19 07:11:06 1.1.1.12
--- gcc/Makefile.in 2003/02/26 08:01:00 1.1.1.12.2.1
-*************** INSTALL_LIBGCC = install-libgcc
-*** 358,364 ****
- # Options to use when compiling libgcc2.a.
- #
- LIBGCC2_DEBUG_CFLAGS = -g
-! LIBGCC2_CFLAGS = -O2 $(LIBGCC2_INCLUDES) $(GCC_CFLAGS) $(TARGET_LIBGCC2_CFLAGS) $(LIBGCC2_DEBUG_CFLAGS) $(GTHREAD_FLAGS) -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED @inhibit_libc@
-
- # Additional options to use when compiling libgcc2.a.
- # Some targets override this to -isystem include
---- 358,364 ----
- # Options to use when compiling libgcc2.a.
- #
- LIBGCC2_DEBUG_CFLAGS = -g
-! LIBGCC2_CFLAGS = -O2 $(LIBGCC2_INCLUDES) $(GCC_CFLAGS) $(TARGET_LIBGCC2_CFLAGS) $(LIBGCC2_DEBUG_CFLAGS) $(GTHREAD_FLAGS) -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED @inhibit_libc@ -fno-stack-protector
-
- # Additional options to use when compiling libgcc2.a.
- # Some targets override this to -isystem include
*************** OBJS = alias.o bb-reorder.o bitmap.o bui
*** 728,734 ****
sibcall.o simplify-rtx.o ssa.o ssa-ccp.o ssa-dce.o stmt.o \
@@ -57,23 +40,6 @@ diff -c -3 -p -r1.1.1.12 -r1.1.1.12.2.1
# Defined in libgcc2.c, included only in the static library.
LIB2FUNCS_ST = _eprintf _bb __gcc_bcmp
-*************** toplev.o : toplev.c $(CONFIG_H) $(SYSTEM
-*** 1360,1366 ****
- ssa.h $(PARAMS_H) $(TM_P_H) reload.h dwarf2asm.h $(TARGET_H) halfpic.h \
- langhooks.h insn-flags.h options.h
- $(CC) $(ALL_CFLAGS) $(ALL_CPPFLAGS) $(INCLUDES) \
-! -DTARGET_NAME=\"$(target_alias)\" \
- -c $(srcdir)/toplev.c $(OUTPUT_OPTION)
- main.o : main.c $(CONFIG_H) $(SYSTEM_H) toplev.h
-
---- 1360,1366 ----
- ssa.h $(PARAMS_H) $(TM_P_H) reload.h dwarf2asm.h $(TARGET_H) halfpic.h \
- langhooks.h insn-flags.h options.h
- $(CC) $(ALL_CFLAGS) $(ALL_CPPFLAGS) $(INCLUDES) \
-! -DSTACK_PROTECTOR -DTARGET_NAME=\"$(target_alias)\" \
- -c $(srcdir)/toplev.c $(OUTPUT_OPTION)
- main.o : main.c $(CONFIG_H) $(SYSTEM_H) toplev.h
-
Index: gcc/calls.c
===================================================================
RCS file: /home/cvsroot/gcc/gcc/calls.c,v
@@ -268,10 +234,10 @@ Index: gcc/expr.c
===================================================================
RCS file: /home/cvsroot/gcc/gcc/expr.c,v
retrieving revision 1.1.1.11
-retrieving revision 1.1.1.11.2.2
-diff -c -3 -p -r1.1.1.11 -r1.1.1.11.2.2
+retrieving revision 1.1.1.11.2.1
+diff -c -3 -p -r1.1.1.11 -r1.1.1.11.2.1
*** gcc/expr.c 2003/02/19 07:11:13 1.1.1.11
---- gcc/expr.c 2003/04/07 02:36:16 1.1.1.11.2.2
+--- gcc/expr.c 2003/02/26 08:01:01 1.1.1.11.2.1
*************** Software Foundation, 59 Temple Place - S
*** 45,50 ****
--- 45,51 ----
@@ -380,25 +346,6 @@ diff -c -3 -p -r1.1.1.11 -r1.1.1.11.2.2
cst = (*data->constfun) (data->constfundata, data->offset, mode);
emit_insn ((*genfun) (to1, cst));
-*************** force_operand (value, target)
-*** 5474,5480 ****
- && GET_CODE (XEXP (value, 0)) == PLUS
- && GET_CODE (XEXP (XEXP (value, 0), 0)) == REG
- && REGNO (XEXP (XEXP (value, 0), 0)) >= FIRST_VIRTUAL_REGISTER
-! && REGNO (XEXP (XEXP (value, 0), 0)) <= LAST_VIRTUAL_REGISTER)
- {
- rtx temp = expand_simple_binop (GET_MODE (value), code,
- XEXP (XEXP (value, 0), 0), op2,
---- 5478,5486 ----
- && GET_CODE (XEXP (value, 0)) == PLUS
- && GET_CODE (XEXP (XEXP (value, 0), 0)) == REG
- && REGNO (XEXP (XEXP (value, 0), 0)) >= FIRST_VIRTUAL_REGISTER
-! && REGNO (XEXP (XEXP (value, 0), 0)) <= LAST_VIRTUAL_REGISTER
-! && (!flag_propolice_protection
-! || XEXP (XEXP (value, 0), 0) != virtual_stack_vars_rtx))
- {
- rtx temp = expand_simple_binop (GET_MODE (value), code,
- XEXP (XEXP (value, 0), 0), op2,
*************** expand_expr (exp, target, tmode, modifie
*** 7614,7620 ****
/* If adding to a sum including a constant,
@@ -408,7 +355,7 @@ diff -c -3 -p -r1.1.1.11 -r1.1.1.11.2.2
{
rtx constant_term = const0_rtx;
---- 7620,7627 ----
+--- 7618,7625 ----
/* If adding to a sum including a constant,
associate it to put the constant outside. */
if (GET_CODE (op1) == PLUS
@@ -693,10 +640,10 @@ Index: gcc/libgcc2.c
===================================================================
RCS file: /home/cvsroot/gcc/gcc/libgcc2.c,v
retrieving revision 1.1.1.7
-retrieving revision 1.1.1.7.4.3
-diff -c -3 -p -r1.1.1.7 -r1.1.1.7.4.3
+retrieving revision 1.1.1.7.4.2
+diff -c -3 -p -r1.1.1.7 -r1.1.1.7.4.2
*** gcc/libgcc2.c 2002/12/18 00:55:44 1.1.1.7
---- gcc/libgcc2.c 2003/04/07 02:03:19 1.1.1.7.4.3
+--- gcc/libgcc2.c 2003/03/17 13:22:49 1.1.1.7.4.2
*************** atexit (func_ptr func)
*** 2050,2052 ****
--- 2050,2151 ----
@@ -768,7 +715,7 @@ diff -c -3 -p -r1.1.1.7 -r1.1.1.7.4.3
+ strncat(buf, __progname, bufsz-len-1); len = strlen(buf);
+ #endif
+ if (bufsz>len) {strncat(buf, message, bufsz-len-1); len = strlen(buf);}
-+ if (bufsz>len) {strncat(buf, func, bufsz-len-1); len = strlen(buf);}
++ if (bufsz>len) strncat(buf, func, bufsz-len-1);
+
+ /* print error message */
+ write (STDERR_FILENO, buf+3, len-3);
@@ -782,7 +729,7 @@ diff -c -3 -p -r1.1.1.7 -r1.1.1.7.4.3
+ (void)strncpy(SyslogAddr.sun_path, _PATH_LOG,
+ sizeof(SyslogAddr.sun_path) - 1);
+ SyslogAddr.sun_path[sizeof(SyslogAddr.sun_path) - 1] = '\0';
-+ sendto(LogFile, buf, len, 0, (struct sockaddr *)&SyslogAddr,
++ sendto(LogFile, buf, strlen(buf), 0, (struct sockaddr *)&SyslogAddr,
+ sizeof(SyslogAddr));
+ }
+ #endif
diff --git a/sys-devel/gcc/gcc-3.2.2-r3.ebuild b/sys-devel/gcc/gcc-3.2.2-r3.ebuild
index 1dc9d06d4d05..9e74261623c6 100644
--- a/sys-devel/gcc/gcc-3.2.2-r3.ebuild
+++ b/sys-devel/gcc/gcc-3.2.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2-r3.ebuild,v 1.12 2003/04/10 18:54:53 frogger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2-r3.ebuild,v 1.13 2003/04/11 05:35:39 frogger Exp $
IUSE="static nls bootstrap java build"
@@ -183,7 +183,7 @@ src_unpack() {
epatch ${FILESDIR}/3.2.1/gcc32-strip-dotdot.patch
epatch ${FILESDIR}/3.2.1/gcc32-athlon-alignment.patch
- # ProPolice Stack Smashing protection - protector-3.2.2-5
+ # ProPolice Stack Smashing protection - protector-3.2.2-4
epatch ${FILESDIR}/3.2.2/protector.patch
cp ${FILESDIR}/3.2.2/protector.c ${WORKDIR}/${P}/gcc/ || die "protector.c not found"
cp ${FILESDIR}/3.2.2/protector.h ${WORKDIR}/${P}/gcc/ || die "protector.h not found"
diff --git a/sys-devel/gcc/manifest b/sys-devel/gcc/manifest
index a4752f26a0ec..96544fd2fb59 100644
--- a/sys-devel/gcc/manifest
+++ b/sys-devel/gcc/manifest
@@ -12,11 +12,11 @@ MD5 b8162a884971199cc4a538d2e484cdfe gcc-3.1.1-r1.ebuild 9636
MD5 133b092cbfeff595b0b793eab0c13a2e gcc-3.2.2.ebuild 15339
MD5 5a4475fa7fe0b65b070ad173457878d5 gcc-2.95.3-r8.ebuild 9170
MD5 da9e936766a9c4650965f9edabbc618d gcc-3.2-r5.ebuild 13126
-MD5 d689e7886b9a34b0288f0e8544eebddd gcc-3.2.2-r3.ebuild 16057
+MD5 8f8185c05cb178e91c52f2525234765b gcc-3.2.2-r3.ebuild 16057
MD5 396808683bbe6fe294fe6f803ec4e7a2 gcc-3.1-r8.ebuild 9803
MD5 4ca314ddb4dc31959140fa45137e4ec0 gcc-3.2.1-r6.ebuild 14406
MD5 31eaf707d3524543fefb3ff3d1f8af30 gcc-3.2.1-r1.ebuild 13025
-MD5 57685ee5013ad4789ea890701150f9dc ChangeLog 17860
+MD5 45a43daa1cd05b459a4d7e9417d7c902 ChangeLog 18184
MD5 d70bcc196f1d68275346f067efcb9373 files/cc 20
MD5 dcf3646d19d351cc4d95a8096c6eaf58 files/cpp 20
MD5 4a4be6eb294e00da7fef14ec597dcf13 files/digest-gcc-3.0.4-r6 128