summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Houser <chouser@gentoo.org>2002-02-25 00:46:08 +0000
committerChris Houser <chouser@gentoo.org>2002-02-25 00:46:08 +0000
commit3d34c537f1cd1dad153d035007286997889ef809 (patch)
tree923c75cfd41944d9db4f01797cc08274376ba7bc
parentnew revision - fix bug: when gnome is in use, both gtkbitchx and plain bitchx... (diff)
downloadgentoo-2-3d34c537f1cd1dad153d035007286997889ef809.tar.gz
gentoo-2-3d34c537f1cd1dad153d035007286997889ef809.tar.bz2
gentoo-2-3d34c537f1cd1dad153d035007286997889ef809.zip
Initial Gentoo package; thanks, Charles Kerr. Closes bug 124.
-rw-r--r--dev-libs/icu/ChangeLog10
-rw-r--r--dev-libs/icu/files/digest-icu-2.01
-rw-r--r--dev-libs/icu/icu-2.0.ebuild27
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/icu/ChangeLog b/dev-libs/icu/ChangeLog
new file mode 100644
index 000000000000..32b3314c85de
--- /dev/null
+++ b/dev-libs/icu/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.1 2002/02/25 00:46:08 chouser Exp $
+
+*icu-2.0 (24 Feb 2002)
+
+ 24 Feb 2002; Chris Houser <chouser@gentoo.org> icu-2.0.ebuild
+ files/digest-icu-2.0 ChangeLog :
+
+ Initial Gentoo package; thanks, Charles Kerr.
diff --git a/dev-libs/icu/files/digest-icu-2.0 b/dev-libs/icu/files/digest-icu-2.0
new file mode 100644
index 000000000000..5506ce76f572
--- /dev/null
+++ b/dev-libs/icu/files/digest-icu-2.0
@@ -0,0 +1 @@
+MD5 77a52af541c116aa9574677f949df5cb icu-2.0.tgz 7005552
diff --git a/dev-libs/icu/icu-2.0.ebuild b/dev-libs/icu/icu-2.0.ebuild
new file mode 100644
index 000000000000..a2e40b78f7b4
--- /dev/null
+++ b/dev-libs/icu/icu-2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Charles Kerr <punt@kerrskorner.org>
+# Maintainer: Chris Houser <chouser@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.build,v 1.11 2001/12/06 22:12:34 drobbins Exp
+
+S=${WORKDIR}/${PN}/source
+DESCRIPTION="IBM Internationalization Components for Unicode"
+SRC_URI="http://oss.software.ibm.com/icu/download/${PV}/${P}.tgz"
+HOMEPAGE="http://oss.software.ibm.com/icu/index.html"
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ ./configure \
+ --build=${CHOST} \
+ --enable-layout \
+ --prefix=/usr \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "make install failed"
+ dohtml ../readme.html ../license.html
+}