summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-25 16:06:53 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-25 16:06:53 +0000
commit614152aa8c1669b5809f78a61bda4735bc752a15 (patch)
tree381af94d3b83e0d3bd42eb68aa2f6a6bcff66cb5
parentQA - fix use invocation (Manifest recommit) (diff)
downloadgentoo-2-614152aa8c1669b5809f78a61bda4735bc752a15.tar.gz
gentoo-2-614152aa8c1669b5809f78a61bda4735bc752a15.tar.bz2
gentoo-2-614152aa8c1669b5809f78a61bda4735bc752a15.zip
glibc ----------------------------> libc !
-rw-r--r--app-admin/apg/apg-2.1.0.ebuild9
-rw-r--r--app-admin/apg/apg-2.2.3.ebuild8
-rw-r--r--app-admin/apg/apg-2.3.0b.ebuild8
-rw-r--r--app-admin/ccze/ccze-0.2.1.ebuild4
-rw-r--r--app-admin/chkrootkit/chkrootkit-0.37.ebuild5
-rw-r--r--app-admin/chkrootkit/chkrootkit-0.42b.ebuild13
-rw-r--r--app-admin/chkrootkit/chkrootkit-0.43.ebuild13
-rw-r--r--app-admin/cronolog/cronolog-1.6.2-r1.ebuild7
-rw-r--r--app-admin/cronolog/cronolog-1.6.2.ebuild7
9 files changed, 35 insertions, 39 deletions
diff --git a/app-admin/apg/apg-2.1.0.ebuild b/app-admin/apg/apg-2.1.0.ebuild
index 96d577d0b384..cdbd714cb1af 100644
--- a/app-admin/apg/apg-2.1.0.ebuild
+++ b/app-admin/apg/apg-2.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apg/apg-2.1.0.ebuild,v 1.5 2004/06/24 21:23:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apg/apg-2.1.0.ebuild,v 1.6 2004/06/25 16:04:19 vapier Exp $
DESCRIPTION="Another Password Generator"
HOMEPAGE="http://www.adel.nursat.kz/apg/"
@@ -11,8 +11,7 @@ SLOT="0"
KEYWORDS="x86 ppc"
IUSE=""
-RDEPEND=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_compile() {
cp Makefile Makefile.orig
@@ -22,9 +21,9 @@ src_compile() {
}
src_install() {
- exeinto /usr/bin ; doexe apg apgbfm
+ dobin apg apgbfm || die
dodoc CHANGES INSTALL README THANKS TODO
- cd ${S}/doc
+ cd doc
doman man/apg.1
dodoc APG_TIPS pronun.txt rfc0972.txt rfc1750.txt
}
diff --git a/app-admin/apg/apg-2.2.3.ebuild b/app-admin/apg/apg-2.2.3.ebuild
index 201c985207c5..d1699ab003d6 100644
--- a/app-admin/apg/apg-2.2.3.ebuild
+++ b/app-admin/apg/apg-2.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apg/apg-2.2.3.ebuild,v 1.4 2004/06/24 21:23:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apg/apg-2.2.3.ebuild,v 1.5 2004/06/25 16:04:19 vapier Exp $
DESCRIPTION="Another Password Generator"
HOMEPAGE="http://www.adel.nursat.kz/apg/"
@@ -11,7 +11,7 @@ SLOT="0"
KEYWORDS="x86 ~ppc ~sparc"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_compile() {
cp Makefile Makefile.orig
@@ -21,9 +21,9 @@ src_compile() {
}
src_install() {
- exeinto /usr/bin ; doexe apg apgbfm
+ dobin apg apgbfm || die
dodoc CHANGES INSTALL README THANKS TODO
- cd ${S}/doc
+ cd doc
doman man/apg.1
dodoc APG_TIPS pronun.txt rfc0972.txt rfc1750.txt
}
diff --git a/app-admin/apg/apg-2.3.0b.ebuild b/app-admin/apg/apg-2.3.0b.ebuild
index 2407cefaa9ee..595558945d94 100644
--- a/app-admin/apg/apg-2.3.0b.ebuild
+++ b/app-admin/apg/apg-2.3.0b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apg/apg-2.3.0b.ebuild,v 1.7 2004/06/24 21:23:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apg/apg-2.3.0b.ebuild,v 1.8 2004/06/25 16:04:19 vapier Exp $
DESCRIPTION="Another Password Generator"
HOMEPAGE="http://www.adel.nursat.kz/apg/"
@@ -11,7 +11,7 @@ SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc amd64"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
@@ -27,9 +27,9 @@ src_compile() {
}
src_install() {
- dobin apg apgbfm bfconvert/bfconvert
+ dobin apg apgbfm bfconvert/bfconvert || die
dodoc CHANGES INSTALL README THANKS TODO
- cd ${S}/doc
+ cd doc
doman man/apg.1 man/apgbfm.1
dodoc APG_TIPS pronun.txt rfc0972.txt rfc1750.txt
}
diff --git a/app-admin/ccze/ccze-0.2.1.ebuild b/app-admin/ccze/ccze-0.2.1.ebuild
index e96a9997ef1a..5fe624555a96 100644
--- a/app-admin/ccze/ccze-0.2.1.ebuild
+++ b/app-admin/ccze/ccze-0.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ccze/ccze-0.2.1.ebuild,v 1.6 2004/06/24 21:23:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ccze/ccze-0.2.1.ebuild,v 1.7 2004/06/25 16:04:48 vapier Exp $
DESCRIPTION="A flexible and fast logfile colorizer"
HOMEPAGE="http://bonehunter.rulez.org/CCZE.html"
@@ -11,7 +11,7 @@ SLOT="0"
KEYWORDS="x86 sparc"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
sys-libs/ncurses
dev-libs/libpcre"
diff --git a/app-admin/chkrootkit/chkrootkit-0.37.ebuild b/app-admin/chkrootkit/chkrootkit-0.37.ebuild
index fb336634e987..5c179929e709 100644
--- a/app-admin/chkrootkit/chkrootkit-0.37.ebuild
+++ b/app-admin/chkrootkit/chkrootkit-0.37.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/chkrootkit/chkrootkit-0.37.ebuild,v 1.16 2004/06/24 21:24:02 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chkrootkit/chkrootkit-0.37.ebuild,v 1.17 2004/06/25 16:06:10 vapier Exp $
inherit eutils
@@ -12,7 +12,8 @@ LICENSE="AMS"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha"
IUSE=""
-DEPEND="virtual/glibc"
+
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
diff --git a/app-admin/chkrootkit/chkrootkit-0.42b.ebuild b/app-admin/chkrootkit/chkrootkit-0.42b.ebuild
index 4a6dd540c51c..f3721c60b425 100644
--- a/app-admin/chkrootkit/chkrootkit-0.42b.ebuild
+++ b/app-admin/chkrootkit/chkrootkit-0.42b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/chkrootkit/chkrootkit-0.42b.ebuild,v 1.11 2004/06/24 21:24:02 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chkrootkit/chkrootkit-0.42b.ebuild,v 1.12 2004/06/25 16:06:10 vapier Exp $
inherit eutils flag-o-matic
@@ -13,14 +13,12 @@ SLOT="0"
KEYWORDS="x86 ~ppc sparc alpha ~ia64 amd64"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
cd ${S}
-
epatch ${FILESDIR}/${P}-gentoo.diff
-
sed -i 's:${head} -:${head} -n :' chkrootkit
}
@@ -31,8 +29,7 @@ src_compile() {
}
src_install() {
- into /usr
- dosbin check_wtmpx chklastlog chkproc chkrootkit chkwtmp ifpromisc
- newsbin strings strings-static
- dodoc COPYRIGHT README README.chklastlog README.chkwtmp
+ dosbin check_wtmpx chklastlog chkproc chkrootkit chkwtmp ifpromisc || die
+ newsbin strings strings-static || die
+ dodoc README README.chklastlog README.chkwtmp
}
diff --git a/app-admin/chkrootkit/chkrootkit-0.43.ebuild b/app-admin/chkrootkit/chkrootkit-0.43.ebuild
index 00c55d4a0e5c..b7bdd96e1c25 100644
--- a/app-admin/chkrootkit/chkrootkit-0.43.ebuild
+++ b/app-admin/chkrootkit/chkrootkit-0.43.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/chkrootkit/chkrootkit-0.43.ebuild,v 1.9 2004/06/24 21:24:02 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chkrootkit/chkrootkit-0.43.ebuild,v 1.10 2004/06/25 16:06:10 vapier Exp $
inherit eutils
@@ -13,14 +13,12 @@ SLOT="0"
KEYWORDS="x86 ~ppc sparc alpha ~ia64 amd64"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
cd ${S}
-
epatch ${FILESDIR}/${P}-gentoo.diff
-
sed -i 's:${head} -:${head} -n :' chkrootkit
}
@@ -30,8 +28,7 @@ src_compile() {
}
src_install() {
- into /usr
- dosbin check_wtmpx chklastlog chkproc chkrootkit chkwtmp ifpromisc
- newsbin strings strings-static
- dodoc COPYRIGHT README README.chklastlog README.chkwtmp
+ dosbin check_wtmpx chklastlog chkproc chkrootkit chkwtmp ifpromisc || die
+ newsbin strings strings-static || die
+ dodoc README README.chklastlog README.chkwtmp
}
diff --git a/app-admin/cronolog/cronolog-1.6.2-r1.ebuild b/app-admin/cronolog/cronolog-1.6.2-r1.ebuild
index 773cffa65daa..4a44525b9a02 100644
--- a/app-admin/cronolog/cronolog-1.6.2-r1.ebuild
+++ b/app-admin/cronolog/cronolog-1.6.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/cronolog/cronolog-1.6.2-r1.ebuild,v 1.6 2004/06/24 21:24:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cronolog/cronolog-1.6.2-r1.ebuild,v 1.7 2004/06/25 16:06:53 vapier Exp $
inherit eutils
@@ -13,8 +13,9 @@ SLOT="0"
KEYWORDS="x86 ~ppc amd64"
IUSE=""
-DEPEND="virtual/glibc"
-RDEPEND="${DEPEND} net-www/apache"
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}
+ net-www/apache"
src_unpack() {
local a
diff --git a/app-admin/cronolog/cronolog-1.6.2.ebuild b/app-admin/cronolog/cronolog-1.6.2.ebuild
index 875e6cad6561..ac986c2da560 100644
--- a/app-admin/cronolog/cronolog-1.6.2.ebuild
+++ b/app-admin/cronolog/cronolog-1.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/cronolog/cronolog-1.6.2.ebuild,v 1.8 2004/06/24 21:24:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cronolog/cronolog-1.6.2.ebuild,v 1.9 2004/06/25 16:06:53 vapier Exp $
DESCRIPTION="Cronolog apache logfile rotator"
HOMEPAGE="http://cronolog.org/"
@@ -11,8 +11,9 @@ SLOT="0"
KEYWORDS="x86 ~ppc ~ia64"
IUSE=""
-DEPEND="virtual/glibc"
-RDEPEND="${DEPEND} net-www/apache"
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}
+ net-www/apache"
src_install() {
make DESTDIR=${D} install || die