summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Reisch <doctomoe@gentoo.org>2003-02-04 10:26:54 +0000
committerOlivier Reisch <doctomoe@gentoo.org>2003-02-04 10:26:54 +0000
commit776714d0870c6d81ae7caf7dad777debbe3d9497 (patch)
tree9d42ff99c37f2e4c23719021bdfe2fbaf4c32cc8
parentadding 2.0.46-r11 in (diff)
downloadgentoo-2-776714d0870c6d81ae7caf7dad777debbe3d9497.tar.gz
gentoo-2-776714d0870c6d81ae7caf7dad777debbe3d9497.tar.bz2
gentoo-2-776714d0870c6d81ae7caf7dad777debbe3d9497.zip
Initial release of ppc-sources-crypto
-rw-r--r--sys-kernel/ppc-sources-crypto/ChangeLog9
-rw-r--r--sys-kernel/ppc-sources-crypto/files/digest-ppc-sources-crypto-2.4.201
-rw-r--r--sys-kernel/ppc-sources-crypto/ppc-sources-crypto-2.4.20.ebuild113
3 files changed, 123 insertions, 0 deletions
diff --git a/sys-kernel/ppc-sources-crypto/ChangeLog b/sys-kernel/ppc-sources-crypto/ChangeLog
new file mode 100644
index 000000000000..a1e425cd9cf9
--- /dev/null
+++ b/sys-kernel/ppc-sources-crypto/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-kernel/ppc-sources-crypto
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc-sources-crypto/ChangeLog,v 1.1 2003/02/04 10:26:54 doctomoe Exp $
+
+*ppc-sources-crypto-2.4.20 (03 Feb 2003)
+
+ 03 Feb 2003; Olivier Reisch <doctomoe@gentoo.org> all:
+ First ppc crypto kernel release. Basically a 2.4.20-ben5 with
+ cryptoapi-0.1.0, cryptoloop 0.0.1-pre1 and loop-jari patch for 2.4.20
diff --git a/sys-kernel/ppc-sources-crypto/files/digest-ppc-sources-crypto-2.4.20 b/sys-kernel/ppc-sources-crypto/files/digest-ppc-sources-crypto-2.4.20
new file mode 100644
index 000000000000..3089021840ea
--- /dev/null
+++ b/sys-kernel/ppc-sources-crypto/files/digest-ppc-sources-crypto-2.4.20
@@ -0,0 +1 @@
+MD5 5c74ec29e69e4eb8b5b5229a26a7a9a5 linux-ppc-crypto-2.4.20.tar.bz2 27628151
diff --git a/sys-kernel/ppc-sources-crypto/ppc-sources-crypto-2.4.20.ebuild b/sys-kernel/ppc-sources-crypto/ppc-sources-crypto-2.4.20.ebuild
new file mode 100644
index 000000000000..320e5eb4407e
--- /dev/null
+++ b/sys-kernel/ppc-sources-crypto/ppc-sources-crypto-2.4.20.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc-sources-crypto/ppc-sources-crypto-2.4.20.ebuild,v 1.1 2003/02/04 10:26:54 doctomoe Exp $
+
+IUSE="build crypt"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+OKV=2.4.20
+KV=2.4.20
+S=${WORKDIR}/linux-ppc-crypto-${KV}
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+#inherit kernel || die
+
+DESCRIPTION="Full cryptoapi enabled sources for the Gentoo Linux PPC kernel"
+SRC_URI="http://perso.wanadoo.fr/olivier.reisch/linux-ppc-crypto/linux-ppc-crypto-${OKV}.tar.bz2"
+KEYWORDS="-x86 ~ppc -sparc -alpha"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.kerneli.org/ http://www.gentoo.org/"
+LICENSE="GPL-2"
+SLOT="${KV}"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl
+ >=sys-apps/modutils-2.4.2 sys-devel/make"
+fi
+
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack linux-ppc-crypto-${OKV}.tar.bz2
+ cd ${S}
+ pwd
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ cd ${S}
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ make dep
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-ppc/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux ]
+ then
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-ppc-crypto-${KV} ${ROOT}/usr/src/linux
+ fi
+ [ `use xfs` ] && ewarn "XFS is no longer included!"
+}