summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-11-30 09:59:48 +0000
committerChris White <chriswhite@gentoo.org>2005-11-30 09:59:48 +0000
commit7fc4e33f94a86564b34c5a9280f836d1add5e8b1 (patch)
tree0cb6b6b6b1a25e7e958fd4b98190e5e54203ad9a
parent*** empty log message *** (diff)
downloadgentoo-2-7fc4e33f94a86564b34c5a9280f836d1add5e8b1.tar.gz
gentoo-2-7fc4e33f94a86564b34c5a9280f836d1add5e8b1.tar.bz2
gentoo-2-7fc4e33f94a86564b34c5a9280f836d1add5e8b1.zip
-rw-r--r--app-admin/rackview/files/digest-rackview-0.091
-rw-r--r--app-admin/rackview/rackview-0.09.ebuild43
-rw-r--r--eclass/date.log2
-rw-r--r--media-video/winki/files/digest-winki-0.3.111
-rw-r--r--media-video/winki/files/winki-0.3.8.patch17
-rw-r--r--media-video/winki/winki-0.3.11.ebuild58
-rw-r--r--sys-apps/gmemusage/Manifest3
-rw-r--r--sys-apps/gmemusage/files/digest-gmemusage-0.21
-rw-r--r--sys-apps/gmemusage/files/gmemusage-0.2-gentoo.patch105
-rw-r--r--sys-apps/gmemusage/gmemusage-0.2-old.ebuild38
-rw-r--r--sys-apps/gmemusage/gmemusage-0.2.ebuild47
11 files changed, 316 insertions, 0 deletions
diff --git a/app-admin/rackview/files/digest-rackview-0.09 b/app-admin/rackview/files/digest-rackview-0.09
new file mode 100644
index 000000000000..571d3934b9db
--- /dev/null
+++ b/app-admin/rackview/files/digest-rackview-0.09
@@ -0,0 +1 @@
+MD5 b332d97da67180631676bfd3ebabc2c5 rackview-0.09.tar.gz 1023175
diff --git a/app-admin/rackview/rackview-0.09.ebuild b/app-admin/rackview/rackview-0.09.ebuild
new file mode 100644
index 000000000000..7939e74b1ee9
--- /dev/null
+++ b/app-admin/rackview/rackview-0.09.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/rackview/rackview-0.09.ebuild,v 1.1.1.1 2005/11/30 09:59:48 chriswhite Exp $
+
+inherit perl-module webapp
+
+DESCRIPTION="Generate HTML page displaying computer rack layout"
+HOMEPAGE="http://rackview.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ >=dev-perl/Config-Simple-4.1
+ >=dev-perl/GD-1.41
+ >=dev-perl/Eidetic-2
+ >=perl-core/File-Spec-0.83
+ >=perl-core/File-Temp-0.12"
+RDEPEND=""
+
+src_install() {
+ webapp_src_preinst
+ perl-module_src_install
+
+ insinto ${MY_HTDOCSDIR}
+ doins example/index.html example/top_view.png example/top_view.svg
+ doins images
+
+ insinto ${MY_CGIBINDIR}
+ doins cgi-bin/*
+
+ insinto /etc/eidetic
+ doins example/example.dat
+
+ insinto /etc/rackview
+ doins etc/*
+
+ dodoc doc/*
+
+ webapp_src_install
+}
diff --git a/eclass/date.log b/eclass/date.log
new file mode 100644
index 000000000000..6db885e0fae1
--- /dev/null
+++ b/eclass/date.log
@@ -0,0 +1,2 @@
+2005年 9月 23日 金曜日 21:18:29 JST
+2005年 9月 23日 金曜日 21:20:24 JST
diff --git a/media-video/winki/files/digest-winki-0.3.11 b/media-video/winki/files/digest-winki-0.3.11
new file mode 100644
index 000000000000..6401b01384c3
--- /dev/null
+++ b/media-video/winki/files/digest-winki-0.3.11
@@ -0,0 +1 @@
+MD5 ceb8ef52dd6a74f0869cee004bf3f8dc winki-0.3.11.tar.gz 712452
diff --git a/media-video/winki/files/winki-0.3.8.patch b/media-video/winki/files/winki-0.3.8.patch
new file mode 100644
index 000000000000..ac2ad1ab3a1d
--- /dev/null
+++ b/media-video/winki/files/winki-0.3.8.patch
@@ -0,0 +1,17 @@
+diff -Nuar winki-0.3.8/setup.py winki-0.3.8-patched/setup.py
+--- winki-0.3.8/setup.py 2004-11-23 17:33:57.000000000 +0000
++++ winki-0.3.8-patched/setup.py 2004-11-26 13:17:43.093890224 +0000
+@@ -33,13 +33,6 @@
+ dest_icon = os.path.join('/', 'usr', 'share', 'pixmaps')
+ dest_desktop = os.path.join('/', 'usr', 'share', 'applications')
+
+-try:
+- src = os.path.join('/', 'etc', 'winkirc')
+- dst = os.path.join('/', 'etc', 'winkirc.old')
+- os.rename(src, dst)
+-except:
+- pass
+-
+ setup( name = 'winki',
+ version = '0.3.8',
+ description = 'GTK frontend to mencoder, mplayer and lsdvd',
diff --git a/media-video/winki/winki-0.3.11.ebuild b/media-video/winki/winki-0.3.11.ebuild
new file mode 100644
index 000000000000..3fa02fdab4e4
--- /dev/null
+++ b/media-video/winki/winki-0.3.11.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/winki/winki-0.3.11.ebuild,v 1.1.1.1 2005/11/30 09:57:32 chriswhite Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="A Python frontend to many popular encoding programs."
+HOMEPAGE="http://www.winki-the-ripper.de/"
+
+SRC_URI="http://www.winki-the-ripper.de/share/dist/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~ppc ~x86"
+IUSE="css mastroska mp3 ogg vcd vorbis"
+DEPEND=">=dev-lang/python-2.3
+ >=dev-python/gnome-python-2
+ >=dev-python/pygtk-2
+ >=dev-python/pyorbit-2"
+RDEPEND="${DEPEND}
+ media-video/mplayer
+ media-video/lsdvd
+ ogg? (media-sound/ogmtools
+ media-sound/vorbis-tools)
+ matroska? ( media-video/mkvtoolnix )
+ vcd? ( media-libs/libdvb
+ media-video/vcdimager )
+ mp3? ( media-sound/lame )
+ vorbis? ( media-sound/vorbis-tools )"
+
+pkg_setup() {
+ if ! use ogg && ! use matroska; then
+ ewarn "You should specify either the 'ogg' (to use ogmtools)"
+ ewarn "or 'matroska' (to use mkvtoolnix) USE flag. You may"
+ ewarn "ignore this warning if at least one of these packages"
+ ewarn "is already installed."
+ fi
+
+ if ! use vorbis && ! use mp3; then
+ ewarn "You need to specify either the 'vorbis' (to use oggenc)"
+ ewarn "or 'mp3' (to use lame) USE flag (or both) to enable audio"
+ ewarn "encoding in Winki. You may ignore this warning if at"
+ ewarn "least one of these tools is already installed."
+ fi
+
+ if use css && ! built_with_use mplayer dvdread; then
+ ewarn "If you want CSS support in Winki, you must rebuild"
+ ewarn "mplayer with the 'dvdread' USE flag."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # fixes a sandbox violation
+ epatch ${FILESDIR}/${P}.patch
+}
diff --git a/sys-apps/gmemusage/Manifest b/sys-apps/gmemusage/Manifest
new file mode 100644
index 000000000000..24c2b84c8344
--- /dev/null
+++ b/sys-apps/gmemusage/Manifest
@@ -0,0 +1,3 @@
+MD5 0ca7007f9ef35e838cad5da804adc32f gmemusage-0.2.ebuild 1203
+MD5 22ec727a0ec4602874a94a0a15095858 files/digest-gmemusage-0.2 68
+MD5 37794dad03f7d6f57d8371956d248021 files/gmemusage-0.2-gentoo.patch 3064
diff --git a/sys-apps/gmemusage/files/digest-gmemusage-0.2 b/sys-apps/gmemusage/files/digest-gmemusage-0.2
new file mode 100644
index 000000000000..a17e3208158e
--- /dev/null
+++ b/sys-apps/gmemusage/files/digest-gmemusage-0.2
@@ -0,0 +1 @@
+MD5 98fccb8a1730830685e52e1f73ae1c34 gmemusage-0.2-082599.tgz 30129
diff --git a/sys-apps/gmemusage/files/gmemusage-0.2-gentoo.patch b/sys-apps/gmemusage/files/gmemusage-0.2-gentoo.patch
new file mode 100644
index 000000000000..4fef1ffeaa17
--- /dev/null
+++ b/sys-apps/gmemusage/files/gmemusage-0.2-gentoo.patch
@@ -0,0 +1,105 @@
+diff -ur gmemusage-0.2/gmemusage.h gmemusage-0.2-patched/gmemusage.h
+--- gmemusage-0.2/gmemusage.h 1999-08-25 21:23:52.000000000 -0600
++++ gmemusage-0.2-patched/gmemusage.h 2005-09-16 02:43:19.000000000 -0600
+@@ -30,8 +30,8 @@
+ void list (void);
+ void drawstring (int x, int y, char *str);
+ void drawstringfixed (int x, int y, char *str);
+-void drawstringright (int x, int y, char *str, float width);
+-void drawstringcenter (int x, int y, char *str, float width);
++void drawstringright (int x, int y, const char *str, float width);
++void drawstringcenter (int x, int y, const char *str, float width);
+ void refresh (int );
+ void display (void);
+ void mouseClick (int button, int state, int x, int y);
+diff -ur gmemusage-0.2/util.c gmemusage-0.2-patched/util.c
+--- gmemusage-0.2/util.c 1999-08-25 21:23:52.000000000 -0600
++++ gmemusage-0.2-patched/util.c 2005-09-16 02:43:55.000000000 -0600
+@@ -26,11 +26,15 @@
+ */
+
+ #include <GL/glut.h>
++#include <string.h>
+
+ #include "TexFont.h"
+
+ #include "enum.h"
+ #include "extern.h"
++#include <string.h>
++#include <stdlib.h>
++
+
+ /*--------------------------------------------------------*/
+ void drawstring (int x, int y, char *str)
+@@ -89,17 +93,18 @@
+ }
+
+ /*--------------------------------------------------------*/
+-void drawstringright (int x, int y, char *str, float width)
++void drawstringright (int x, int y, const char *str, float width)
+ {
+ int len, i;
+
+
+ len = strlen(str);
++ char *str_ = strdup(str);
+
+ switch(g_drawText)
+ {
+ case BitmapText:
+- glRasterPos2f(x+(width-glutBitmapLength(GLUT_BITMAP_HELVETICA_12, str)), y);
++ glRasterPos2f(x+(width-glutBitmapLength(GLUT_BITMAP_HELVETICA_12, (const unsigned char*)str)), y);
+ for (i=0; i<len; i++)
+ glutBitmapCharacter(GLUT_BITMAP_HELVETICA_12, str[i]);
+ break;
+@@ -107,28 +112,31 @@
+ glEnable(GL_TEXTURE_2D);
+ glPushMatrix();
+ glTranslatef((float)x, (float)y, 0);
+- txfRenderStringRightJustify(helv_txf, str, len, width);
++ txfRenderStringRightJustify(helv_txf, str_, len, width);
+ glPopMatrix();
+ glDisable(GL_TEXTURE_2D);
+ break;
+ default:
+ break;
+ }
++
++ free(str_);
+ }
+
+
+ /*--------------------------------------------------------*/
+-void drawstringcenter (int x, int y, char *str, float width)
++void drawstringcenter (int x, int y, const char *str, float width)
+ {
+ int len, i;
+
+
+ len = strlen(str);
++ char *str_ = strdup(str);
+
+ switch(g_drawText)
+ {
+ case BitmapText:
+- glRasterPos2f(x+(width-glutBitmapLength(GLUT_BITMAP_HELVETICA_12, str))/2, y);
++ glRasterPos2f(x+(width-glutBitmapLength(GLUT_BITMAP_HELVETICA_12, (const unsigned char*)str))/2, y);
+ for (i=0; i<len; i++)
+ glutBitmapCharacter(GLUT_BITMAP_HELVETICA_12, str[i]);
+ break;
+@@ -136,12 +144,14 @@
+ glEnable(GL_TEXTURE_2D);
+ glPushMatrix();
+ glTranslatef(x, y, 0);
+- txfRenderStringCenterJustify(helv_txf, str, len, width);
++ txfRenderStringCenterJustify(helv_txf, str_, len, width);
+ glPopMatrix();
+ glDisable(GL_TEXTURE_2D);
+ break;
+ default:
+ break;
+ }
++
++ free(str_);
+ }
+
diff --git a/sys-apps/gmemusage/gmemusage-0.2-old.ebuild b/sys-apps/gmemusage/gmemusage-0.2-old.ebuild
new file mode 100644
index 000000000000..3c6a477f37d5
--- /dev/null
+++ b/sys-apps/gmemusage/gmemusage-0.2-old.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gmemusage/gmemusage-0.2-old.ebuild,v 1.1.1.1 2005/11/30 09:56:01 chriswhite Exp $
+
+# I need to get md5s from the author.
+# I have personally audited this code for malicious crap and will
+# state that there is nothing obvious. RiverRat (small program)
+
+DESCRIPTION="gmemusage is based on the very useful SGI IRIX utility of the same name."
+HOMEPAGE="http://www.reptilelabour.com/software/gmemusage/index.htm"
+SRC_URI="http://www.reptilelabour.com/software/files/${PN}/${P}-082599.tgz"
+
+inherit eutils
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="${RDEPEND}"
+
+RDEPEND="virtual/x11
+ virtual/opengl"
+
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gentoo.patch || die "patch failed"
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin gmemusage
+ dodoc README COPYING
+}
diff --git a/sys-apps/gmemusage/gmemusage-0.2.ebuild b/sys-apps/gmemusage/gmemusage-0.2.ebuild
new file mode 100644
index 000000000000..fb8a6550a582
--- /dev/null
+++ b/sys-apps/gmemusage/gmemusage-0.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gmemusage/gmemusage-0.2.ebuild,v 1.1.1.1 2005/11/30 09:56:01 chriswhite Exp $
+
+# I need to get md5s from the author.
+# I have personally audited this code for malicious crap and will
+# state that there is nothing obvious. RiverRat (small program)
+
+DESCRIPTION="gmemusage is based on the very useful SGI IRIX utility of the same name."
+HOMEPAGE="http://www.reptilelabour.com/software/gmemusage/index.htm"
+SRC_URI="http://www.reptilelabour.com/software/files/${PN}/${P}-082599.tgz"
+
+inherit eutils
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="${RDEPEND}"
+
+RDEPEND="media-libs/glut
+ virtual/x11
+ virtual/opengl"
+
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch ${FILESDIR}/${P}-gentoo.patch || die "patch failed"
+
+ # custom cflags...
+ # multi-lib fix...
+ sed -i \
+ -e "s:^CFLAGS.*:CFLAGS = ${CFLAGS} -DLINUX:g" \
+ -e "s:^LIBS = -L/usr/X11R6/lib:LIBS = -L/usr/X11R6/$(get_libdir):g" \
+ Makefile || die "sed-ing failed"
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin gmemusage
+ dodoc README
+}