summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-11-17 18:25:03 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-11-17 18:25:03 +0000
commit9cdf6730cad6efc5c5ff6feca584a678926e322e (patch)
tree91711bbec671729c194b98712fe0e7c9228055e9
parentfixed lintool warnings (diff)
downloadgentoo-2-9cdf6730cad6efc5c5ff6feca584a678926e322e.tar.gz
gentoo-2-9cdf6730cad6efc5c5ff6feca584a678926e322e.tar.bz2
gentoo-2-9cdf6730cad6efc5c5ff6feca584a678926e322e.zip
fix awk module compile if bootstrap in USE
-rw-r--r--sys-apps/baselayout/baselayout-1.8.5.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/sys-apps/baselayout/baselayout-1.8.5.ebuild b/sys-apps/baselayout/baselayout-1.8.5.ebuild
index a872d5d078ac..ad108170dca4 100644
--- a/sys-apps/baselayout/baselayout-1.8.5.ebuild
+++ b/sys-apps/baselayout/baselayout-1.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.8.5.ebuild,v 1.1 2002/11/17 17:16:01 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.8.5.ebuild,v 1.2 2002/11/17 18:25:03 azarah Exp $
IUSE="bootstrap build"
@@ -110,14 +110,17 @@ src_compile() {
einfo "Building sysvinit..."
emake LDFLAGS="" || die "problem compiling sysvinit"
- # Build gawk module
- cd ${S}/src
- einfo "Building awk module..."
- make || {
- eerror "Failed to build gawk module. Make sure you have"
- eerror "sys-apps/gawk-3.1.1-r1 or later installed"
- die "problem compiling gawk module"
- }
+ if [ -z "`use bootstrap`" ]
+ then
+ # Build gawk module
+ cd ${S}/src
+ einfo "Building awk module..."
+ make || {
+ eerror "Failed to build gawk module. Make sure you have"
+ eerror "sys-apps/gawk-3.1.1-r1 or later installed"
+ die "problem compiling gawk module"
+ }
+ fi
fi
}