summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWout Mertens <wmertens@gentoo.org>2003-05-04 13:19:50 +0000
committerWout Mertens <wmertens@gentoo.org>2003-05-04 13:19:50 +0000
commitb0d6d5ce92348b264c74f8d578229f3b6d2f3101 (patch)
tree300e8780e10d044622dd097543b876001598d360
parentVersion bump (diff)
downloadgentoo-2-b0d6d5ce92348b264c74f8d578229f3b6d2f3101.tar.gz
gentoo-2-b0d6d5ce92348b264c74f8d578229f3b6d2f3101.tar.bz2
gentoo-2-b0d6d5ce92348b264c74f8d578229f3b6d2f3101.zip
Version bump, fix #20072
-rw-r--r--sys-apps/thinkpad/ChangeLog10
-rw-r--r--sys-apps/thinkpad/files/digest-thinkpad-4.31
-rw-r--r--sys-apps/thinkpad/thinkpad-4.3.ebuild67
-rw-r--r--sys-apps/tpctl/ChangeLog8
-rw-r--r--sys-apps/tpctl/files/digest-tpctl-4.41
-rw-r--r--sys-apps/tpctl/tpctl-4.4.ebuild54
6 files changed, 137 insertions, 4 deletions
diff --git a/sys-apps/thinkpad/ChangeLog b/sys-apps/thinkpad/ChangeLog
index 0d05587f3773..848ea0693461 100644
--- a/sys-apps/thinkpad/ChangeLog
+++ b/sys-apps/thinkpad/ChangeLog
@@ -1,13 +1,19 @@
# ChangeLog for sys-apps/thinkpad
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/ChangeLog,v 1.6 2003/02/24 22:34:59 dragon Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/ChangeLog,v 1.7 2003/05/04 13:19:50 wmertens Exp $
+
+*thinkpad-4.3 (04 May 2003)
+
+ 04 May 2003; Wout Mertens <wmertens@gentoo.org> thinkpad-4.3.ebuild :
+ version bump, fixing #20072. Also improved kernel stuff and discovered
+ the /etc/devfs.d directory
*thinkpad-4.1 (17 Feb 2003)
24 Feb 2003; Nicholas Wourms <dragon@gentoo.org> thinkpad-4.1.ebuild :
This is definitely not for mips.
- 17 Feb 2003); Wout Mertens <wmertens@gentoo.org>:
+ 17 Feb 2003; Wout Mertens <wmertens@gentoo.org>:
version bump and correct kernel version detection
*thinkpad-3.2 (25 April 2002)
diff --git a/sys-apps/thinkpad/files/digest-thinkpad-4.3 b/sys-apps/thinkpad/files/digest-thinkpad-4.3
new file mode 100644
index 000000000000..53dacb1f3fe8
--- /dev/null
+++ b/sys-apps/thinkpad/files/digest-thinkpad-4.3
@@ -0,0 +1 @@
+MD5 af8dfd6e1529ee07620c2e4f11f05702 thinkpad_4.3.tar.gz 84492
diff --git a/sys-apps/thinkpad/thinkpad-4.3.ebuild b/sys-apps/thinkpad/thinkpad-4.3.ebuild
new file mode 100644
index 000000000000..43fa8d48df39
--- /dev/null
+++ b/sys-apps/thinkpad/thinkpad-4.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/thinkpad-4.3.ebuild,v 1.1 2003/05/04 13:19:50 wmertens Exp $
+
+#transform P to match tarball versioning
+MYPV=${PV/_beta/beta}
+MYP="${PN}_${MYPV}"
+DESCRIPTION="Thinkpad system control kernel modules"
+SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
+HOMEPAGE="http://tpctl.sourceforge.net/tpctlhome.htm"
+KEYWORDS="~x86 -ppc -mips -sparc"
+SLOT="0"
+LICENSE="GPL-2"
+
+#virtual/glibc should depend on specific kernel headers
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ check_KV
+ unpack ${A} || die
+ cd ${S}
+
+ # Use the correct drivers for your kernel. The standard distro comes
+ # with 2.5.
+ mkdir 2.5
+ mv drivers include 2.5
+ # Use your kernel version to build.
+ local ver=${KV:0:3} # first 3 chars of $KV, thank you bash :)
+ ln -s $ver/drivers drivers
+ ln -s $ver/include include
+}
+
+src_compile() {
+ check_KV
+ emake DIR_MOD_VER=/lib/modules/${KV} || die "Make failed"
+}
+
+src_install() {
+ dodoc AUTHORS COPYING ChangeLog README SUPPORTED-MODELS TECHNOTES
+ dodir /lib/modules/${KV}/thinkpad
+ cp ${S}/drivers/{thinkpad,smapi,superio,rtcmosram,thinkpadpm}.o \
+ ${D}/lib/modules/${KV}/thinkpad
+ dodir /etc/modules.d
+ sed 's/%KV%/'${KV}'/g' ${FILESDIR}/thinkpad > ${D}/etc/modules.d/thinkpad
+ dodir /etc/devfs.d
+ echo 'REGISTER ^thinkpad/.*$ PERMISSIONS root.thinkpad 0664' \
+ > ${D}/etc/devfs.d/thinkpad
+}
+
+pkg_postinst() {
+ /usr/sbin/update-modules || return 0
+ if ! grep -q '^ *INCLUDE.*devfs\.d' /etc/devfsd.conf; then
+ ewarn 'Your /etc/devfsd.conf is missing the include for'
+ ewarn '/etc/devfs.d/! Please fix this by adding'
+ ewarn 'INCLUDE /etc/devfs.d'
+ ewarn 'to your /etc/devfs.conf'
+ fi
+ if grep -q thinkpad /etc/devfsd.conf; then
+ ewarn 'The thinkpad devfsd entry has moved to'
+ ewarn '/etc/devfs.d/thinkpad, so you can remove it from'
+ ewarn '/etc/devfsd.conf if you like.'
+ fi
+}
+
+pkg_prerm() {
+ /sbin/modprobe -r smapi superion rtcmosram thinkpadpm thinkpad
+}
diff --git a/sys-apps/tpctl/ChangeLog b/sys-apps/tpctl/ChangeLog
index 609be3887867..a591650473ea 100644
--- a/sys-apps/tpctl/ChangeLog
+++ b/sys-apps/tpctl/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for sys-apps/tpctl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tpctl/ChangeLog,v 1.5 2003/02/17 16:17:07 wmertens Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tpctl/ChangeLog,v 1.6 2003/05/04 13:18:17 wmertens Exp $
+*tpctl-4.4 (04 May 2003)
+ 17 Feb 2003; Wout Mertens (wmertens@gentoo.org) tpctl-4.4.ebuild :
+ Version bump, fixing #20072
+
*tpctl-4.2 (17 Feb 2003)
- 17 Feb 2003; Wout Mertens (wmertens@gentoo.org):
+ 17 Feb 2003; Wout Mertens (wmertens@gentoo.org) tpctl-4.2.ebuild :
Version bump
*tpctl-3.2 (25 April 2002)
diff --git a/sys-apps/tpctl/files/digest-tpctl-4.4 b/sys-apps/tpctl/files/digest-tpctl-4.4
new file mode 100644
index 000000000000..53fc926f7e1d
--- /dev/null
+++ b/sys-apps/tpctl/files/digest-tpctl-4.4
@@ -0,0 +1 @@
+MD5 658968fac5f02ebc6f64c3750b52fc44 tpctl_4.4.tar.gz 83113
diff --git a/sys-apps/tpctl/tpctl-4.4.ebuild b/sys-apps/tpctl/tpctl-4.4.ebuild
new file mode 100644
index 000000000000..f808fd756fed
--- /dev/null
+++ b/sys-apps/tpctl/tpctl-4.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tpctl/tpctl-4.4.ebuild,v 1.1 2003/05/04 13:18:17 wmertens Exp $
+
+IUSE="ncurses tpctlir perl"
+
+#transform P to match tarball versioning
+MYPV=${PV/_beta/beta}
+MYP="${PN}_${MYPV}"
+
+DESCRIPTION="Thinkpad system control user space programs"
+SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
+HOMEPAGE="http://tpctl.sourceforge.net/tpctlhome.htm"
+KEYWORDS="~x86 -ppc -mips -sparc"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="$DEPEND >=sys-apps/thinkpad-4.3 ncurses? ( sys-libs/ncurses )"
+RDEPEND="$RDEPEND >=sys-apps/thinkpad-4.3 ncurses? ( sys-libs/ncurses ) perl? ( dev-lang/perl )"
+
+src_compile() {
+ emake -C lib || die "lib make failed"
+ emake -C tpctl || die "tpctl make failed"
+ if use ncurses > /dev/null; then
+ emake -C ntpctl || die "ntpctl make failed"
+ fi
+
+ # Only for thinkpad models 760 and 765
+ # build with:
+ # $ USE=tpctlir emerge tpctl
+ if use tpctlir; then
+ emake -C tpctlir || die "tpctlir make failed"
+ fi
+}
+
+src_install() {
+ dodoc AUTHORS COPYING ChangeLog README SUPPORTED-MODELS TROUBLESHOOTING \
+ VGA-MODES
+ dolib lib/libsmapidev.so.2.0
+ dobin tpctl/tpctl
+ [ -e ntpctl/ntpctl ] && dobin ntpctl/ntpctl
+ if use tpctlir && [ -e tpctlir/tpctlir ]; then
+ mv tpctlir/README README.tpctlir
+ dodoc README.tpctlir
+ dobin tpctlir/tpctlir
+ fi
+ if use perl > /dev/null; then
+ mv apmiser/README README.apmiser
+ dodoc README.apmiser
+ dosbin apmiser/apmiser
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/apmiser.rc apmiser
+ fi
+}