summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-02-04 20:24:44 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-02-04 20:24:44 +0000
commitb232985a2e53cb1124f964f6bc8bcdd1cbcd70e0 (patch)
treeecacd75e735ac7f5f583e3a7ec1fa51de1b4e6ae
parentFixed initscripts/digest (diff)
downloadgentoo-2-b232985a2e53cb1124f964f6bc8bcdd1cbcd70e0.tar.gz
gentoo-2-b232985a2e53cb1124f964f6bc8bcdd1cbcd70e0.tar.bz2
gentoo-2-b232985a2e53cb1124f964f6bc8bcdd1cbcd70e0.zip
Update to rc7.
-rw-r--r--media-sound/alsa-driver/ChangeLog12
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.9.0_rc7.ebuild92
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc71
3 files changed, 98 insertions, 7 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index 05f73c4ea7eb..a83aa01920e5 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,14 +1,12 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.22 2003/01/16 23:21:48 wwoods Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.23 2003/02/04 20:24:44 agenkin Exp $
- 16 Jan 2003; Will Woods <wwoods@gentoo.org> : alsa-driver-0.5.12a.ebuild
- Added ~alpha keyword
-
- 31 Dec 2002; Olivier Reisch <doctomoe@gentoo.org>
- alsa-driver-0.9.0_rc6.ebuild :
- Added ~ppc keyword for testing
+*alsa-driver-0.9.0_rc7 (04 Feb 2003)
+ 04 Feb 2003; Arcady Genkin <agenkin@gentoo.org> :
+ Quick update to rc7.
+
*alsa-driver-0.9.0_rc6 (19 Nov 2002)
21 Dec 2002; Arcady Genkin <agenkin@gentoo.org> :
diff --git a/media-sound/alsa-driver/alsa-driver-0.9.0_rc7.ebuild b/media-sound/alsa-driver/alsa-driver-0.9.0_rc7.ebuild
new file mode 100644
index 000000000000..95e8e8a3e9ed
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-0.9.0_rc7.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.9.0_rc7.ebuild,v 1.1 2003/02/04 20:24:44 agenkin Exp $
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+LICENSE="GPL-2 LGPL-2.1"
+
+# By default, drivers for all supported cards will be compiled.
+# If you want to only compile for specific card(s), set ALSA_CARDS
+# environment to a space-separated list of drivers that you want to build.
+# For example:
+#
+# env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
+#
+[ x"${ALSA_CARDS}" = x ] && ALSA_CARDS=all
+
+# Need the baselayout 1.7.9 or newer for the init script to work correctly.
+DEPEND="sys-devel/autoconf
+ virtual/glibc
+ >=sys-apps/portage-1.9.10
+ >=sys-apps/baselayout-1.7.9"
+PROVIDE="virtual/alsa"
+
+SLOT="0.9"
+KEYWORDS="~x86"
+
+SRC_URI="ftp://ftp.alsa-project.org/pub/driver/${P/_rc/rc}.tar.bz2"
+S=${WORKDIR}/${P/_rc/rc}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Some *broken* Gentoo packages install stuff in /etc/rc.d/init.d
+ # instead of /etc/init.d. However, this causes alsa's installer
+ # to do the same foolish thing. This *hack* inibits the problem.
+ # I filed a bug report about this with the ALSA people:
+ # http://sourceforge.net/tracker/?func=detail&aid=551668&group_id=27464&atid=390601
+ # Arcady Genkin <agenkin@thpoon.com>
+ sed -e 's:/etc/rc.d/init.d:/etc/init.d:' < Makefile > Makefile.hacked
+ mv Makefile.hacked Makefile
+
+ # Is this fixed in rc7?
+ # See bug http://bugs.gentoo.org/show_bug.cgi?id=11572
+ # http://www.mail-archive.com/alsa-devel@lists.sourceforge.net/msg05318.html
+ #patch -p1 < ${FILESDIR}/ice1712-${P}.diff || die
+}
+
+
+src_compile() {
+ # Portage should determine the version of the kernel sources
+ check_KV
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-kernel="${ROOT}usr/src/linux" \
+ --with-isapnp=yes \
+ --with-sequencer=yes \
+ --with-oss=yes \
+ --with-cards="${ALSA_CARDS}" \
+ || die "./configure failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+
+src_install () {
+ dodir /usr/include/sound
+ dodir /etc/init.d
+ make DESTDIR=${D} install || die
+
+ dodoc CARDS-STATUS COPYING FAQ INSTALL README WARNING TODO doc/*
+
+ insinto /etc/modules.d
+ newins ${FILESDIR}/alsa-modules.conf-rc alsa
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/alsasound
+}
+
+pkg_postinst () {
+ if [ "${ROOT}" = / ]
+ then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ einfo
+ einfo "You need to edit file /etc/modules.d/alsa according to your"
+ einfo "hardware configuration."
+ einfo
+ einfo "If you are going to be using the 'alsasound' init script, make sure"
+ einfo "that you add it to the 'boot' runlevel (not 'default')."
+ einfo
+}
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc7 b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc7
new file mode 100644
index 000000000000..a15a677fd6b8
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc7
@@ -0,0 +1 @@
+MD5 3cc7dbfe37e2db014bf5d8d681eb419e alsa-driver-0.9.0rc7.tar.bz2 1683567