summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-05-24 01:16:35 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-05-24 01:16:35 +0000
commitbec03e67596f24f0674a53841aad3dcabf893353 (patch)
treed4aa2f8fe7514fe0a2172c950806ab56833bbe4a
parentBump, see changelog (diff)
downloadgentoo-2-bec03e67596f24f0674a53841aad3dcabf893353.tar.gz
gentoo-2-bec03e67596f24f0674a53841aad3dcabf893353.tar.bz2
gentoo-2-bec03e67596f24f0674a53841aad3dcabf893353.zip
Bump, see changelog
-rw-r--r--dev-libs/openssl/ChangeLog8
-rw-r--r--dev-libs/openssl/Manifest4
-rw-r--r--dev-libs/openssl/files/digest-openssl-0.9.6j1
-rw-r--r--dev-libs/openssl/openssl-0.9.6j.ebuild96
4 files changed, 106 insertions, 3 deletions
diff --git a/dev-libs/openssl/ChangeLog b/dev-libs/openssl/ChangeLog
index 7a89f02eb3e3..731ec6dadc53 100644
--- a/dev-libs/openssl/ChangeLog
+++ b/dev-libs/openssl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/openssl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.37 2003/05/20 19:16:23 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.38 2003/05/24 01:16:32 lostlogic Exp $
+
+*openssl-0.9.6j (23 May 2003)
+
+ 23 May 2003; Brandon Low <lostlogic@gentoo.org> openssl-0.9.6j.ebuild:
+ Bump, lots of nice security fixes, several patches from 0.9.6i-r2 are merged
+ in here
20 May 2003; Tavis Ormandy <taviso@gentoo.org> openssl-0.9.6i-r2.ebuild,
openssl-0.9.7b.ebuild:
diff --git a/dev-libs/openssl/Manifest b/dev-libs/openssl/Manifest
index 226ab8452b47..f39ac6b9dcd7 100644
--- a/dev-libs/openssl/Manifest
+++ b/dev-libs/openssl/Manifest
@@ -1,10 +1,10 @@
MD5 ae8b3398ac108e38cedd3c0b835026c2 openssl-0.9.6i-r1.ebuild 2423
-MD5 383ae04c5b7371efa23ccdecb5c786a6 openssl-0.9.6j.ebuild 2784
+MD5 90774c10ec0b8bbbbba001b5bf8b3aa4 openssl-0.9.6j.ebuild 2791
MD5 f9889068ffc2fc73a7a85ac5579e0f18 openssl-0.9.7a-r1.ebuild 2569
MD5 7e42226d154e07d3ae1223cbc0a60f85 openssl-0.9.7a.ebuild 2517
MD5 f1f7f7f88d2931001e73d0d9f33d499f openssl-0.9.6i.ebuild 2384
MD5 894cbd2e4688992fbb86afada3f24ab0 openssl-0.9.6i-r2.ebuild 2873
-MD5 912b928bef473f280aedf202e6db2719 ChangeLog 6435
+MD5 01ccced4241df20adbc5795bfc686b7b ChangeLog 6632
MD5 f48f6270ee3c27f892a7fdb0cb9ee759 openssl-0.9.7a-r2.ebuild 2626
MD5 be1bf2ca3de7971873e0aef8cddbd9cb openssl-0.9.7b.ebuild 2858
MD5 a5a379391dfaaef98e4fe4198ff2ed2c files/openssl-0.9.6i-blinding.patch 1717
diff --git a/dev-libs/openssl/files/digest-openssl-0.9.6j b/dev-libs/openssl/files/digest-openssl-0.9.6j
new file mode 100644
index 000000000000..90c081d62322
--- /dev/null
+++ b/dev-libs/openssl/files/digest-openssl-0.9.6j
@@ -0,0 +1 @@
+MD5 52ea996e52bcea5120f193f51469bbb1 openssl-0.9.6j.tar.gz 2182643
diff --git a/dev-libs/openssl/openssl-0.9.6j.ebuild b/dev-libs/openssl/openssl-0.9.6j.ebuild
new file mode 100644
index 000000000000..159751af1056
--- /dev/null
+++ b/dev-libs/openssl/openssl-0.9.6j.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.6j.ebuild,v 1.1 2003/05/24 01:16:32 lostlogic Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Toolkit for SSL v2/v3 and TLS v1"
+SRC_URI="http://www.openssl.org/source/${P}.tar.gz"
+HOMEPAGE="http://www.openssl.org/"
+
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND} >=dev-lang/perl-5"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~mips ~hppa ~arm"
+IUSE=""
+
+if [ "$PROFILE_ARCH" = "sparc" -a "`uname -m`" = "sparc64" ]; then
+ SSH_TARGET="linux-sparcv8"
+fi
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ epatch ${FILESDIR}/${PN}-0.9.6i-gentoo.diff
+
+ if [ "${ARCH}" = "mips" ]
+ then
+ cd ${S}
+ epatch ${FILESDIR}/openssl-0.9.6-mips.diff
+ fi
+
+ if [ "${ARCH}" = "arm" ]; then
+ # patch linker to add -ldl or things linking aginst libcrypto fail
+ sed -e \
+ 's!^"linux-elf-arm"\(.*\)::BN\(.*\)!"linux-elf-arm"\1:-ldl:BN\2!' \
+ Configure > Configure.orig
+ elif [ "${ARCH}" = "hppa" ]; then
+ sed -e \
+ 's!^"linux-parisc"\(.*\)::BN\(.*\)::!"linux-parisc"\1:-ldl:BN\2::::::::::dlfcn:linux-shared:-fPIC::.so.\\$(SHLIB_MAJOR).\\$(SHLIB_MINOR)!' \
+ Configure > Configure.orig
+ elif [ "${ARCH}" = "alpha" ]; then
+ if [ "${CC}" != "ccc" ]; then
+ # ccc compiled openssl will break things linked against
+ # a gcc compiled openssl, the configure will automatically detect
+ # ccc and use it, so stop that if user hasnt asked for it.
+ #
+ sed -e \
+ 's!CC=ccc!CC=gcc!' config > config.orig
+ cp config.orig config
+ fi
+ cp Configure Configure.orig
+ else
+ cp Configure Configure.orig
+ fi
+ sed -e "s/-O3/$CFLAGS/" -e "s/-m486//" Configure.orig > Configure
+}
+
+src_compile() {
+ if [ ${SSH_TARGET} ]; then
+ einfo "Forcing ${SSH_TARGET} compile"
+ ./Configure ${SSH_TARGET} --prefix=/usr \
+ --openssldir=/etc/ssl shared threads || die
+ else
+ ./config --prefix=/usr --openssldir=/etc/ssl shared threads || die
+ fi
+ # i think parallel make has problems
+ make all || die
+
+}
+
+src_install() {
+ make INSTALL_PREFIX=${D} MANDIR=/usr/share/man install || die
+ dodoc CHANGES* FAQ LICENSE NEWS README
+ dodoc doc/*.txt
+ dohtml doc/*
+ insinto /usr/share/emacs/site-lisp
+ doins doc/c-indentation.el
+
+ # The man pages rand.3 and passwd.1 conflict with other packages
+ # Rename them to ssl-* and also make a symlink from openssl-* to ssl-*
+ cd ${D}/usr/share/man/man1
+ mv passwd.1 ssl-passwd.1
+ ln -sf ssl-passwd.1 openssl-passwd.1
+ cd ${D}/usr/share/man/man3
+ mv rand.3 ssl-rand.3
+ ln -sf ssl-rand.3 openssl-rand.3
+
+ # create the certs directory. Previous openssl builds
+ # would need to create /usr/lib/ssl/certs but this looks
+ # to be the more FHS compliant setup... -raker
+ dodir /etc/ssl/certs
+
+}
+