summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-12-20 19:04:08 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-12-20 19:04:08 +0000
commitbfa43762bd22e2e6e6c7a3dd190ce96941eec3e3 (patch)
treeda45805ad6e367278b1a3954af97f1df8c0e40d1
parentfixing nasty automake version mismatch bug (Manifest recommit) (diff)
downloadgentoo-2-bfa43762bd22e2e6e6c7a3dd190ce96941eec3e3.tar.gz
gentoo-2-bfa43762bd22e2e6e6c7a3dd190ce96941eec3e3.tar.bz2
gentoo-2-bfa43762bd22e2e6e6c7a3dd190ce96941eec3e3.zip
better workaround for strict-aliasing warnings (#69330)
-rw-r--r--gnome-extra/drwright/ChangeLog5
-rw-r--r--gnome-extra/drwright/drwright-0.17.ebuild13
2 files changed, 10 insertions, 8 deletions
diff --git a/gnome-extra/drwright/ChangeLog b/gnome-extra/drwright/ChangeLog
index a829ba994d12..cf666b93077e 100644
--- a/gnome-extra/drwright/ChangeLog
+++ b/gnome-extra/drwright/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for gnome-extra/drwright
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/drwright/ChangeLog,v 1.7 2004/08/19 22:58:30 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/drwright/ChangeLog,v 1.8 2004/12/20 19:04:08 liquidx Exp $
+
+ 20 Dec 2004; Alastair Tse <liquidx@gentoo.org> drwright-0.17.ebuild:
+ better workaround for strict-aliasing warnings (#69330)
19 Aug 2004; foser <foser@gentoo.org> drwright-0.17.ebuild :
Fix QA issue (#48366)
diff --git a/gnome-extra/drwright/drwright-0.17.ebuild b/gnome-extra/drwright/drwright-0.17.ebuild
index fe8deef1594e..5dee877abd0b 100644
--- a/gnome-extra/drwright/drwright-0.17.ebuild
+++ b/gnome-extra/drwright/drwright-0.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/drwright/drwright-0.17.ebuild,v 1.6 2004/08/19 22:58:30 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/drwright/drwright-0.17.ebuild,v 1.7 2004/12/20 19:04:08 liquidx Exp $
inherit gnome2 flag-o-matic gcc
@@ -24,11 +24,10 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README"
-src_compile() {
-
- [ "`gcc-version`" = "3.3" ] && append-flags -Wno-strict-aliasing
-
- gnome2_src_compile
-
+src_unpack() {
+ cd ${S}
+ unpack ${A}
+ # get rid of strict-aliasing warnings
+ sed -i -e 's/-Wall//' ${S}/src/Makefile.in ${S}/src/Makefile.am
}