summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-18 14:24:44 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-18 14:24:44 +0000
commitc0cc7bc1e7716a966fdb60fde90e3078a2be5907 (patch)
tree6b224f61038d8ba203340647011a21692e4c88af
parentremoving unneeded patches (Manifest recommit) (diff)
downloadgentoo-2-c0cc7bc1e7716a966fdb60fde90e3078a2be5907.tar.gz
gentoo-2-c0cc7bc1e7716a966fdb60fde90e3078a2be5907.tar.bz2
gentoo-2-c0cc7bc1e7716a966fdb60fde90e3078a2be5907.zip
- Fix bug 54179: Install mozillafirefox.desktop to /usr/share/applications instead of /usr/share/gnome/apps/Internet. This also necessitated some changes to the .desktop file which I based on epiphany.desktop - Fix bug 54295: Move init file unpacking from pkg_postinst to src_install - Get rid of the stupid perl dependency; it was only being used to edit the .desktop file, and sed would have sufficed in any case
-rw-r--r--net-www/mozilla-firefox/ChangeLog13
-rw-r--r--net-www/mozilla-firefox/files/icon/mozillafirefox.desktop8
-rw-r--r--net-www/mozilla-firefox/mozilla-firefox-0.9-r1.ebuild29
3 files changed, 31 insertions, 19 deletions
diff --git a/net-www/mozilla-firefox/ChangeLog b/net-www/mozilla-firefox/ChangeLog
index b4b7624514c3..bd8aea2883e0 100644
--- a/net-www/mozilla-firefox/ChangeLog
+++ b/net-www/mozilla-firefox/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for net-www/mozilla-firefox
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/ChangeLog,v 1.43 2004/06/17 13:32:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/ChangeLog,v 1.44 2004/06/18 14:24:44 agriffis Exp $
+
+ 18 Jun 2004; Aron Griffis <agriffis@gentoo.org>
+ +files/icon/mozillafirefox.desktop, mozilla-firefox-0.9-r1.ebuild:
+ - Fix bug 54179: Install mozillafirefox.desktop to
+ /usr/share/applications instead of /usr/share/gnome/apps/Internet.
+ This also necessitated some changes to the .desktop file which I
+ based on epiphany.desktop
+ - Fix bug 54295: Move init file unpacking from pkg_postinst to
+ src_install
+ - Get rid of the stupid perl dependency; it was only being used to
+ edit the .desktop file, and sed would have sufficed in any case
17 Jun 2004; Aron Griffis <agriffis@gentoo.org>
mozilla-firefox-0.9-r1.ebuild:
diff --git a/net-www/mozilla-firefox/files/icon/mozillafirefox.desktop b/net-www/mozilla-firefox/files/icon/mozillafirefox.desktop
new file mode 100644
index 000000000000..c9eb057275ff
--- /dev/null
+++ b/net-www/mozilla-firefox/files/icon/mozillafirefox.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Mozilla Firefox
+Comment=Web Browser
+Exec=/usr/bin/firefox %U
+Icon=firefox-icon.png
+Terminal=false
+Type=Application
+Categories=Application;Network;
diff --git a/net-www/mozilla-firefox/mozilla-firefox-0.9-r1.ebuild b/net-www/mozilla-firefox/mozilla-firefox-0.9-r1.ebuild
index 4d1308edfede..d787c0f1f92f 100644
--- a/net-www/mozilla-firefox/mozilla-firefox-0.9-r1.ebuild
+++ b/net-www/mozilla-firefox/mozilla-firefox-0.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/mozilla-firefox-0.9-r1.ebuild,v 1.5 2004/06/17 13:32:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/mozilla-firefox-0.9-r1.ebuild,v 1.6 2004/06/18 14:24:44 agriffis Exp $
inherit makeedit flag-o-matic gcc nsplugins eutils mozilla-launcher
@@ -37,7 +37,6 @@ RDEPEND="virtual/x11
DEPEND="${RDEPEND}
virtual/glibc
dev-util/pkgconfig
- dev-lang/perl
java? ( >=dev-java/java-config-0.2.0 )"
# needed by src_compile() and src_install()
@@ -232,17 +231,17 @@ src_install() {
if use gnome; then
insinto /usr/share/pixmaps
doins ${FILESDIR}/icon/firefox-icon.png
- # Fix comment of menu entry
- cd ${S}/build/package/rpm/SOURCES
- cp mozilla.desktop mozillafirefox.desktop
- perl -pi -e 's:Name=Mozilla:Name=Mozilla Firefox:' mozillafirefox.desktop
- perl -pi -e 's:Comment=Mozilla:Comment=Mozilla Firefox Web Browser:' mozillafirefox.desktop
- perl -pi -e 's:Exec=/usr/bin/mozilla:Exec=/usr/bin/firefox:' mozillafirefox.desktop
- perl -pi -e 's:Icon=mozilla-icon.png:Icon=firefox-icon.png:' mozillafirefox.desktop
- cd ${S}
- insinto /usr/share/gnome/apps/Internet
- doins ${S}/build/package/rpm/SOURCES/mozillafirefox.desktop
+ # Fix bug 54179: Install .desktop file into /usr/share/applications
+ # instead of /usr/share/gnome/apps/Internet (18 Jun 2004 agriffis)
+ insinto /usr/share/applications
+ doins ${FILESDIR}/icon/mozillafirefox.desktop
fi
+
+ # Normally firefox-0.9 must be run as root once before it can be
+ # run as a normal user. Drop in some initialized files to avoid
+ # this.
+ einfo "Extracting firefox-${PV} initialization files"
+ tar xjpf ${FILESDIR}/firefox-${PV}-init.tar.bz2 -C ${D}/usr/lib/MozillaFirefox
}
pkg_preinst() {
@@ -259,12 +258,6 @@ pkg_preinst() {
pkg_postinst() {
export MOZILLA_FIVE_HOME="${ROOT}/usr/lib/MozillaFirefox"
- # Normally firefox-0.9 must be run as root once before it can be
- # run as a normal user. Drop in some initialized files to avoid
- # this.
- einfo "Extracting firefox-${PV} initialization files"
- cd ${MOZILLA_FIVE_HOME} && tar xjpf ${FILESDIR}/firefox-${PV}-init.tar.bz2
-
# Needed to update the run time bindings for REGXPCOM
# (do not remove next line!)
env-update