summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-01-11 16:53:53 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-01-11 16:53:53 +0000
commitc9ec357c88c169a76c8e4b063a70d80b572551d7 (patch)
treeb31485b5b0edd2bbe7c4c4c686e48c43c128f395
parentMarking stable on x86 and amd64, updated to use latest vmware-any-any-update ... (diff)
downloadgentoo-2-c9ec357c88c169a76c8e4b063a70d80b572551d7.tar.gz
gentoo-2-c9ec357c88c169a76c8e4b063a70d80b572551d7.tar.bz2
gentoo-2-c9ec357c88c169a76c8e4b063a70d80b572551d7.zip
*** empty log message ***
-rw-r--r--dev-lisp/cl-icu/ChangeLog10
-rw-r--r--dev-lisp/cl-icu/Manifest3
-rw-r--r--dev-lisp/cl-icu/cl-icu-0.0_p11.ebuild51
-rw-r--r--dev-lisp/cl-icu/files/0.0_p11-gentoo.patch40
-rw-r--r--dev-lisp/cl-icu/files/digest-cl-icu-0.0_p111
-rw-r--r--dev-lisp/cl-icu/metadata.xml5
6 files changed, 110 insertions, 0 deletions
diff --git a/dev-lisp/cl-icu/ChangeLog b/dev-lisp/cl-icu/ChangeLog
new file mode 100644
index 000000000000..09dfccbc58b4
--- /dev/null
+++ b/dev-lisp/cl-icu/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-icu
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-icu/ChangeLog,v 1.1 2005/01/11 16:53:53 mkennedy Exp $
+
+*cl-icu-0.0_p11 (11 Jan 2005)
+
+ 11 Jan 2005; Matthew Kennedy <mkennedy@gentoo.org> +metadata.xml,
+ +files/0.0_p11-gentoo.patch, +cl-icu-0.0_p11.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/cl-icu/Manifest b/dev-lisp/cl-icu/Manifest
new file mode 100644
index 000000000000..c5130776afc9
--- /dev/null
+++ b/dev-lisp/cl-icu/Manifest
@@ -0,0 +1,3 @@
+MD5 f412cd224b2d57954003c66d70bd2bea cl-icu-0.0_p11.ebuild 1058
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
+MD5 0ba9241af41eabd2045968e7574710a5 files/digest-cl-icu-0.0_p11 77
diff --git a/dev-lisp/cl-icu/cl-icu-0.0_p11.ebuild b/dev-lisp/cl-icu/cl-icu-0.0_p11.ebuild
new file mode 100644
index 000000000000..9dee09092d11
--- /dev/null
+++ b/dev-lisp/cl-icu/cl-icu-0.0_p11.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-icu/cl-icu-0.0_p11.ebuild,v 1.1 2005/01/11 16:53:53 mkennedy Exp $
+
+inherit common-lisp eutils
+
+MY_P=${PN}--dev--${PV/_*/}--patch-${PV/*_p/}
+
+DESCRIPTION="CL-ICU is a common lisp interface to IBM's ICU library."
+HOMEPAGE="http://common-lisp.net/project/bese/cl-icu.html"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+# ICU is not binary compatible between *minor* version releases because they
+# suffix all the symbols with a version string!
+
+DEPEND="dev-lisp/cl-uffi
+ dev-lisp/cl-arnesi
+ =dev-libs/icu-2.6*"
+
+CLPACKAGE=cl-icu
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ local version=$(icu-config --version)
+ if [ "${version:0:3}" != "2.6" ]; then
+ die "dev-lisp/cl-icue is only compatible with =dev-libs/icu-2.6 (ICU ${version} was installed)"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-gentoo.patch || die
+ find ${S}/ -type d -name .arch-ids -exec rm -rf '{}' \; &>/dev/null
+
+}
+
+src_install() {
+ dodir /usr/share/common-lisp/source/cl-icu
+ dodir /usr/share/common-lisp/systems
+ cp -R src ${D}/usr/share/common-lisp/source/cl-icu/
+ common-lisp-install cl-icu.asd
+ common-lisp-system-symlink
+ dosym /usr/share/common-lisp/source/cl-icu/cl-icu.asd \
+ /usr/share/common-lisp/systems/
+ dodoc README
+}
diff --git a/dev-lisp/cl-icu/files/0.0_p11-gentoo.patch b/dev-lisp/cl-icu/files/0.0_p11-gentoo.patch
new file mode 100644
index 000000000000..69cf6fd49350
--- /dev/null
+++ b/dev-lisp/cl-icu/files/0.0_p11-gentoo.patch
@@ -0,0 +1,40 @@
+diff -ur cl-icu--dev--0.0--patch-11.orig/src/calendar.lisp cl-icu--dev--0.0--patch-11/src/calendar.lisp
+--- cl-icu--dev--0.0--patch-11.orig/src/calendar.lisp 2004-12-28 17:49:51.000000000 -0600
++++ cl-icu--dev--0.0--patch-11/src/calendar.lisp 2005-01-11 09:50:02.000000000 -0600
+@@ -49,7 +49,7 @@
+ (make-date (ucal-getnow)))
+
+ (defmethod make-date ((millis number))
+- (make-date (coerce 'double-float millis)))
++ (make-date (coerce millis 'double-float)))
+
+ (defmethod make-date ((millis double-float))
+ (make-instance 'date :uobject millis))
+diff -ur cl-icu--dev--0.0--patch-11.orig/src/init-icu.lisp cl-icu--dev--0.0--patch-11/src/init-icu.lisp
+--- cl-icu--dev--0.0--patch-11.orig/src/init-icu.lisp 2004-12-28 17:49:51.000000000 -0600
++++ cl-icu--dev--0.0--patch-11/src/init-icu.lisp 2005-01-11 09:47:49.000000000 -0600
+@@ -14,7 +14,7 @@
+ "The namse of the libraries we need to load for ICU support.")
+
+ ;; the output of 'icu-config --ldflags-searchpath'
+-(defvar *icu-lib-install-dir* "/home/baringer/ucw/icu/binary/lib/"
++(defvar *icu-lib-install-dir* "/usr/lib/"
+ "The directory where the ICU libraries can be found.")
+
+ ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
+diff -ur cl-icu--dev--0.0--patch-11.orig/src/locale.lisp cl-icu--dev--0.0--patch-11/src/locale.lisp
+--- cl-icu--dev--0.0--patch-11.orig/src/locale.lisp 2004-12-28 17:49:51.000000000 -0600
++++ cl-icu--dev--0.0--patch-11/src/locale.lisp 2005-01-11 09:51:15.000000000 -0600
+@@ -11,11 +11,7 @@
+
+ (defun make-locale (id)
+ (make-instance 'locale
+- :uobject (convert-to-foreign-string (typecase id
+- (simple-string id)
+- (string (map-into (make-string (length id))
+- #'identity
+- id))))))
++ :uobject id))
+
+ (defun default-locale ()
+ (make-instance 'locale :uobject (uloc-getDefault)))
diff --git a/dev-lisp/cl-icu/files/digest-cl-icu-0.0_p11 b/dev-lisp/cl-icu/files/digest-cl-icu-0.0_p11
new file mode 100644
index 000000000000..cc1bf466e1ba
--- /dev/null
+++ b/dev-lisp/cl-icu/files/digest-cl-icu-0.0_p11
@@ -0,0 +1 @@
+MD5 93c3bad21f9e0c6a0c83c78bb0c2517c cl-icu--dev--0.0--patch-11.tar.gz 76058
diff --git a/dev-lisp/cl-icu/metadata.xml b/dev-lisp/cl-icu/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-icu/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>