summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-09-06 17:48:37 +0000
committerTravis Tilley <lv@gentoo.org>2004-09-06 17:48:37 +0000
commitf1da587a3d6e4ec1ed8a3ab386c97f283669dcd6 (patch)
treed05068f2cedfa5eb29df162bd3aa914192331880
parentRemoved mention of Gmail from DESCRIPTION, fixed changelog header. (Manifest ... (diff)
downloadgentoo-2-f1da587a3d6e4ec1ed8a3ab386c97f283669dcd6.tar.gz
gentoo-2-f1da587a3d6e4ec1ed8a3ab386c97f283669dcd6.tar.bz2
gentoo-2-f1da587a3d6e4ec1ed8a3ab386c97f283669dcd6.zip
added $(get_libdir) support for amd64 and x86 and changed locale building logic to build user-specified locales only if USE=userlocales. fixes bug 62081
-rw-r--r--sys-libs/glibc/ChangeLog7
-rw-r--r--sys-libs/glibc/files/2.3.4/glibc-gentoo-libdir.patch36
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040808.ebuild25
3 files changed, 54 insertions, 14 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 2426220b5be9..54bedd7db7b0 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/glibc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.250 2004/09/06 05:25:49 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.251 2004/09/06 17:48:37 lv Exp $
+
+ 06 Sep 2004; Travis Tilley <lv@gentoo.org>
+ +files/2.3.4/glibc-gentoo-libdir.patch, glibc-2.3.4.20040808.ebuild:
+ added $(get_libdir) support for amd64 and x86 and changed locale building
+ logic to build user-specified locales only if USE=userlocales. fixes bug 62081
06 Sep 2004; <solar@gentoo.org> files/glibc-sec-hotfix-20040804.patch,
glibc-2.3.3.20040420-r1.ebuild, glibc-2.3.4.20040619-r1.ebuild:
diff --git a/sys-libs/glibc/files/2.3.4/glibc-gentoo-libdir.patch b/sys-libs/glibc/files/2.3.4/glibc-gentoo-libdir.patch
new file mode 100644
index 000000000000..147968b3776f
--- /dev/null
+++ b/sys-libs/glibc/files/2.3.4/glibc-gentoo-libdir.patch
@@ -0,0 +1,36 @@
+diff -Nru glibc-2.3.3.old/sysdeps/unix/sysv/linux/configure glibc-2.3.3/sysdeps/unix/sysv/linux/configure
+--- glibc-2.3.3.old/sysdeps/unix/sysv/linux/configure 2004-09-06 12:33:39.320387104 -0400
++++ glibc-2.3.3/sysdeps/unix/sysv/linux/configure 2004-09-06 12:34:42.575770824 -0400
+@@ -224,29 +224,13 @@
+ # in /lib and /etc.
+ case "$prefix" in
+ /usr | /usr/)
+- # 64-bit libraries on bi-arch platforms go in /lib64 instead of /lib
+- case $machine in
+- sparc/sparc64 | x86_64 | powerpc/powerpc64 | s390/s390-64 | \
+- mips/mips64/n64/* )
+- libc_cv_slibdir="/lib64"
++ libc_cv_slibdir="/@GENTOO_LIBDIR@/"
+ if test "$libdir" = '${exec_prefix}/lib'; then
+- libdir='${exec_prefix}/lib64';
++ libdir='${exec_prefix}/@GENTOO_LIBDIR@/'
+ # Locale data can be shared between 32bit and 64bit libraries
+ libc_cv_localedir='${exec_prefix}/lib/locale'
+ fi
+- ;;
+- mips/mips64/n32/* )
+- libc_cv_slibdir="/lib32"
+- if test "$libdir" = '${exec_prefix}/lib'; then
+- libdir='${exec_prefix}/lib32';
+- # Locale data can be shared between 32bit and 64bit libraries
+- libc_cv_localedir='${exec_prefix}/lib/locale'
+- fi
+- ;;
+- *)
+- libc_cv_slibdir="/lib"
+- ;;
+- esac
++
+ # Allow the user to override the path with --sysconfdir
+ if test $sysconfdir = '${prefix}/etc'; then
+ libc_cv_sysconfdir=/etc
diff --git a/sys-libs/glibc/glibc-2.3.4.20040808.ebuild b/sys-libs/glibc/glibc-2.3.4.20040808.ebuild
index 0bbbce7340dd..93212e454199 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040808.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040808.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808.ebuild,v 1.16 2004/09/06 00:40:08 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808.ebuild,v 1.17 2004/09/06 17:48:37 lv Exp $
inherit eutils flag-o-matic gcc
@@ -40,7 +40,7 @@ SRC_URI="http://dev.gentoo.org/~lv/${PN}-${BASE_PV}.tar.bz2
LICENSE="LGPL-2"
SLOT="2.2"
KEYWORDS="-* ~x86 ~amd64 ~hppa ppc64 ~ppc"
-IUSE="nls pic build nptl erandom hardened makecheck multilib debug"
+IUSE="nls pic build nptl erandom hardened makecheck multilib debug userlocales"
RESTRICT="nostrip" # we'll handle stripping ourself #46186
# We need new cleanup attribute support from gcc for NPTL among things ...
@@ -245,9 +245,9 @@ install_locales() {
setup_locales() {
- if use nls || use makecheck; then
- einfo "nls or makecheck in USE, installing -ALL- locales..."
- install_locales
+ if use !userlocales || use makecheck; then
+ einfo "makecheck in USE or userlocales not enabled, installing -ALL- locales..."
+ install_locales || die
elif [ -e /etc/locales.build ]; then
einfo "Installing locales in /etc/locales.build..."
echo 'SUPPORTED-LOCALES=\' > SUPPORTED.locales
@@ -285,11 +285,9 @@ pkg_setup() {
do_arch_amd64_patches() {
cd ${S};
- # multilib!!! i lovesdidid youuuu!
- #epatch ${FILESDIR}/2.3.2/${PN}-2.3.2-amd64-nomultilib.patch
- # commented out broken patch that destroyed the possibility of ever
- # being FHS compliant or having multilib capabilities.
- # Travis Tilley <lv@gentoo.org> (08 Aug 2004)
+ # CONF_LIBDIR support
+ epatch ${FILESDIR}/2.3.4/glibc-gentoo-libdir.patch
+ sed -i -e "s:@GENTOO_LIBDIR@:$(get_libdir):g" ${S}/sysdeps/unix/sysv/linux/configure
}
@@ -388,8 +386,9 @@ do_arch_sparc_patches() {
do_arch_x86_patches() {
cd ${S};
-
- # Any needed patches for x86 go here
+ # CONF_LIBDIR support
+ epatch ${FILESDIR}/2.3.4/glibc-gentoo-libdir.patch
+ sed -i -e "s:@GENTOO_LIBDIR@:$(get_libdir):g" ${S}/sysdeps/unix/sysv/linux/configure
}
@@ -718,7 +717,7 @@ pkg_preinst() {
# decide to be multilib compatible and FHS compliant. note that this
# chunk of FHS compliance only applies to 64bit archs where 32bit
# compatibility is a major concern (not IA64, for example).
- use amd64 && fix_lib64_symlinks
+ use amd64 && [ "$(get_libdir)" == "lib64" ] && fix_lib64_symlinks
}
pkg_postinst() {