summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-01 12:48:37 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-01 12:48:37 +0000
commit15c2ca092cdfea8caa823092e8389efe743019a4 (patch)
tree349b750aaa90ef41dbbe5483490c3eb77546eca6
parenthousekeeping and fixes (diff)
downloadgentoo-2-15c2ca092cdfea8caa823092e8389efe743019a4.tar.gz
gentoo-2-15c2ca092cdfea8caa823092e8389efe743019a4.tar.bz2
gentoo-2-15c2ca092cdfea8caa823092e8389efe743019a4.zip
version bump and fixes
-rw-r--r--net-libs/openh323/ChangeLog5
-rw-r--r--net-libs/openh323/files/digest-openh323-1.11.71
-rw-r--r--net-libs/openh323/openh323-1.11.7.ebuild73
3 files changed, 79 insertions, 0 deletions
diff --git a/net-libs/openh323/ChangeLog b/net-libs/openh323/ChangeLog
index 162f25795e4b..c2455646cbaa 100644
--- a/net-libs/openh323/ChangeLog
+++ b/net-libs/openh323/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
# $Header:
+*openh323-1.11.7 (01 Apr 2003)
+
+ 01 Apr 2003; Alastair Tse <liquidx@gentoo.org> openh323-1.11.7.ebuild:
+ version bump and additional check for possible broken pwlib makefiles
+
*openh323-1.11.2 (28 Jan 2003)
01 Feb 2003; Nick Hadaway <raker@gentoo.org> openh323-1.11.2.ebuild :
diff --git a/net-libs/openh323/files/digest-openh323-1.11.7 b/net-libs/openh323/files/digest-openh323-1.11.7
new file mode 100644
index 000000000000..5ddfe6307e5c
--- /dev/null
+++ b/net-libs/openh323/files/digest-openh323-1.11.7
@@ -0,0 +1 @@
+MD5 369449dcca5e30ebd3b94e57995b544f openh323_1.11.7.tar.gz 2109194
diff --git a/net-libs/openh323/openh323-1.11.7.ebuild b/net-libs/openh323/openh323-1.11.7.ebuild
new file mode 100644
index 000000000000..21a7a19b58e1
--- /dev/null
+++ b/net-libs/openh323/openh323-1.11.7.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/openh323/openh323-1.11.7.ebuild,v 1.1 2003/04/01 12:48:37 liquidx Exp $
+
+IUSE="ssl"
+S="${WORKDIR}/${PN}"
+SRC_URI="http://www.openh323.org/bin/${PN}_${PV}.tar.gz"
+HOMEPAGE="http://www.openh323.org"
+DESCRIPTION="Open Source implementation of the ITU H.323 teleconferencing protocol"
+DEPEND=">=dev-libs/pwlib-1.4.11
+ ssl? ( dev-libs/openssl )"
+SLOT="0"
+LICENSE="MPL-1.1"
+KEYWORDS="~x86 ~ppc -sparc "
+
+pkg_setup() {
+ # to prevent merge problems with broken makefiles from old
+ # pwlib versions, we double-check here.
+
+ if [ "` fgrep '\$(OPENSSLDIR)/include' /usr/share/pwlib/make/unix.mak`" ]; then
+ # patch unix.mak so it doesn't require annoying
+ # unmerge/merge cycle to upgrade
+ einfo "Fixing broken pwlib makefile."
+ cd /usr/share/pwlib/make
+ cp unix.mak unix.mak.orig
+ sed \
+ -e "s:-DP_SSL -I\$(OPENSSLDIR)/include -I\$(OPENSSLDIR)/crypto:-DP_SSL:" \
+ -e "s:^LDFLAGS.*\+= -L\$(OPENSSLDIR)/lib -L\$(OPENSSLDIR):LDFLAGS +=:" \
+ unix.mak.orig > unix.mak
+ [ -f unix.mak.orig ] && rm -f unix.mak.orig
+ fi
+
+}
+
+src_compile() {
+ export PWLIBDIR=/usr/share/pwlib
+ export OPENH323DIR=${S}
+ if [ "`use ssl`" ]; then
+ export OPENSSLFLAG=1
+ export OPENSSLDIR=/usr
+ export OPENSSLLIBS="-lssl -lcrypt"
+ fi
+ make optshared || die
+}
+
+src_install() {
+
+ dodir /usr/lib /usr/share/openh323
+
+ cd ${S}/lib
+ mv lib* ${D}/usr/lib
+
+ cd ${S}
+ cp -a * ${D}/usr/share/openh323
+ rm -rf ${D}/usr/share/openh323/make/CVS
+ rm -rf ${D}/usr/share/openh323/tools/CVS
+ rm -rf ${D}/usr/share/openh323/tools/asnparser/CVS
+ rm -rf ${D}/usr/share/openh323/src
+ rm -rf ${D}/usr/share/openh323/include/CVS
+ rm -rf ${D}/usr/share/openh323/include/ptlib/unix/CVS
+ rm -rf ${D}/usr/share/openh323/include/ptlib/CVS
+
+ cd ${D}/usr/lib
+ if [ ${ARCH} = "ppc" ] ; then
+ ln -sf libh323_linux_ppc_r.so.${PV} libopenh323.so
+ else
+ ln -sf libh323_linux_x86_r.so.${PV} libopenh323.so
+ fi
+
+
+}
+
+