summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-07-02 15:45:40 +0000
committerMark Wright <gienah@gentoo.org>2014-07-02 15:45:40 +0000
commita56821929a6426aec741aeeb4a618b78a0e7ee2b (patch)
tree33d34dde8555299674a0513e9a61ce83a07a1676
parentBump data-endian to 0.1 (diff)
downloadgentoo-2-a56821929a6426aec741aeeb4a618b78a0e7ee2b.tar.gz
gentoo-2-a56821929a6426aec741aeeb4a618b78a0e7ee2b.tar.bz2
gentoo-2-a56821929a6426aec741aeeb4a618b78a0e7ee2b.zip
Bump pandoc-citeproc to 0.3.1
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
-rw-r--r--dev-haskell/pandoc-citeproc/ChangeLog8
-rw-r--r--dev-haskell/pandoc-citeproc/metadata.xml1
-rw-r--r--dev-haskell/pandoc-citeproc/pandoc-citeproc-0.3.1.ebuild70
3 files changed, 78 insertions, 1 deletions
diff --git a/dev-haskell/pandoc-citeproc/ChangeLog b/dev-haskell/pandoc-citeproc/ChangeLog
index 29a42200d5b1..efe055dcfea3 100644
--- a/dev-haskell/pandoc-citeproc/ChangeLog
+++ b/dev-haskell/pandoc-citeproc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/pandoc-citeproc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/pandoc-citeproc/ChangeLog,v 1.3 2014/03/09 06:22:40 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/pandoc-citeproc/ChangeLog,v 1.4 2014/07/02 15:45:40 gienah Exp $
+
+*pandoc-citeproc-0.3.1 (02 Jul 2014)
+
+ 02 Jul 2014; Mark Wright <gienah@gentoo.org> +pandoc-citeproc-0.3.1.ebuild,
+ metadata.xml:
+ Bump pandoc-citeproc to 0.3.1
*pandoc-citeproc-0.3.0.1 (09 Mar 2014)
diff --git a/dev-haskell/pandoc-citeproc/metadata.xml b/dev-haskell/pandoc-citeproc/metadata.xml
index c4e8363b55cd..36f7220b5439 100644
--- a/dev-haskell/pandoc-citeproc/metadata.xml
+++ b/dev-haskell/pandoc-citeproc/metadata.xml
@@ -11,6 +11,7 @@
<flag name="network">use <pkg>dev-haskell/network</pkg> and <pkg>dev-haskell/http</pkg> to retrieve CSL file from URIs</flag>
<flag name="hexpat">use <pkg>dev-haskell/hexpat</pkg> instead of <pkg>dev-haskell/xml</pkg> for XML parsing</flag>
<flag name="small_base">Choose the new smaller, split-up base package.</flag>
+ <flag name="test_citeproc">Build the test-citeproc program</flag>
<flag name="unicode_collation">Use Haskell bindings to the <pkg>dev-libs/icu</pkg></flag>
</use>
<longdescription>
diff --git a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.3.1.ebuild b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.3.1.ebuild
new file mode 100644
index 000000000000..cbe2d0d3dc35
--- /dev/null
+++ b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.3.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.3.1.ebuild,v 1.1 2014/07/02 15:45:40 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+#hackport: flags: -small_base
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Supports using pandoc with citeproc"
+HOMEPAGE="http://hackage.haskell.org/package/pandoc-citeproc"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+bibutils embed_data_files +hexpat +network test_citeproc unicode_collation"
+
+RDEPEND=">=app-text/pandoc-1.12.1:=[profile?]
+ dev-haskell/aeson:=[profile?]
+ dev-haskell/aeson-pretty:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pandoc-types-1.12.3:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/split:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/tagsoup:=[profile?]
+ >=dev-haskell/temporary-1.1:=[profile?]
+ >=dev-haskell/texmath-0.6.4:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/vector-0.10:=[profile?] <dev-haskell/vector-0.11:=[profile?]
+ >=dev-haskell/yaml-0.8.8.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ bibutils? ( >=dev-haskell/hs-bibutils-0.3:=[profile?] )
+ hexpat? ( >=dev-haskell/hexpat-0.20.2:=[profile?] )
+ !hexpat? ( dev-haskell/xml:=[profile?] )
+ network? ( >=dev-haskell/http-4000.0.9:=[profile?]
+ >=dev-haskell/network-2:=[profile?] )
+ unicode_collation? ( dev-haskell/text-icu:=[profile?] )
+ !unicode_collation? ( dev-haskell/rfc5051:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.12
+ test? ( >=app-text/pandoc-1.12.1
+ dev-haskell/aeson
+ >=dev-haskell/pandoc-types-1.12.3
+ dev-haskell/text
+ >=dev-haskell/yaml-0.8.8.2 )
+"
+
+src_configure() {
+ # workaround bug on ghc-7.6.3:
+ # > [13 of 24] Compiling Text.CSL.Input.Bibtex ...
+ # > stack overflow: use +RTS -K<size> to increase it
+ [[ $(ghc-version) == 7.6.* ]] && replace-hcflags -O[2-9] -O1
+ [[ $(ghc-version) == 7.8.* ]] && replace-hcflags -O[2-9] -O1
+
+ haskell-cabal_src_configure \
+ $(cabal_flag bibutils bibutils) \
+ $(cabal_flag embed_data_files embed_data_files) \
+ $(cabal_flag hexpat hexpat) \
+ $(cabal_flag network network) \
+ --flag=-small_base \
+ $(cabal_flag test_citeproc test_citeproc) \
+ $(cabal_flag unicode_collation unicode_collation)
+}