summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-03-31 19:26:38 +0000
committerSamuli Suominen <drac@gentoo.org>2007-03-31 19:26:38 +0000
commitad86db7a592f60866c83a31809de48152b201a6f (patch)
treef4272d5c7ea96e4a0bba674cdc50036126455ed0
parentVersion bump. (diff)
downloadgentoo-2-ad86db7a592f60866c83a31809de48152b201a6f.tar.gz
gentoo-2-ad86db7a592f60866c83a31809de48152b201a6f.tar.bz2
gentoo-2-ad86db7a592f60866c83a31809de48152b201a6f.zip
Replace dos2unix with edos2unix for bug 162841 and fix missing asm/io.h.
(Portage version: 2.1.2.3)
-rw-r--r--media-video/vstrip/ChangeLog6
-rw-r--r--media-video/vstrip/files/vstrip-0.8f-gentoo.patch2
-rw-r--r--media-video/vstrip/vstrip-0.8f.ebuild19
3 files changed, 15 insertions, 12 deletions
diff --git a/media-video/vstrip/ChangeLog b/media-video/vstrip/ChangeLog
index 3c48ddc03e5d..155a63e66490 100644
--- a/media-video/vstrip/ChangeLog
+++ b/media-video/vstrip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/vstrip
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vstrip/ChangeLog,v 1.4 2007/02/03 21:14:30 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vstrip/ChangeLog,v 1.5 2007/03/31 19:26:38 drac Exp $
+
+ 31 Mar 2007; Samuli Suominen <drac@gentoo.org>
+ files/vstrip-0.8f-gentoo.patch, vstrip-0.8f.ebuild:
+ Change dos2unix to edos2unix and fix include location from patch.
03 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/media-video/vstrip/files/vstrip-0.8f-gentoo.patch b/media-video/vstrip/files/vstrip-0.8f-gentoo.patch
index e6551b9dc1e3..e157fea1734f 100644
--- a/media-video/vstrip/files/vstrip-0.8f-gentoo.patch
+++ b/media-video/vstrip/files/vstrip-0.8f-gentoo.patch
@@ -30,7 +30,7 @@
+#include <stdlib.h>
#include <stdio.h>
-#include <io.h>
-+#include <asm/io.h>
++#include <sys/io.h>
#include <fcntl.h>
#include "s_types.h"
#include "vstrip.h"
diff --git a/media-video/vstrip/vstrip-0.8f.ebuild b/media-video/vstrip/vstrip-0.8f.ebuild
index 31ce469f386c..bf73ab98fb40 100644
--- a/media-video/vstrip/vstrip-0.8f.ebuild
+++ b/media-video/vstrip/vstrip-0.8f.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vstrip/vstrip-0.8f.ebuild,v 1.3 2005/09/16 02:36:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vstrip/vstrip-0.8f.ebuild,v 1.4 2007/03/31 19:26:38 drac Exp $
inherit eutils
@@ -13,28 +13,27 @@ SLOT="0"
KEYWORDS="~ppc ~x86"
IUSE=""
-DEPEND="app-text/dos2unix
- app-arch/unzip"
+DEPEND="app-arch/unzip"
RDEPEND=""
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch ${FILESDIR}/vstrip-0.8f-gentoo.patch
- dos2unix -q -o *.c *.h
-
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ edos2unix *.c *.h
+
for file in *.c *.h ; do
echo >>$file
done
}
src_compile() {
- emake || die "emake failed"
+ emake || die "emake failed."
}
src_install() {
- dobin vstrip || die "dobin failed"
+ dobin vstrip
}