summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-16 17:26:39 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-16 17:26:39 +0000
commitaf04cdf053c955bf0e63940d4fa063149140ef13 (patch)
tree3662fc9ecf04b46b8ce402de848176c1715eddcf
parentVersion bump, closes #44580. (diff)
downloadgentoo-2-af04cdf053c955bf0e63940d4fa063149140ef13.tar.gz
gentoo-2-af04cdf053c955bf0e63940d4fa063149140ef13.tar.bz2
gentoo-2-af04cdf053c955bf0e63940d4fa063149140ef13.zip
fix DEPEND/RDEPEND #44816
-rw-r--r--app-misc/screen/screen-4.0.1-r2.ebuild11
-rw-r--r--dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild8
-rw-r--r--dev-util/strace/strace-4.4.98.ebuild15
-rw-r--r--games-strategy/freeciv/freeciv-1.14.1.ebuild7
-rw-r--r--sys-fs/xfsprogs/xfsprogs-2.3.9.ebuild15
5 files changed, 26 insertions, 30 deletions
diff --git a/app-misc/screen/screen-4.0.1-r2.ebuild b/app-misc/screen/screen-4.0.1-r2.ebuild
index cac8292664d0..68d12915e917 100644
--- a/app-misc/screen/screen-4.0.1-r2.ebuild
+++ b/app-misc/screen/screen-4.0.1-r2.ebuild
@@ -1,21 +1,22 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/screen/screen-4.0.1-r2.ebuild,v 1.4 2004/03/14 20:01:19 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/screen/screen-4.0.1-r2.ebuild,v 1.5 2004/03/16 17:24:55 vapier Exp $
inherit flag-o-matic
-IUSE="pam"
DESCRIPTION="Screen is a full-screen window manager that multiplexes a physical terminal between several processes"
HOMEPAGE="http://www.guckes.net/screen/"
SRC_URI="ftp://ftp.uni-erlangen.de/pub/utilities/screen/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 sparc ppc hppa amd64 mips alpha ia64 ppc64"
+IUSE="pam"
-DEPEND=">=sys-libs/ncurses-5.2
+RDEPEND=">=sys-libs/ncurses-5.2
>=sys-apps/sed-4
- pam? ( >=sys-libs/pam-0.75 )
+ pam? ( >=sys-libs/pam-0.75 )"
+DEPEND="${RDEPEND}"
>=sys-devel/autoconf-2.58"
src_unpack() {
diff --git a/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild b/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild
index 58b720a647f8..e0edc4cf6d74 100644
--- a/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild
+++ b/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild,v 1.9 2004/01/26 00:08:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild,v 1.10 2004/03/16 17:26:39 vapier Exp $
inherit libtool
@@ -14,11 +14,7 @@ KEYWORDS="x86 sparc ppc hppa alpha amd64 ia64"
DEPEND=">=sys-devel/automake-1.6.1
>=sys-devel/libtool-1.4.1-r8"
-
-src_compile() {
- econf || die "configure failure"
- emake || die "make failure"
-}
+RDEPEND=""
src_install() {
dodir /usr/{bin,include,lib}
diff --git a/dev-util/strace/strace-4.4.98.ebuild b/dev-util/strace/strace-4.4.98.ebuild
index 1eb86c5b27d6..50f4debc3cf3 100644
--- a/dev-util/strace/strace-4.4.98.ebuild
+++ b/dev-util/strace/strace-4.4.98.ebuild
@@ -1,19 +1,20 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.4.98.ebuild,v 1.11 2004/02/02 22:11:45 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.4.98.ebuild,v 1.12 2004/03/16 17:23:50 vapier Exp $
+
+inherit flag-o-matic
DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-RESTRICT="nomirror"
HOMEPAGE="http://www.wi.leidenuniv.nl/~wichert/strace/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-IUSE="static"
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
KEYWORDS="x86 ppc sparc ~alpha hppa mips amd64 ia64"
-inherit flag-o-matic
+IUSE="static"
-DEPEND="virtual/glibc
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND}
>=sys-devel/autoconf-2.54"
src_compile() {
diff --git a/games-strategy/freeciv/freeciv-1.14.1.ebuild b/games-strategy/freeciv/freeciv-1.14.1.ebuild
index 440f9f072183..fb6ef7248edd 100644
--- a/games-strategy/freeciv/freeciv-1.14.1.ebuild
+++ b/games-strategy/freeciv/freeciv-1.14.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/freeciv-1.14.1.ebuild,v 1.7 2004/02/03 19:22:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/freeciv-1.14.1.ebuild,v 1.8 2004/03/16 17:26:16 vapier Exp $
inherit games
@@ -13,11 +13,10 @@ SRC_URI="ftp://ftp.freeciv.org/freeciv/stable/${MY_P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~ppc sparc amd64"
+KEYWORDS="x86 ppc sparc amd64"
IUSE="X Xaw3d gtk gtk2 sdl nls readline"
-RDEPEND="
- X? ( virtual/x11 )
+RDEPEND="X? ( virtual/x11 )
Xaw3d? ( x11-libs/Xaw3d )
readline ( sys-libs/readline )
>=sys-devel/bison-1.35
diff --git a/sys-fs/xfsprogs/xfsprogs-2.3.9.ebuild b/sys-fs/xfsprogs/xfsprogs-2.3.9.ebuild
index 39e2d93b537c..4f4cae9ed89e 100644
--- a/sys-fs/xfsprogs/xfsprogs-2.3.9.ebuild
+++ b/sys-fs/xfsprogs/xfsprogs-2.3.9.ebuild
@@ -1,21 +1,20 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-2.3.9.ebuild,v 1.4 2004/01/31 11:11:14 ferringb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-2.3.9.ebuild,v 1.5 2004/03/16 17:22:53 vapier Exp $
inherit flag-o-matic
+DESCRIPTION="xfs filesystem utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
#SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
SRC_URI="mirror://gentoo/${P}.src.tar.gz"
-HOMEPAGE="http://oss.sgi.com/projects/xfs"
-DESCRIPTION="xfs filesystem utilities"
-SLOT="0"
LICENSE="LGPL-2.1"
-KEYWORDS="x86 amd64 alpha mips hppa ia64 ~ppc"
-
-S=${WORKDIR}/${P}
+SLOT="0"
+KEYWORDS="x86 ~ppc alpha mips hppa ia64 amd64"
-DEPEND="sys-fs/e2fsprogs
+RDEPEND="sys-fs/e2fsprogs"
+DEPEND="${RDEPEND}
sys-devel/autoconf
>=sys-apps/sed-4"