summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-06-30 04:27:29 +0000
committerMike Gilbert <floppym@gentoo.org>2014-06-30 04:27:29 +0000
commitd6547493506ff49cf23d8df18de721652a96d502 (patch)
treeb0688fffaac849d9ff30d65d4e82b67a543f03c4
parentDepend on setuptools. (diff)
downloadgentoo-2-d6547493506ff49cf23d8df18de721652a96d502.tar.gz
gentoo-2-d6547493506ff49cf23d8df18de721652a96d502.tar.bz2
gentoo-2-d6547493506ff49cf23d8df18de721652a96d502.zip
Convert to distutils-r1. Depend on setuptools.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
-rw-r--r--sci-biology/pysam/ChangeLog11
-rw-r--r--sci-biology/pysam/pysam-0.6-r1.ebuild24
-rw-r--r--sci-biology/pysam/pysam-0.6.ebuild19
3 files changed, 32 insertions, 22 deletions
diff --git a/sci-biology/pysam/ChangeLog b/sci-biology/pysam/ChangeLog
index 595c359ae60e..3ff678500d52 100644
--- a/sci-biology/pysam/ChangeLog
+++ b/sci-biology/pysam/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/pysam
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/pysam/ChangeLog,v 1.3 2013/03/11 16:50:14 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/pysam/ChangeLog,v 1.4 2014/06/30 04:27:29 floppym Exp $
+
+*pysam-0.6-r1 (30 Jun 2014)
+
+ 30 Jun 2014; Mike Gilbert <floppym@gentoo.org> +pysam-0.6-r1.ebuild,
+ -pysam-0.6.ebuild:
+ Convert to distutils-r1. Depend on setuptools.
11 Mar 2013; Justin Lecher <jlec@gentoo.org> metadata.xml:
Drop Andrey as maintainer so that bugs get assigned to sci-biology directly
@@ -13,4 +19,3 @@
29 Jan 2012; Andrey Kislyuk <weaver@gentoo.org> +pysam-0.6.ebuild,
+metadata.xml:
New package, ebuild written by me
-
diff --git a/sci-biology/pysam/pysam-0.6-r1.ebuild b/sci-biology/pysam/pysam-0.6-r1.ebuild
new file mode 100644
index 000000000000..9db2aad912f4
--- /dev/null
+++ b/sci-biology/pysam/pysam-0.6-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/pysam/pysam-0.6-r1.ebuild,v 1.1 2014/06/30 04:27:29 floppym Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for the SAM/BAM sequence alignment and mapping format"
+HOMEPAGE="http://code.google.com/p/pysam http://pypi.python.org/pypi/pysam"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
diff --git a/sci-biology/pysam/pysam-0.6.ebuild b/sci-biology/pysam/pysam-0.6.ebuild
deleted file mode 100644
index 664245fb580c..000000000000
--- a/sci-biology/pysam/pysam-0.6.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/pysam/pysam-0.6.ebuild,v 1.2 2012/02/25 02:56:39 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* 2.5 2.7-pypy-* *-jython"
-
-inherit distutils
-
-DESCRIPTION="Python interface for the SAM/BAM sequence alignment and mapping format"
-HOMEPAGE="http://code.google.com/p/${PN} http://pypi.python.org/pypi/${PN}"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""