summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-20 13:50:07 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-20 13:50:07 +0000
commited076862c1f1611082f7f0c3574fb427937cbc71 (patch)
tree3cecc566bef0d6fbef78d06c02ca029ca10f3723 /app-admin/longrun
parentclean old ebuild (Manifest recommit) (diff)
downloadgentoo-2-ed076862c1f1611082f7f0c3574fb427937cbc71.tar.gz
gentoo-2-ed076862c1f1611082f7f0c3574fb427937cbc71.tar.bz2
gentoo-2-ed076862c1f1611082f7f0c3574fb427937cbc71.zip
inherit eutils for epatch; error check
Diffstat (limited to 'app-admin/longrun')
-rw-r--r--app-admin/longrun/ChangeLog5
-rw-r--r--app-admin/longrun/longrun-0.9-r1.ebuild18
2 files changed, 13 insertions, 10 deletions
diff --git a/app-admin/longrun/ChangeLog b/app-admin/longrun/ChangeLog
index 34456de5be8e..c7b03ea44636 100644
--- a/app-admin/longrun/ChangeLog
+++ b/app-admin/longrun/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-admin/longrun
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/longrun/ChangeLog,v 1.6 2004/03/20 13:48:25 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/longrun/ChangeLog,v 1.7 2004/03/20 13:50:07 mr_bones_ Exp $
+
+ 20 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> longrun-0.9-r1.ebuild:
+ inherit eutils for epatch; error check
20 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> longrun-0.9.ebuild:
clean old ebuild
diff --git a/app-admin/longrun/longrun-0.9-r1.ebuild b/app-admin/longrun/longrun-0.9-r1.ebuild
index f981529b8cdc..734331bf7e9a 100644
--- a/app-admin/longrun/longrun-0.9-r1.ebuild
+++ b/app-admin/longrun/longrun-0.9-r1.ebuild
@@ -1,11 +1,13 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/longrun/longrun-0.9-r1.ebuild,v 1.6 2004/03/12 10:45:38 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/longrun/longrun-0.9-r1.ebuild,v 1.7 2004/03/20 13:50:07 mr_bones_ Exp $
-S=${WORKDIR}/${PN}
+inherit eutils
+
+S="${WORKDIR}/${PN}"
DESCRIPTION="A utility to control Transmeta's Crusoe processor"
-SRC_URI="mirror://kernel/linux/utils/cpu/crusoe/${P}.tar.bz2"
HOMEPAGE="http://freshmeat.net/projects/longrun/"
+SRC_URI="mirror://kernel/linux/utils/cpu/crusoe/${P}.tar.bz2"
IUSE=""
SLOT="0"
@@ -17,17 +19,15 @@ DEPEND="virtual/glibc"
# Include fix from debian
src_unpack() {
unpack ${A} ; cd ${S}
- epatch ${FILESDIR}/${PF}-debian-gcc-3.diff
+ epatch "${FILESDIR}/${PF}-debian-gcc-3.diff"
}
src_compile() {
- emake || die
+ emake || die "emake failed"
}
src_install() {
- dosbin longrun
-
+ dosbin longrun || die "dosbin failed"
doman longrun.1
-
- dodoc COPYING MAKEDEV-cpuid-msr
+ dodoc MAKEDEV-cpuid-msr
}