summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-25 23:07:33 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-25 23:07:33 +0000
commit76f0815ddd429335e2d91e99cfd9b0bab25ae5e7 (patch)
tree978be750f80e70f5af9c85b87de6d0f13932eff7 /app-admin/watchdog
parentstable on amd64 (Manifest recommit) (diff)
downloadgentoo-2-76f0815ddd429335e2d91e99cfd9b0bab25ae5e7.tar.gz
gentoo-2-76f0815ddd429335e2d91e99cfd9b0bab25ae5e7.tar.bz2
gentoo-2-76f0815ddd429335e2d91e99cfd9b0bab25ae5e7.zip
use virtual/libc
Diffstat (limited to 'app-admin/watchdog')
-rw-r--r--app-admin/watchdog/watchdog-5.2.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/app-admin/watchdog/watchdog-5.2.ebuild b/app-admin/watchdog/watchdog-5.2.ebuild
index de77ee2fe7bc..c2efbcb97d86 100644
--- a/app-admin/watchdog/watchdog-5.2.ebuild
+++ b/app-admin/watchdog/watchdog-5.2.ebuild
@@ -1,18 +1,19 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/watchdog-5.2.ebuild,v 1.17 2004/06/24 21:42:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/watchdog-5.2.ebuild,v 1.18 2004/06/25 23:06:54 vapier Exp $
inherit eutils
-IUSE=""
-DESCRIPTION="A software watchdog."
+DESCRIPTION="A software watchdog"
HOMEPAGE="http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/"
SRC_URI="http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 -ppc"
-DEPEND="virtual/glibc"
+IUSE=""
+
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A} ; cd ${S}
@@ -21,31 +22,26 @@ src_unpack() {
}
src_compile() {
- # Two configure switches have been added to use /etc/watchdog
econf \
--sysconfdir=/etc/watchdog \
- --with-configfile=/etc/watchdog/watchdog.conf || die "econf failed"
+ --with-configfile=/etc/watchdog/watchdog.conf \
+ || die "econf failed"
emake || die
}
src_install() {
dodir /etc/watchdog
make DESTDIR="${D}" install || die
-
exeinto /etc/init.d
doexe "${FILESDIR}/${PVR}/watchdog"
}
pkg_postinst() {
- einfo
einfo "To enable the start-up script run \"rc-update add watchdog boot\"."
- einfo
- if [ ! -e /dev/watchdog ]
+ if [ ! -e ${ROOT}/dev/watchdog ]
then
- ewarn
ewarn "No /dev/watchdog found! Make sure your kernel has watchdog support"
ewarn "compiled in or the kernel module is loaded. The watchdog service"
ewarn "will not start at boot until your kernel is configured properly."
- ewarn
fi
}