summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-01-19 00:55:56 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-01-19 00:55:56 +0000
commita1b8b12338dd8f92fd27b76b327704f209c920f6 (patch)
tree2edafb9de406d42019e86524209fcbff9f7a9ce3 /app-arch/arj
parentAdded installation of examples based on doc USE flag and closing bug #76945. (diff)
downloadgentoo-2-a1b8b12338dd8f92fd27b76b327704f209c920f6.tar.gz
gentoo-2-a1b8b12338dd8f92fd27b76b327704f209c920f6.tar.bz2
gentoo-2-a1b8b12338dd8f92fd27b76b327704f209c920f6.zip
repoman: Fix leading whitespace
Diffstat (limited to 'app-arch/arj')
-rw-r--r--app-arch/arj/arj-3.10.21.ebuild56
1 files changed, 28 insertions, 28 deletions
diff --git a/app-arch/arj/arj-3.10.21.ebuild b/app-arch/arj/arj-3.10.21.ebuild
index fca1d6b4f781..19e388fd9944 100644
--- a/app-arch/arj/arj-3.10.21.ebuild
+++ b/app-arch/arj/arj-3.10.21.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/arj/arj-3.10.21.ebuild,v 1.4 2005/01/01 22:12:53 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/arj/arj-3.10.21.ebuild,v 1.5 2005/01/19 00:55:56 mr_bones_ Exp $
inherit gnuconfig eutils gcc
@@ -17,34 +17,34 @@ RESTRICT="nostrip"
DEPEND="virtual/libc"
src_compile() {
- if [ -x /usr/sbin/gcc-config ]
- then
- # Do we have a gcc that use the new layout and gcc-config ?
- if /usr/sbin/gcc-config --get-current-profile &> /dev/null
- then
- export GCC_PROFILE="$(/usr/sbin/gcc-config --get-current-profile)"
+ if [ -x /usr/sbin/gcc-config ]
+ then
+ # Do we have a gcc that use the new layout and gcc-config ?
+ if /usr/sbin/gcc-config --get-current-profile &> /dev/null
+ then
+ export GCC_PROFILE="$(/usr/sbin/gcc-config --get-current-profile)"
- # Just recheck gcc version ...
- if [ "$(gcc-version)" != "3.2" ] && [ "$(gcc-version)" != "3.3" ]
- then
- # See if we can get a gcc profile we know is proper ...
- if /usr/sbin/gcc-config --get-bin-path ${CHOST}-3.3.4 &> /dev/null
- then
- export PATH="$(/usr/sbin/gcc-config --get-bin-path ${CHOST}-3.3.4):${PATH}"
- export GCC_PROFILE="${CHOST}-3.3.4"
- else
- eerror "This build needs gcc-3.2 or gcc-3.3!"
- eerror
- eerror "Use gcc-config to change your gcc profile:"
- eerror
- eerror " # gcc-config $CHOST-3.3.4"
- eerror
- eerror "or whatever gcc version is relevant."
- die
- fi
- fi
- fi
- fi
+ # Just recheck gcc version ...
+ if [ "$(gcc-version)" != "3.2" ] && [ "$(gcc-version)" != "3.3" ]
+ then
+ # See if we can get a gcc profile we know is proper ...
+ if /usr/sbin/gcc-config --get-bin-path ${CHOST}-3.3.4 &> /dev/null
+ then
+ export PATH="$(/usr/sbin/gcc-config --get-bin-path ${CHOST}-3.3.4):${PATH}"
+ export GCC_PROFILE="${CHOST}-3.3.4"
+ else
+ eerror "This build needs gcc-3.2 or gcc-3.3!"
+ eerror
+ eerror "Use gcc-config to change your gcc profile:"
+ eerror
+ eerror " # gcc-config $CHOST-3.3.4"
+ eerror
+ eerror "or whatever gcc version is relevant."
+ die
+ fi
+ fi
+ fi
+ fi
gnuconfig_update