summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-27 09:48:28 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-27 09:48:28 +0000
commit56b5e97ef6f0ae413f0d42a02756a1ef76c9bf33 (patch)
tree6851ba68b28390d394e5cd42105b934e37947b15 /app-arch/lbzip2/lbzip2-0.23-r1.ebuild
parentFix tests, bug 288689 (diff)
downloadgentoo-2-56b5e97ef6f0ae413f0d42a02756a1ef76c9bf33.tar.gz
gentoo-2-56b5e97ef6f0ae413f0d42a02756a1ef76c9bf33.tar.bz2
gentoo-2-56b5e97ef6f0ae413f0d42a02756a1ef76c9bf33.zip
Add support for symlink decompression #309683
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/lbzip2/lbzip2-0.23-r1.ebuild')
-rw-r--r--app-arch/lbzip2/lbzip2-0.23-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-arch/lbzip2/lbzip2-0.23-r1.ebuild b/app-arch/lbzip2/lbzip2-0.23-r1.ebuild
new file mode 100644
index 000000000000..10d65dcb8c88
--- /dev/null
+++ b/app-arch/lbzip2/lbzip2-0.23-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-0.23-r1.ebuild,v 1.1 2010/03/27 09:48:27 jlec Exp $
+
+EAPI="3"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Pthreads-based parallel bzip2/bunzip2 filter, passable to GNU tar"
+HOMEPAGE="http://lacos.hu/"
+SRC_URI="http://lacos.web.elte.hu/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="symlink test"
+
+RDEPEND="app-arch/bzip2"
+DEPEND="${REDEPEND}
+ test? (
+ app-shells/dash
+ sys-process/time
+ )"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-s_isreg.patch
+ epatch "${FILESDIR}"/0.22-Makefile.patch
+}
+
+src_compile() {
+ append-lfs-flags
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_test() {
+ if [ -t 0 ] || return; then
+ rm -rf "${T}/scratch" "${T}/results" "${T}/rnd"
+ hexdump -n 10485760 /dev/urandom > "${T}/rnd"
+ emake -j1 SHELL="${EPREFIX}"/bin/dash PATH="${S}:${PATH}" TESTFILE="${T}/rnd" check \
+ || die "make check failed"
+ else
+ ewarn "make check must be run attached to a terminal"
+ fi
+}
+
+src_install() {
+ dobin ${PN} || die "Installation of ${PN} failed"
+ dodoc ChangeLog README || die "no docs"
+ doman ${PN}.1 || die "no man"
+ insinto /usr/share/${PN}
+ doins corr-perf.sh malloc_trace.pl || die
+
+ if use symlink; then
+ dosym ${PN} /usr/bin/bzip2 || die
+ fi
+}