summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-08-12 21:27:06 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-08-12 21:27:06 +0000
commit9e5052a93a375640edbe05355d0382f862a92175 (patch)
treeb323a9b8ef0db19b63b5764f87e7535aced9abc4 /app-arch/unrar/unrar-3.4.2.ebuild
parentAdding missing metadata.xml. (Manifest recommit) (diff)
downloadgentoo-2-9e5052a93a375640edbe05355d0382f862a92175.tar.gz
gentoo-2-9e5052a93a375640edbe05355d0382f862a92175.tar.bz2
gentoo-2-9e5052a93a375640edbe05355d0382f862a92175.zip
Version bump and unmask.
Diffstat (limited to 'app-arch/unrar/unrar-3.4.2.ebuild')
-rw-r--r--app-arch/unrar/unrar-3.4.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-arch/unrar/unrar-3.4.2.ebuild b/app-arch/unrar/unrar-3.4.2.ebuild
new file mode 100644
index 000000000000..66daf37489ae
--- /dev/null
+++ b/app-arch/unrar/unrar-3.4.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unrar/unrar-3.4.2.ebuild,v 1.1 2004/08/12 21:27:06 aliz Exp $
+
+MY_PN=${PN}src
+DESCRIPTION="Uncompress rar files"
+HOMEPAGE="http://www.rarlab.com/rar_add.htm"
+SRC_URI="http://www.rarlab.com/rar/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="unRAR"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ppc64 ~macos"
+IUSE=""
+
+DEPEND=""
+
+S="${WORKDIR}/unrar"
+
+src_compile() {
+ emake -f makefile.unix CXXFLAGS="$CXXFLAGS" || die "emake failed"
+}
+
+src_install() {
+ dobin unrar || die "dobin failed"
+ dodoc readme.txt
+}