summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-06-13 00:31:02 +0000
committerMike Frysinger <vapier@gentoo.org>2007-06-13 00:31:02 +0000
commit5386a575b8477dbfd8d6cd52ddda7567208334d5 (patch)
treeada7dec52865de5f1bf89e08245b365b8279d53e /app-arch/zip
parentold (diff)
downloadgentoo-2-5386a575b8477dbfd8d6cd52ddda7567208334d5.tar.gz
gentoo-2-5386a575b8477dbfd8d6cd52ddda7567208334d5.tar.bz2
gentoo-2-5386a575b8477dbfd8d6cd52ddda7567208334d5.zip
Respect build flags #181783.
(Portage version: 2.1.2.9)
Diffstat (limited to 'app-arch/zip')
-rw-r--r--app-arch/zip/ChangeLog6
-rw-r--r--app-arch/zip/files/zip-2.31-make.patch16
-rw-r--r--app-arch/zip/zip-2.32.ebuild15
3 files changed, 24 insertions, 13 deletions
diff --git a/app-arch/zip/ChangeLog b/app-arch/zip/ChangeLog
index 12a64ba43802..aaf0b770200f 100644
--- a/app-arch/zip/ChangeLog
+++ b/app-arch/zip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/zip
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/ChangeLog,v 1.65 2007/06/11 19:48:34 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/ChangeLog,v 1.66 2007/06/13 00:31:02 vapier Exp $
+
+ 13 Jun 2007; Mike Frysinger <vapier@gentoo.org> files/zip-2.31-make.patch,
+ zip-2.32.ebuild:
+ Respect build flags #181783.
11 Jun 2007; Raúl Porcel <armin76@gentoo.org> zip-2.32.ebuild:
alpha stable
diff --git a/app-arch/zip/files/zip-2.31-make.patch b/app-arch/zip/files/zip-2.31-make.patch
index 0e862e62f275..3b0606457e30 100644
--- a/app-arch/zip/files/zip-2.31-make.patch
+++ b/app-arch/zip/files/zip-2.31-make.patch
@@ -1,8 +1,6 @@
-Index: zip-2.31/unix/Makefile
-===================================================================
---- zip-2.31.orig/unix/Makefile
+--- zip-2.31/unix/Makefile
+++ zip-2.31/unix/Makefile
-@@ -13,7 +13,7 @@ all:
+@@ -13,15 +13,15 @@
list: all
@@ -11,3 +9,13 @@ Index: zip-2.31/unix/Makefile
SHELL = /bin/sh
LN = ln -s
+ # (to use the Gnu compiler, change cc to gcc in CC)
+-CC = cc
++CC ?= gcc
+ BIND = $(CC)
+ AS = $(CC) -c
+-CPP = /lib/cpp
++CPP ?= $(CC)
+ EXE =
+
+ # probably can change this to 'install' if you have it
diff --git a/app-arch/zip/zip-2.32.ebuild b/app-arch/zip/zip-2.32.ebuild
index 2c06b2f8eb91..590ad78f393c 100644
--- a/app-arch/zip/zip-2.32.ebuild
+++ b/app-arch/zip/zip-2.32.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/zip-2.32.ebuild,v 1.11 2007/06/11 19:48:34 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/zip-2.32.ebuild,v 1.12 2007/06/13 00:31:02 vapier Exp $
inherit toolchain-funcs eutils flag-o-matic
@@ -21,17 +21,16 @@ src_unpack() {
epatch "${FILESDIR}"/zip-2.3-unix_configure-pic.patch
epatch "${FILESDIR}"/${PN}-2.31-exec-stack.patch
epatch "${FILESDIR}"/${PN}-2.31-make.patch
- cd unix
use crypt || append-flags -DNO_CRYPT
- sed -i -e "s:-O2:${CFLAGS}:" Makefile
+ sed -i \
+ -e "s:-O[23]:${CFLAGS}:" \
+ -e '/^LFLAGS1=""/s:=.*:="${LDFLAGS}":' \
+ unix/configure
}
src_compile() {
- emake \
- -f unix/Makefile \
- CC="$(tc-getCC)" \
- CPP="$(tc-getCC) -E" \
- generic || die
+ tc-export CC CPP
+ emake -f unix/Makefile generic || die
}
src_install() {