summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2001-06-21 15:26:25 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2001-06-21 15:26:25 +0000
commit7a91dfb87ff9014862e36151470b2e240623d5a2 (patch)
tree2189fd7d8a21cf8e7080d894fe5100940bcf5531 /app-crypt/krb5/krb5-1.2.2.ebuild
parentutilities for type 1 fonts (diff)
downloadgentoo-2-7a91dfb87ff9014862e36151470b2e240623d5a2.tar.gz
gentoo-2-7a91dfb87ff9014862e36151470b2e240623d5a2.tar.bz2
gentoo-2-7a91dfb87ff9014862e36151470b2e240623d5a2.zip
Kerberos V and PAM; new ebuilds
Diffstat (limited to 'app-crypt/krb5/krb5-1.2.2.ebuild')
-rw-r--r--app-crypt/krb5/krb5-1.2.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-crypt/krb5/krb5-1.2.2.ebuild b/app-crypt/krb5/krb5-1.2.2.ebuild
new file mode 100644
index 000000000000..2c8498d40905
--- /dev/null
+++ b/app-crypt/krb5/krb5-1.2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Grant Goodyear <grant@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/krb5/krb5-1.2.2.ebuild,v 1.1 2001/06/21 15:26:25 g2boojum Exp $
+
+#P=
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+SRC_URI="http://www.crypto-publish.org/dist/mit-kerberos5/${A1}"
+DESCRIPTION="MIT Kerberos V (set up for pam)"
+HOMEPAGE="http://crypto-publish.org"
+
+DEPEND="virtual/glibc"
+
+
+src_compile() {
+
+ cd ${S}/src
+ try ./configure --with-krb4 --enable-shared --prefix=/usr --host=${CHOST}
+ mv Makefile Makefile.orig
+ #Don't install the ftp, telnet, r* apps; use pam instead
+ sed -e 's/ appl //' Makefile.orig > Makefile
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}/src
+ try make DESTDIR=${D} install
+ cd ..
+ dodoc README
+ echo 'NOTE: ftp, telnet, r* apps not installed. Install pam-krb5!'
+
+}
+