summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-10-04 19:14:38 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-10-04 19:14:38 +0000
commit1d583017795f40565c45cb4cf44c7d8005da0d48 (patch)
treecfca836d6f9c5076d96180adfb05dd89694973c5 /app-doc/psmark
parentalpha/arm/ia64/sh/sparc stable wrt #287362 (diff)
downloadgentoo-2-1d583017795f40565c45cb4cf44c7d8005da0d48.tar.gz
gentoo-2-1d583017795f40565c45cb4cf44c7d8005da0d48.tar.bz2
gentoo-2-1d583017795f40565c45cb4cf44c7d8005da0d48.zip
respecting LDFLAGS, fixing pre-stripped files bug 240001, respecting CC variable bug 243554, fixing repoman warnings
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-doc/psmark')
-rw-r--r--app-doc/psmark/ChangeLog7
-rw-r--r--app-doc/psmark/files/psmark-2.1-Makefile-QA.patch19
-rw-r--r--app-doc/psmark/psmark-2.1.ebuild19
3 files changed, 37 insertions, 8 deletions
diff --git a/app-doc/psmark/ChangeLog b/app-doc/psmark/ChangeLog
index c3f71a3b162a..c622c2b819b8 100644
--- a/app-doc/psmark/ChangeLog
+++ b/app-doc/psmark/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-doc/psmark
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/psmark/ChangeLog,v 1.2 2009/09/23 15:19:33 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/psmark/ChangeLog,v 1.3 2009/10/04 19:14:37 vostorga Exp $
+
+ 04 Oct 2009; Víctor Ostorga <vostorga@gentoo.org> psmark-2.1.ebuild,
+ +files/psmark-2.1-Makefile-QA.patch:
+ respecting LDFLAGS, fixing pre-stripped files bug 240001, respecting CC
+ variable bug 243554, fixing repoman warnings
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> psmark-2.1.ebuild:
Remove virtual/libc
diff --git a/app-doc/psmark/files/psmark-2.1-Makefile-QA.patch b/app-doc/psmark/files/psmark-2.1-Makefile-QA.patch
new file mode 100644
index 000000000000..30a81498bf6d
--- /dev/null
+++ b/app-doc/psmark/files/psmark-2.1-Makefile-QA.patch
@@ -0,0 +1,19 @@
+--- Makefile.original 2009-10-04 19:06:09.000000000 -0600
++++ Makefile 2009-10-04 19:08:25.000000000 -0600
+@@ -3,14 +3,13 @@
+ all:
+ make clean
+ make psmark
+
+ psmark:
+- gcc $(CFLAGS) -o psmark psmark.c
+- strip psmark
++ $(CC) $(CFLAGS) $(LDFLAGS) -o psmark psmark.c
+
+ clean:
+ rm -f *.o psmark
+
+ install:
+- install -s psmark /usr/bin/
++ install psmark /usr/bin/
+ install psmark.1 /usr/man/man1/
diff --git a/app-doc/psmark/psmark-2.1.ebuild b/app-doc/psmark/psmark-2.1.ebuild
index efce294482ef..c41db755a659 100644
--- a/app-doc/psmark/psmark-2.1.ebuild
+++ b/app-doc/psmark/psmark-2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/psmark/psmark-2.1.ebuild,v 1.2 2009/09/23 15:19:33 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/psmark/psmark-2.1.ebuild,v 1.3 2009/10/04 19:14:37 vostorga Exp $
inherit eutils toolchain-funcs
@@ -20,14 +20,19 @@ KEYWORDS="~x86"
DEPEND=""
RDEPEND="${DEPEND}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-string.patch
+ epatch "${FILESDIR}"/${P}-Makefile-QA.patch
+}
+
src_compile() {
- cd ${S}
- epatch ${FILESDIR}/${P}-string.patch || die "epatch failed"
- make CFLAGS="${CFLAGS}" || die "make failed"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "make failed"
}
src_install() {
- dobin psmark
- doman psmark.1
- dodoc README CHANGELOG COPYING
+ dobin psmark || die "dobin failed"
+ doman psmark.1 || die "doman failed"
+ dodoc README CHANGELOG || die "dodoc failed"
}