summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2003-02-18 11:34:23 +0000
committerLuca Barbato <lu_zero@gentoo.org>2003-02-18 11:34:23 +0000
commitb81d26517e523f0b3eccd92d227f5368d9ac78b8 (patch)
tree15ccc49a1bd60ce671343212d10893f1b07a0c0a /app-editors/bluefish/bluefish-0.9.ebuild
parentAdded a missing depend on media-libs/ladspa-sdk (diff)
downloadgentoo-2-b81d26517e523f0b3eccd92d227f5368d9ac78b8.tar.gz
gentoo-2-b81d26517e523f0b3eccd92d227f5368d9ac78b8.tar.bz2
gentoo-2-b81d26517e523f0b3eccd92d227f5368d9ac78b8.zip
Version bump
Diffstat (limited to 'app-editors/bluefish/bluefish-0.9.ebuild')
-rw-r--r--app-editors/bluefish/bluefish-0.9.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-editors/bluefish/bluefish-0.9.ebuild b/app-editors/bluefish/bluefish-0.9.ebuild
new file mode 100644
index 000000000000..c7adb1cb3d7c
--- /dev/null
+++ b/app-editors/bluefish/bluefish-0.9.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-0.9.ebuild,v 1.1 2003/02/18 11:34:23 lu_zero Exp $
+
+#MY_P=${PN}-gtk2-${PV}
+#S=${WORKDIR}/${MY_P}
+DESCRIPTION="Bluefish is a GTK HTML editor for the experienced web designer or programmer."
+SRC_URI="http://pkedu.fbt.eitn.wau.nl/~olivier/downloads/${P}.tar.bz2"
+HOMEPAGE="http://bluefish.openoffice.nl/"
+
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc ~sparc"
+SLOT="0"
+IUSE="nls perl"
+
+DEPEND=">=x11-libs/gtk+-2.0.5
+ >=media-libs/freetype-2.0.9
+ >=media-libs/gdk-pixbuf-0.18
+ dev-libs/libpcre
+ perl? ( sys-devel/perl )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf="--with-autocomplet"
+ use perl && myconf="${myconf} --with-perl"
+ use nls || myconf="${myconf} --disable-nls"
+ econf ${myconf}
+
+ emake || die
+
+}
+
+src_install() {
+ cd ${S}
+ sed -e "s:"/usr/share":"${D}/usr/share":g" Makefile \
+ > Makefile.new
+ cp Makefile.new Makefile
+ cd data
+ sed -e "s:"/usr/share":"${D}/usr/share":g" Makefile \
+ > Makefile.new
+ cp Makefile.new Makefile
+ einstall datadir=${D}/usr/share \
+ pkgdatadir=${D}/usr/share/bluefish
+# pixmapsdir=${D}/usr/share/pixmap \
+}