summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-02-07 07:38:29 +0000
committerPeter Gavin <pete@gentoo.org>2001-02-07 07:38:29 +0000
commit0c97e8665ecc92c73212fe45d57534bac642ce5c (patch)
tree18dfdcace34ce1fee06daf346854b3fa8312c7d2 /app-editors/emacs-x11
parentchanged the mount /boot to just a warning message (diff)
downloadgentoo-2-0c97e8665ecc92c73212fe45d57534bac642ce5c.tar.gz
gentoo-2-0c97e8665ecc92c73212fe45d57534bac642ce5c.tar.bz2
gentoo-2-0c97e8665ecc92c73212fe45d57534bac642ce5c.zip
same as emacs-x11-20.7.ebuild, just changed the prefix to /usr
Diffstat (limited to 'app-editors/emacs-x11')
-rw-r--r--app-editors/emacs-x11/emacs-x11-20.7-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-editors/emacs-x11/emacs-x11-20.7-r1.ebuild b/app-editors/emacs-x11/emacs-x11-20.7-r1.ebuild
new file mode 100644
index 000000000000..15e089b7561a
--- /dev/null
+++ b/app-editors/emacs-x11/emacs-x11-20.7-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Peter Gavin <pbg1854@garnet.acns.fsu.edu>
+
+A=emacs-20.7.tar.gz
+S=${WORKDIR}/emacs-20.7
+DESCRIPTION="An incredibly powerful, extensible text editor (X11 version)"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/emacs/emacs-20.7.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/emacs"
+RDEPEND=">=sys-libs/ncurses-4.0
+ >=sys-libs/glibc-2.0
+ >=x11-base/xfree-4.0
+ !app-editors/emacs-nogui
+ !app-editors/emacs-motif"
+
+DEPEND=">=sys-libs/ncurses-4.0
+ >=sys-libs/glibc-2.0
+ >=x11-base/xfree-4.0
+ >=sys-devel/gettext-0.10.35"
+
+src_compile() {
+ cd ${S}
+ try ./configure --prefix=/usr --libexecdir=/usr/X11R6/lib --host=${CHOST} --with-x
+ try make
+}
+
+src_install () {
+ cd ${S}
+ try make prefix=${D}/usr/X11R6 libexecdir=${D}/usr/X11R6/lib install
+ dodoc BUGS ChangeLog README
+ gzip -9 ${D}/usr/X11R6/info/*
+}
+