summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-01 23:25:24 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-01 23:25:24 +0000
commitb174e68e0595e4438947a46143a75c538a13f765 (patch)
tree2e46b088cd0da73ab932ff5fbd633c1b21a1eaf8 /app-editors/emacs
parentdie backticks (Manifest recommit) (diff)
downloadgentoo-2-b174e68e0595e4438947a46143a75c538a13f765.tar.gz
gentoo-2-b174e68e0595e4438947a46143a75c538a13f765.tar.bz2
gentoo-2-b174e68e0595e4438947a46143a75c538a13f765.zip
Fix use invocation
Diffstat (limited to 'app-editors/emacs')
-rw-r--r--app-editors/emacs/ChangeLog6
-rw-r--r--app-editors/emacs/emacs-21.3-r2.ebuild6
-rw-r--r--app-editors/emacs/emacs-21.3-r3.ebuild6
3 files changed, 11 insertions, 7 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index e21c3ca80cc9..18f48b899140 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/emacs
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.27 2004/05/17 06:30:04 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.28 2004/06/01 23:23:25 agriffis Exp $
+
+ 01 Jun 2004; Aron Griffis <agriffis@gentoo.org> emacs-21.3-r2.ebuild,
+ emacs-21.3-r3.ebuild:
+ Fix use invocation
17 May 2004; <mkennedy@gentoo.org> files/emacs-18.59-gcc-gentoo.patch:
Remove compiler option adjustments which made the build incompatible with GCC
diff --git a/app-editors/emacs/emacs-21.3-r2.ebuild b/app-editors/emacs/emacs-21.3-r2.ebuild
index d693e356d1d5..788887dc3e26 100644
--- a/app-editors/emacs/emacs-21.3-r2.ebuild
+++ b/app-editors/emacs/emacs-21.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.3-r2.ebuild,v 1.13 2004/04/09 06:41:32 iggy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.3-r2.ebuild,v 1.14 2004/06/01 23:23:25 agriffis Exp $
inherit flag-o-matic eutils
@@ -55,9 +55,9 @@ src_compile() {
--with-tiff
--with-gif
--with-png"
- if [ "`use motif`" ] ; then
+ if use motif ; then
myconf="${myconf} --with-x-toolkit=motif"
- elif [ "`use Xaw3d`" ] ; then
+ elif use Xaw3d ; then
myconf="${myconf} --with-x-toolkit=athena"
else
# do not build emacs with any toolkit, bug 35300
diff --git a/app-editors/emacs/emacs-21.3-r3.ebuild b/app-editors/emacs/emacs-21.3-r3.ebuild
index 961b3e3a25a6..b1e1ed5b003c 100644
--- a/app-editors/emacs/emacs-21.3-r3.ebuild
+++ b/app-editors/emacs/emacs-21.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.3-r3.ebuild,v 1.3 2004/05/26 02:48:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.3-r3.ebuild,v 1.4 2004/06/01 23:23:25 agriffis Exp $
inherit flag-o-matic eutils
@@ -62,9 +62,9 @@ src_compile() {
--with-tiff
--with-gif
--with-png"
- if [ "`use motif`" ] ; then
+ if use motif ; then
myconf="${myconf} --with-x-toolkit=motif"
- elif [ "`use Xaw3d`" ] ; then
+ elif use Xaw3d ; then
myconf="${myconf} --with-x-toolkit=athena"
else
# do not build emacs with any toolkit, bug 35300