summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-06-13 19:34:52 +0000
committerPacho Ramos <pacho@gentoo.org>2010-06-13 19:34:52 +0000
commit952321d8437871f2cc69d24d86a3af1cb1af84c5 (patch)
tree80fbd9e0fc4ca90679ca7ecb4482bd67c5b0fb0e /app-editors/gedit
parentAdd new version for Gnome 2.30 (diff)
downloadgentoo-2-952321d8437871f2cc69d24d86a3af1cb1af84c5.tar.gz
gentoo-2-952321d8437871f2cc69d24d86a3af1cb1af84c5.tar.bz2
gentoo-2-952321d8437871f2cc69d24d86a3af1cb1af84c5.zip
Add new version for Gnome 2.30
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/gedit')
-rw-r--r--app-editors/gedit/ChangeLog7
-rw-r--r--app-editors/gedit/gedit-2.30.2.ebuild81
2 files changed, 87 insertions, 1 deletions
diff --git a/app-editors/gedit/ChangeLog b/app-editors/gedit/ChangeLog
index ee2e42337ded..0989835aff3a 100644
--- a/app-editors/gedit/ChangeLog
+++ b/app-editors/gedit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/gedit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.302 2010/06/04 20:16:41 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.303 2010/06/13 19:34:52 pacho Exp $
+
+*gedit-2.30.2 (13 Jun 2010)
+
+ 13 Jun 2010; Pacho Ramos <pacho@gentoo.org> +gedit-2.30.2.ebuild:
+ Add new version for Gnome 2.30.
04 Jun 2010; Markus Meier <maekke@gentoo.org> gedit-2.28.4.ebuild:
x86 stable, bug #314899
diff --git a/app-editors/gedit/gedit-2.30.2.ebuild b/app-editors/gedit/gedit-2.30.2.ebuild
new file mode 100644
index 000000000000..fbb38ab06900
--- /dev/null
+++ b/app-editors/gedit/gedit-2.30.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.30.2.ebuild,v 1.1 2010/06/13 19:34:52 pacho Exp $
+
+GCONF_DEBUG="no"
+
+inherit gnome2 python
+
+DESCRIPTION="A text editor for the GNOME desktop"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="doc python spell"
+
+RDEPEND=">=gnome-base/gconf-2
+ >=x11-libs/libSM-1.0
+ >=dev-libs/libxml2-2.5.0
+ >=dev-libs/glib-2.22
+ >=x11-libs/gtk+-2.16.0
+ >=x11-libs/gtksourceview-2.9.7
+ spell? (
+ >=app-text/enchant-1.2
+ >=app-text/iso-codes-0.35
+ )
+ python? (
+ >=dev-python/pygobject-2.15.4
+ >=dev-python/pygtk-2.12
+ >=dev-python/pygtksourceview-2.9.2
+ )"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ >=app-text/scrollkeeper-0.3.11
+ >=app-text/gnome-doc-utils-0.3.2
+ ~app-text/docbook-xml-dtd-4.1.2
+ doc? ( >=dev-util/gtk-doc-1 )"
+# gnome-common and gtk-doc-am needed to eautoreconf
+
+DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
+
+if [[ "${ARCH}" == "PPC" ]] ; then
+ # HACK HACK HACK: someone fix this garbage
+ MAKEOPTS="${MAKEOPTS} -j1"
+fi
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ --disable-updater
+ $(use_enable python)
+ $(use_enable spell)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Installed for plugins, but they're dlopen()-ed
+ find "${D}" -name "*.la" -delete || die "remove of la files failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ use python && python_mod_optimize /usr/$(get_libdir)/gedit-2/plugins
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/gedit-2/plugins
+}