summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2012-02-13 16:32:07 +0000
committerJeremy Olexa <darkside@gentoo.org>2012-02-13 16:32:07 +0000
commit732c1c8fc61da238e08a2505e9f4dbd3ab4773c7 (patch)
tree06256aaf279afb0ab10fcfe2cfeb4b884f5637db /app-editors/levee
parentMigrate changes from Gentoo Prefix. EAPI4, darwin patch, emake call modificat... (diff)
downloadgentoo-2-732c1c8fc61da238e08a2505e9f4dbd3ab4773c7.tar.gz
gentoo-2-732c1c8fc61da238e08a2505e9f4dbd3ab4773c7.tar.bz2
gentoo-2-732c1c8fc61da238e08a2505e9f4dbd3ab4773c7.zip
use src_configure phase for configure call
(Portage version: 2.1.10.41/cvs/Linux i686)
Diffstat (limited to 'app-editors/levee')
-rw-r--r--app-editors/levee/ChangeLog5
-rw-r--r--app-editors/levee/levee-3.5a.ebuild7
2 files changed, 9 insertions, 3 deletions
diff --git a/app-editors/levee/ChangeLog b/app-editors/levee/ChangeLog
index 05c512e031a7..4be09ae0f998 100644
--- a/app-editors/levee/ChangeLog
+++ b/app-editors/levee/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/levee
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/levee/ChangeLog,v 1.26 2012/02/13 16:30:44 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/levee/ChangeLog,v 1.27 2012/02/13 16:32:07 darkside Exp $
+
+ 13 Feb 2012; Jeremy Olexa <darkside@gentoo.org> levee-3.5a.ebuild:
+ use src_configure phase for configure call
13 Feb 2012; Jeremy Olexa <darkside@gentoo.org>
+files/levee-3.4o-darwin.patch, levee-3.5a.ebuild:
diff --git a/app-editors/levee/levee-3.5a.ebuild b/app-editors/levee/levee-3.5a.ebuild
index 5487ef7c90f1..63f31a415379 100644
--- a/app-editors/levee/levee-3.5a.ebuild
+++ b/app-editors/levee/levee-3.5a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/levee/levee-3.5a.ebuild,v 1.6 2012/02/13 16:30:44 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/levee/levee-3.5a.ebuild,v 1.7 2012/02/13 16:32:07 darkside Exp $
EAPI=4
@@ -25,10 +25,13 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-3.5-glibc210.patch
}
-src_compile() {
+src_configure() {
export AC_CPP_PROG=$(tc-getCPP)
export AC_PATH=${PATH}
./configure.sh --prefix="${PREFIX}"/usr || die "configure failed"
+}
+
+src_compile() {
emake CFLAGS="${CFLAGS} -Wall -Wextra ${LDFLAGS}" CC=$(tc-getCC)
}