summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-08-27 12:04:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-08-27 12:04:47 +0000
commit49c859fc544e6c7e3c2b7dac2cc3fda43f6d41da (patch)
treee6b2e58fa13b2b8610eb35f228df1c636b9e7142 /app-editors
parentfix typo reported in bug #60039 (Manifest recommit) (diff)
downloadgentoo-2-49c859fc544e6c7e3c2b7dac2cc3fda43f6d41da.tar.gz
gentoo-2-49c859fc544e6c7e3c2b7dac2cc3fda43f6d41da.tar.bz2
gentoo-2-49c859fc544e6c7e3c2b7dac2cc3fda43f6d41da.zip
fix up gmp symlink and tidy src_compile
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/mp/ChangeLog5
-rw-r--r--app-editors/mp/mp-3.3.1.ebuild22
2 files changed, 16 insertions, 11 deletions
diff --git a/app-editors/mp/ChangeLog b/app-editors/mp/ChangeLog
index 1ae07f810527..961dbd84c81a 100644
--- a/app-editors/mp/ChangeLog
+++ b/app-editors/mp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/mp
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/ChangeLog,v 1.22 2004/08/27 11:55:54 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/ChangeLog,v 1.23 2004/08/27 12:04:47 mr_bones_ Exp $
+
+ 27 Aug 2004; Michael Sterrett <mr_bones_@gentoo.org> mp-3.3.1.ebuild:
+ fix up gmp symlink and tidy src_compile
27 Aug 2004; Michael Sterrett <mr_bones_@gentoo.org> mp-3.3.1.ebuild:
fix typo reported in bug #60039
diff --git a/app-editors/mp/mp-3.3.1.ebuild b/app-editors/mp/mp-3.3.1.ebuild
index 8604ff5f804e..2253f3c56300 100644
--- a/app-editors/mp/mp-3.3.1.ebuild
+++ b/app-editors/mp/mp-3.3.1.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.3.1.ebuild,v 1.4 2004/08/27 11:55:54 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.3.1.ebuild,v 1.5 2004/08/27 12:04:47 mr_bones_ Exp $
DESCRIPTION="Minimum Profit: A text editor for programmers"
HOMEPAGE="http://www.triptico.com/software/mp.html"
-SRC_URI="http://www.triptico.com/download/mp-3.3.1.tar.gz"
+SRC_URI="http://www.triptico.com/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~sparc ~amd64"
-
IUSE="ncurses gtk"
+
DEPEND="virtual/libc
ncurses? ( sys-libs/ncurses )
gtk? ( >=x11-libs/gtk+-1.2* )
@@ -21,14 +21,16 @@ RDEPEND="${DEPEND}
src_compile() {
local myconf
- if use ncurses && use gtk ; then
- sh config.sh ${myconf}|| die "Configure Failed"
- elif use ncurses || ! use gtk ; then
+ if use gtk ; then
+ if use ncurses ; then
+ sh config.sh ${myconf}|| die "Configure Failed"
+ else
+ myconf="${myconf} --without-curses"
+ sh config.sh ${myconf} || die "Configure Failed"
+ fi
+ else
myconf="${myconf} --without-gtk"
sh config.sh ${myconf} || die "Configure Failed"
- elif use gtk && ! use ncurses ; then
- myconf="${myconf} --without-curses"
- sh config.sh ${myconf} || die "Configure Failed"
fi
echo ${CFLAGS} >> config.cflags
emake || die "Compile Failed"
@@ -36,7 +38,7 @@ src_compile() {
src_install() {
dobin mp || die "Install Failed"
- dosym mp ${DESTTREE}/bin/gmp
+ use gtk && dosym mp "${DESTTREE}/bin/gmp"
dodoc AUTHORS README Changelog mprc.sample
doman mp.1
}