summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRay Russell Reese III <anti@gentoo.org>2004-02-09 05:33:16 +0000
committerRay Russell Reese III <anti@gentoo.org>2004-02-09 05:33:16 +0000
commit660b35ba8e4a2b8a8e261bfe43e8c15c435f1f83 (patch)
treefed333bec7351196602869e41876ae0ad49e137b /app-editors
parentChanging x11-base/xfree-4.3.0-r4 mask to x11-base/xfree-4.3.0-r5, for work-in... (diff)
downloadgentoo-2-660b35ba8e4a2b8a8e261bfe43e8c15c435f1f83.tar.gz
gentoo-2-660b35ba8e4a2b8a8e261bfe43e8c15c435f1f83.tar.bz2
gentoo-2-660b35ba8e4a2b8a8e261bfe43e8c15c435f1f83.zip
Fixed .keep stuff to use keepdir
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/jedit/ChangeLog6
-rw-r--r--app-editors/jedit/jedit-4.0.3-r2.ebuild6
-rw-r--r--app-editors/jedit/jedit-4.1.ebuild6
-rw-r--r--app-editors/jedit/jedit-4.2_pre8.ebuild6
-rw-r--r--app-editors/jedit/jedit-4.2_pre9.ebuild6
5 files changed, 17 insertions, 13 deletions
diff --git a/app-editors/jedit/ChangeLog b/app-editors/jedit/ChangeLog
index b49d5e43f840..1d90dc7a7fc8 100644
--- a/app-editors/jedit/ChangeLog
+++ b/app-editors/jedit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/jedit
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/ChangeLog,v 1.23 2004/02/08 00:34:34 anti Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/ChangeLog,v 1.24 2004/02/09 05:33:16 anti Exp $
+
+ 09 Feb 2004; Ray Russell Reese III <anti@gentoo.org> jedit-4.0.3-r2.ebuild,
+ jedit-4.1.ebuild, jedit-4.2_pre8.ebuild, jedit-4.2_pre9.ebuild:
+ Changed .keep behavior, now uses keepdir. Closes #39810
*jedit-4.2_pre9 (07 Feb 2004)
diff --git a/app-editors/jedit/jedit-4.0.3-r2.ebuild b/app-editors/jedit/jedit-4.0.3-r2.ebuild
index 64605140884b..269f38601ae5 100644
--- a/app-editors/jedit/jedit-4.0.3-r2.ebuild
+++ b/app-editors/jedit/jedit-4.0.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.0.3-r2.ebuild,v 1.7 2004/01/01 05:55:02 anti Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.0.3-r2.ebuild,v 1.8 2004/02/09 05:33:16 anti Exp $
MY_PV=${PV//.}
S="${WORKDIR}/jEdit"
@@ -48,11 +48,11 @@ src_install () {
chmod 755 ${D}/usr/share/jedit/jedit.sh
ln -s ../share/jedit/jedit.sh ${D}/usr/bin/jedit
+
+ keepdir /usr/share/jedit/jars
}
pkg_postinst() {
- touch /usr/share/jedit/jars/.keep
-
einfo "The system directory for jEdit plugins is"
einfo "/usr/share/jedit/jars"
}
diff --git a/app-editors/jedit/jedit-4.1.ebuild b/app-editors/jedit/jedit-4.1.ebuild
index 1dd0f3ac9ee4..ed4ed7a0f745 100644
--- a/app-editors/jedit/jedit-4.1.ebuild
+++ b/app-editors/jedit/jedit-4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.1.ebuild,v 1.5 2004/01/01 05:55:02 anti Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.1.ebuild,v 1.6 2004/02/09 05:33:16 anti Exp $
MY_PV="41"
@@ -57,11 +57,11 @@ src_install () {
chmod 755 ${D}/usr/share/jedit/jedit.sh
ln -s ../share/jedit/jedit.sh ${D}/usr/bin/jedit
+
+ keepdir /usr/share/jedit/jars
}
pkg_postinst() {
- touch /usr/share/jedit/jars/.keep
-
einfo "The system directory for jEdit plugins is"
einfo "/usr/share/jedit/jars"
}
diff --git a/app-editors/jedit/jedit-4.2_pre8.ebuild b/app-editors/jedit/jedit-4.2_pre8.ebuild
index 9b29f85437b2..16fbdc297543 100644
--- a/app-editors/jedit/jedit-4.2_pre8.ebuild
+++ b/app-editors/jedit/jedit-4.2_pre8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.2_pre8.ebuild,v 1.3 2004/02/05 04:52:21 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.2_pre8.ebuild,v 1.4 2004/02/09 05:33:16 anti Exp $
MY_PV="42pre8"
@@ -57,11 +57,11 @@ src_install () {
chmod 755 ${D}/usr/share/jedit/jedit.sh
ln -s ../share/jedit/jedit.sh ${D}/usr/bin/jedit
+
+ keepdir /usr/share/jedit/jars
}
pkg_postinst() {
- touch /usr/share/jedit/jars/.keep
-
einfo "The system directory for jEdit plugins is"
einfo "/usr/share/jedit/jars"
}
diff --git a/app-editors/jedit/jedit-4.2_pre9.ebuild b/app-editors/jedit/jedit-4.2_pre9.ebuild
index e3869c4cf1f6..1e10365ff332 100644
--- a/app-editors/jedit/jedit-4.2_pre9.ebuild
+++ b/app-editors/jedit/jedit-4.2_pre9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.2_pre9.ebuild,v 1.1 2004/02/08 00:34:34 anti Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.2_pre9.ebuild,v 1.2 2004/02/09 05:33:16 anti Exp $
MY_PV="42pre9"
@@ -57,11 +57,11 @@ src_install () {
chmod 755 ${D}/usr/share/jedit/jedit.sh
ln -s ../share/jedit/jedit.sh ${D}/usr/bin/jedit
+
+ keepdir /usr/share/jedit/jars
}
pkg_postinst() {
- touch /usr/share/jedit/jars/.keep
-
einfo "The system directory for jEdit plugins is"
einfo "/usr/share/jedit/jars"
}