summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2002-11-16 10:16:18 +0000
committerHanno Böck <hanno@gentoo.org>2002-11-16 10:16:18 +0000
commit77077ca3eb3aedad44d84e96b8b4dd88c19fb003 (patch)
treeeb9d9c31d0c9f1142b00f4e6dd42e0abf524b6eb /app-editors
parentfixed small bug in ebuild (diff)
downloadgentoo-2-77077ca3eb3aedad44d84e96b8b4dd88c19fb003.tar.gz
gentoo-2-77077ca3eb3aedad44d84e96b8b4dd88c19fb003.tar.bz2
gentoo-2-77077ca3eb3aedad44d84e96b8b4dd88c19fb003.zip
new gtk2 port version
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/bluefish/ChangeLog7
-rw-r--r--app-editors/bluefish/bluefish-2002.11.08.ebuild56
-rw-r--r--app-editors/bluefish/files/digest-bluefish-2002.11.081
3 files changed, 63 insertions, 1 deletions
diff --git a/app-editors/bluefish/ChangeLog b/app-editors/bluefish/ChangeLog
index 66759ad99bc8..fb78d4066ef6 100644
--- a/app-editors/bluefish/ChangeLog
+++ b/app-editors/bluefish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/bluefish
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.7 2002/11/14 17:06:11 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.8 2002/11/16 10:16:18 hanno Exp $
+
+*bluefish-2002.11.08 (16 Nov 2002)
+
+ 16 Nov 2002; Hanno Boeck <hanno@gentoo.org> bluefish-2002.11.08.ebuild :
+ New version of gtk2 port.
*bluefish-0.7-r3 (14 Nov 2002)
diff --git a/app-editors/bluefish/bluefish-2002.11.08.ebuild b/app-editors/bluefish/bluefish-2002.11.08.ebuild
new file mode 100644
index 000000000000..ad35632a2211
--- /dev/null
+++ b/app-editors/bluefish/bluefish-2002.11.08.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-2002.11.08.ebuild,v 1.1 2002/11/16 10:16:18 hanno Exp $
+
+IUSE="nls perl"
+
+MY_PV=`echo ${PV} | sed -e 's/\./-/g'`
+S=${WORKDIR}/${PN}-gtk2
+DESCRIPTION="Bluefish is a GTK HTML editor for the experienced web designer or programmer."
+SRC_URI="http://pkedu.fbt.eitn.wau.nl/~olivier/snapshots/${PN}-gtk2port-${MY_PV}.tgz"
+HOMEPAGE="http://bluefish.openoffice.nl/"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+SLOT="0"
+
+DEPEND=">=x11-libs/gtk+-2.0.5
+ >=media-libs/freetype-2.0.9
+ >=media-libs/gdk-pixbuf-0.18
+ perl? ( sys-devel/perl )
+ nls? ( sys-devel/gettext )"
+
+
+src_compile() {
+
+ local myconf
+ use perl && myconf="${myconf} --with-perl"
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --with-autocomplet \
+ ${myconf} || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ makefiles=`find . -name Makefile`
+ for f in $makefiles; do
+ mv $f $f.orig
+ sed -e 's#$(prefix)#$(DESTDIR)$(prefix)#' \
+ -e 's#${prefix}#$(DESTDIR)${prefix}#' \
+ -e 's#/usr/share/pixmaps#$(DESTDIR)$(prefix)/share/pixmaps#' \
+ $f.orig > $f
+ done
+
+ make \
+ DESTDIR=${D} \
+ mandir=${D}/usr/share/man \
+ install || die
+
+}
diff --git a/app-editors/bluefish/files/digest-bluefish-2002.11.08 b/app-editors/bluefish/files/digest-bluefish-2002.11.08
new file mode 100644
index 000000000000..3d798fbd863f
--- /dev/null
+++ b/app-editors/bluefish/files/digest-bluefish-2002.11.08
@@ -0,0 +1 @@
+MD5 ca8f7353031cb6f2a20708caa1aadb66 bluefish-gtk2port-2002-11-08.tgz 413083