summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-10-28 07:22:01 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-10-28 07:22:01 +0000
commita96d0152eac1960d91d8968886e1eaf5a8deb3f7 (patch)
treef1e85ad62ce4f94c52418bb8402350e92f5a781d /app-editors
parentchange versions to reflect real version (diff)
downloadgentoo-2-a96d0152eac1960d91d8968886e1eaf5a8deb3f7.tar.gz
gentoo-2-a96d0152eac1960d91d8968886e1eaf5a8deb3f7.tar.bz2
gentoo-2-a96d0152eac1960d91d8968886e1eaf5a8deb3f7.zip
have ebuilds control vim dependencies
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gvim/gvim-6.1-r3.ebuild22
-rw-r--r--app-editors/vim-core/vim-core-6.1-r3.ebuild9
-rw-r--r--app-editors/vim/vim-6.1-r16.ebuild11
3 files changed, 39 insertions, 3 deletions
diff --git a/app-editors/gvim/gvim-6.1-r3.ebuild b/app-editors/gvim/gvim-6.1-r3.ebuild
index 7858a202fdb3..ab2d69838642 100644
--- a/app-editors/gvim/gvim-6.1-r3.ebuild
+++ b/app-editors/gvim/gvim-6.1-r3.ebuild
@@ -1,9 +1,29 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-6.1-r3.ebuild,v 1.1 2002/10/27 22:52:29 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-6.1-r3.ebuild,v 1.2 2002/10/28 07:20:29 rphillips Exp $
inherit vim
DESCRIPTION="graphical vim"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+DEPEND="dev-util/cscope
+ >=sys-libs/ncurses-5.2-r2
+ app-editors/vim-core
+ x11-base/xfree
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ gnome? ( gnome-base/gnome-libs )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ perl? ( sys-devel/perl )
+ python? ( dev-lang/python )
+ ruby? ( >=dev-lang/ruby-1.6.4 )"
+# tcltk? ( dev-lang/tcl )"
+# It appears that the tclinterp stuff in Vim is broken right now (at
+# least on Linux... it works on BSD). When you --enable-tclinterp
+# flag, then the following command never returns:
+#
+# VIMINIT='let OS = system("uname -s")' vim
+#
+# Please don't re-enable the tclinterp flag without verifying first
+# that the above works. Thanks. (08 Sep 2001 agriffis)
src_compile() {
local myconf
diff --git a/app-editors/vim-core/vim-core-6.1-r3.ebuild b/app-editors/vim-core/vim-core-6.1-r3.ebuild
index 84cd0538ea5e..da6a8e28ec8b 100644
--- a/app-editors/vim-core/vim-core-6.1-r3.ebuild
+++ b/app-editors/vim-core/vim-core-6.1-r3.ebuild
@@ -1,9 +1,16 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/vim-core-6.1-r3.ebuild,v 1.1 2002/10/27 22:52:29 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/vim-core-6.1-r3.ebuild,v 1.2 2002/10/28 07:22:01 rphillips Exp $
inherit vim
DESCRIPTION="vim, gvim and kvim shared files"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+DEPEND="dev-util/cscope
+ >=sys-libs/ncurses-5.2-r2
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ perl? ( sys-devel/perl )
+ python? ( dev-lang/python )
+ ruby? ( >=dev-lang/ruby-1.6.4 )"
src_compile() {
diff --git a/app-editors/vim/vim-6.1-r16.ebuild b/app-editors/vim/vim-6.1-r16.ebuild
index adf356fcdf98..ea14dfd845b4 100644
--- a/app-editors/vim/vim-6.1-r16.ebuild
+++ b/app-editors/vim/vim-6.1-r16.ebuild
@@ -1,10 +1,19 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.1-r16.ebuild,v 1.1 2002/10/27 22:52:29 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.1-r16.ebuild,v 1.2 2002/10/28 07:21:10 rphillips Exp $
inherit vim
DESCRIPTION="Vi IMproved!"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+DEPEND="app-editors/vim-core
+ dev-util/cscope
+ >=sys-libs/ncurses-5.2-r2
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ perl? ( sys-devel/perl )
+ python? ( dev-lang/python )
+ ruby? ( >=dev-lang/ruby-1.6.4 )"
+# tcltk? ( dev-lang/tcl )"
src_compile() {
local myconf