summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMats Lidell <matsl@gentoo.org>2013-06-26 22:52:02 +0000
committerMats Lidell <matsl@gentoo.org>2013-06-26 22:52:02 +0000
commit96337bb8aa759d4b82d827b80a291cdcf7f13c3f (patch)
treec0d1deaee032eae1e6bdc18fb359a1e8b38587ed /app-editors
parentInitial import (diff)
downloadgentoo-2-96337bb8aa759d4b82d827b80a291cdcf7f13c3f.tar.gz
gentoo-2-96337bb8aa759d4b82d827b80a291cdcf7f13c3f.tar.bz2
gentoo-2-96337bb8aa759d4b82d827b80a291cdcf7f13c3f.zip
Partial fix for bug #472162
(Portage version: 2.1.12.2/cvs/Linux i686, signed Manifest commit with key 0x377034660A5828DE!)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/xemacs/ChangeLog6
-rw-r--r--app-editors/xemacs/files/xemacs-21.5.33-no-mule-build.patch33
-rw-r--r--app-editors/xemacs/xemacs-21.5.33.ebuild14
3 files changed, 47 insertions, 6 deletions
diff --git a/app-editors/xemacs/ChangeLog b/app-editors/xemacs/ChangeLog
index a8c505696fa2..081dde5b2519 100644
--- a/app-editors/xemacs/ChangeLog
+++ b/app-editors/xemacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/xemacs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/ChangeLog,v 1.165 2013/06/02 09:18:02 matsl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/ChangeLog,v 1.166 2013/06/26 22:52:01 matsl Exp $
+
+ 26 Jun 2013; Mats Lidell <matsl@gentoo.org> xemacs-21.5.33.ebuild,
+ +files/xemacs-21.5.33-no-mule-build.patch:
+ Partial fix for bug #472162
*xemacs-21.5.33 (01 Jun 2013)
diff --git a/app-editors/xemacs/files/xemacs-21.5.33-no-mule-build.patch b/app-editors/xemacs/files/xemacs-21.5.33-no-mule-build.patch
new file mode 100644
index 000000000000..17e572044fac
--- /dev/null
+++ b/app-editors/xemacs/files/xemacs-21.5.33-no-mule-build.patch
@@ -0,0 +1,33 @@
+diff -r a2912073be85 lisp/paragraphs.el
+--- a/lisp/paragraphs.el Wed Jun 19 09:30:30 2013 -0600
++++ b/lisp/paragraphs.el Sat Jun 22 13:27:48 2013 +0200
+@@ -180,7 +180,10 @@
+ :type '(choice regexp (const :tag "Use default value" nil)))
+ (put 'sentence-end 'safe-local-variable 'string-or-null-p)
+
+-(defcustom sentence-end-base "[.?!][]\"'”)}]*"
++(defcustom sentence-end-base
++ (concat "[.?!][]\"'"
++ (if (featurep 'mule) (string (unicode-to-char #x201D)) "")
++ ")}]*")
+ "Regexp matching the basic end of a sentence, not including following space."
+ :group 'paragraphs
+ :type 'string
+@@ -201,14 +204,14 @@
+ in between. See Info node `(elisp)Standard Regexps'."
+ (or sentence-end
+ ;; We accept non-break space along with space.
+- (concat (if sentence-end-without-period "\\w[ \u00a0][ \u00a0]\\|")
++ (concat (if sentence-end-without-period "\\w[ \240][ \240]\\|")
+ "\\("
+ sentence-end-base
+ (if sentence-end-double-space
+- "\\($\\|[ \u00a0]$\\|\t\\|[ \u00a0][ \u00a0]\\)" "\\($\\|[\t \u00a0]\\)")
++ "\\($\\|[ \240]$\\|\t\\|[ \240][ \240]\\)" "\\($\\|[\t \240]\\)")
+ "\\|[" sentence-end-without-space "]+"
+ "\\)"
+- "[ \u00a0\t\n]*")))
++ "[ \240\t\n]*")))
+
+ (defcustom page-delimiter "^\014"
+ "*Regexp describing line-beginnings that separate pages."
diff --git a/app-editors/xemacs/xemacs-21.5.33.ebuild b/app-editors/xemacs/xemacs-21.5.33.ebuild
index 7ebd424ec37f..e62e3e6fb4ff 100644
--- a/app-editors/xemacs/xemacs-21.5.33.ebuild
+++ b/app-editors/xemacs/xemacs-21.5.33.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.5.33.ebuild,v 1.1 2013/06/02 09:18:02 matsl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.5.33.ebuild,v 1.2 2013/06/26 22:52:02 matsl Exp $
# Note: xemacs currently does not work with a hardened profile. If you
# want to use xemacs on a hardened profile then compile with the
@@ -63,6 +63,10 @@ src_unpack() {
src_prepare() {
use neXt && cp "${WORKDIR}"/NeXT.XEmacs/xemacs-icons/* "${S}"/etc/toolbar/
+
+ # Fix for no-mule build.
+ find "${S}"/lisp -name '*.elc' -exec rm {} \; || die
+ epatch "${FILESDIR}"/${P}-no-mule-build.patch
}
src_configure() {
@@ -170,10 +174,10 @@ src_configure() {
src_install() {
emake prefix="${D}"/usr \
- mandir="${D}"/usr/share/man/man1 \
- infodir="${D}"/usr/share/info \
- libdir="${D}"/usr/$(get_libdir) \
- datadir="${D}"/usr/share \
+ mandir="${D}"/usr/share/man/man1 \
+ infodir="${D}"/usr/share/info \
+ libdir="${D}"/usr/$(get_libdir) \
+ datadir="${D}"/usr/share \
install gzip-el || die
# Rename some applications installed in bin so that it is clear