summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-12-11 07:36:09 +0000
committerUlrich Müller <ulm@gentoo.org>2012-12-11 07:36:09 +0000
commitf0f2d2a24b0696c638f9a26c19ccc035ca710d7e (patch)
tree726cea0ede718e4cf7bccb144fa7e0e98712eda2 /app-emacs/haskell-mode
parentVersion bump. (diff)
downloadgentoo-2-f0f2d2a24b0696c638f9a26c19ccc035ca710d7e.tar.gz
gentoo-2-f0f2d2a24b0696c638f9a26c19ccc035ca710d7e.tar.bz2
gentoo-2-f0f2d2a24b0696c638f9a26c19ccc035ca710d7e.zip
Version bump, bug 446234.
(Portage version: 2.1.11.36/cvs/Linux x86_64, signed Manifest commit with key E7BE08CA7DC6EA25)
Diffstat (limited to 'app-emacs/haskell-mode')
-rw-r--r--app-emacs/haskell-mode/ChangeLog9
-rw-r--r--app-emacs/haskell-mode/haskell-mode-2.9.1.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/app-emacs/haskell-mode/ChangeLog b/app-emacs/haskell-mode/ChangeLog
index 71eb7ef97867..5d62152a6d28 100644
--- a/app-emacs/haskell-mode/ChangeLog
+++ b/app-emacs/haskell-mode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/haskell-mode
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/ChangeLog,v 1.43 2010/08/13 12:57:43 josejx Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/ChangeLog,v 1.44 2012/12/11 07:36:09 ulm Exp $
+
+*haskell-mode-2.9.1 (11 Dec 2012)
+
+ 11 Dec 2012; Ulrich Müller <ulm@gentoo.org> +haskell-mode-2.9.1.ebuild:
+ Version bump, bug 446234.
13 Aug 2010; Joseph Jezak <josejx@gentoo.org> haskell-mode-2.8.0.ebuild:
Marked ppc stable for bug #332081.
diff --git a/app-emacs/haskell-mode/haskell-mode-2.9.1.ebuild b/app-emacs/haskell-mode/haskell-mode-2.9.1.ebuild
new file mode 100644
index 000000000000..79d4177f7eda
--- /dev/null
+++ b/app-emacs/haskell-mode/haskell-mode-2.9.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/haskell-mode-2.9.1.ebuild,v 1.1 2012/12/11 07:36:09 ulm Exp $
+
+EAPI=5
+
+inherit elisp
+
+MY_PV=${PV//./_}
+DESCRIPTION="Mode for editing (and running) Haskell programs in Emacs"
+HOMEPAGE="http://projects.haskell.org/haskellmode-emacs/
+ http://www.haskell.org/haskellwiki/Emacs#Haskell-mode"
+SRC_URI="https://github.com/haskell/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+DOCS="NEWS README.md *.hs examples/init.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ # We install the logo in SITEETC, not in SITELISP
+ # https://github.com/haskell/haskell-mode/issues/102
+ sed -i -e "/defconst haskell-process-logo/{n;" \
+ -e "s:(.*\"\\(.*\\)\".*):\"${SITEETC}/${PN}/\\1\":}" \
+ haskell-process.el || die
+}
+
+src_compile() {
+ elisp-make-autoload-file haskell-site-file.el || die
+ elisp-compile *.el || die
+}
+
+src_install() {
+ elisp_src_install
+ insinto "${SITEETC}/${PN}"
+ doins logo.svg
+}