summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Veber <coronalvr@gentoo.org>2003-06-26 15:29:48 +0000
committerAlex Veber <coronalvr@gentoo.org>2003-06-26 15:29:48 +0000
commit85d56404937f8ae93556c7943db9de49ff3577ff (patch)
treec47045fab621a9dcb943ad6b997ea1f51d20b6f6 /app-emulation/wine
parentbump (diff)
downloadgentoo-2-85d56404937f8ae93556c7943db9de49ff3577ff.tar.gz
gentoo-2-85d56404937f8ae93556c7943db9de49ff3577ff.tar.bz2
gentoo-2-85d56404937f8ae93556c7943db9de49ff3577ff.zip
bump
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/ChangeLog7
-rw-r--r--app-emulation/wine/Manifest4
-rw-r--r--app-emulation/wine/files/digest-wine-200306185
-rw-r--r--app-emulation/wine/wine-20030618.ebuild133
4 files changed, 146 insertions, 3 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 18f8d72397ed..69091ac6d9f5 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/wine
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.43 2003/06/11 21:09:48 utx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.44 2003/06/26 15:29:37 coronalvr Exp $
+
+*wine-20030618 (26 Jun 2003)
+
+ 26 Jun 2003; Alex Veber <coronalvr@gentoo.org> wine-20030618.ebuild:
+ version bump.
11 Jun 2003; Stanislav Brabec <utx@gentoo.org>:
Version 20030411-r1 included back to portage tree (bug #22587).
diff --git a/app-emulation/wine/Manifest b/app-emulation/wine/Manifest
index b4f64bb39aee..6c7465a7dad8 100644
--- a/app-emulation/wine/Manifest
+++ b/app-emulation/wine/Manifest
@@ -1,7 +1,7 @@
-MD5 aaa8ff174de5bf3158c7de202e2761ec wine-20030618.ebuild 3592
+MD5 aee7beb5a5f700a09c6372391991d744 wine-20030618.ebuild 3598
MD5 ed757cad198481d86401836750a5e7a9 wine-20030508.ebuild 3479
MD5 cf7820d37da40ca549fdecbc8942ba50 wine-20030411-r1.ebuild 3312
-MD5 10c87bd9a8762e16f48e1e6eb9300506 ChangeLog 8663
+MD5 c751c2797fecc2daaed1fa4017be3a80 ChangeLog 8787
MD5 dcd68f96e0066c424ec1ceb8411c7549 files/digest-wine-20030411-r1 67
MD5 af8da46a0e51578ff1e18e399141d628 files/wine-20030411-fake_windows.tar.bz2 500
MD5 b0780073e1d513fb7658070bba8d0672 files/digest-wine-20030508 284
diff --git a/app-emulation/wine/files/digest-wine-20030618 b/app-emulation/wine/files/digest-wine-20030618
new file mode 100644
index 000000000000..2e5ef81457d0
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20030618
@@ -0,0 +1,5 @@
+MD5 71d1e24efd36dcd9522788e1dedb3c14 wine-20030618.tar.bz2 6976391
+MD5 bb9d5f77ffee8e72cf714aebc874157a wine-20030618-xopenfont.patch 1069
+MD5 af8da46a0e51578ff1e18e399141d628 wine-20030618-fake_windows.tar.bz2 500
+MD5 8052677213b772973d85623012d68e86 wine-20030618-misc.tar.bz2 4591
+MD5 35f5ecf311952d369a24bdf7477c59df wine-nvidia-fix.patch.gz 6124
diff --git a/app-emulation/wine/wine-20030618.ebuild b/app-emulation/wine/wine-20030618.ebuild
new file mode 100644
index 000000000000..b67999158510
--- /dev/null
+++ b/app-emulation/wine/wine-20030618.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20030618.ebuild,v 1.1 2003/06/26 15:29:37 coronalvr Exp $
+
+inherit eutils base
+
+DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
+SRC_URI="mirror://gentoo/wine-${PV}.tar.bz2
+ mirror://gentoo/${P}-xopenfont.patch
+ mirror://gentoo/${P}-fake_windows.tar.bz2
+ mirror://gentoo/${P}-misc.tar.bz2
+ mirror://gentoo/wine-nvidia-fix.patch.gz"
+HOMEPAGE="http://www.winehq.com/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc -sparc"
+IUSE="nas arts cups opengl alsa tcltk nptl"
+
+DEPEND="sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ >=sys-libs/ncurses-5.2
+ >=media-libs/freetype-2.0.0
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tcl dev-lang/tk )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )"
+
+src_unpack() {
+ base_src_unpack
+ cd ${S}
+ epatch ${DISTDIR}/${P}-xopenfont.patch
+}
+
+src_compile() {
+ cd ${S}/dlls/opengl32
+ epatch ${WORKDIR}/wine-nvidia-fix.patch
+
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="$myconf --enable-opengl" || myconf="$myconf --disable-opengl"
+ use nptl && myconf="$myconf --with-nptl" || myconf="$myconf --without-nptl"
+
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ # there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected
+
+ ac_cv_header_jack_jack_h=no \
+ ac_cv_lib_soname_jack= \
+ ./configure --prefix=/usr/lib/wine \
+ --sysconfdir=/etc/wine \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
+
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ # No parallel make
+ cd ${S}
+ make depend all || die
+ cd programs && emake || die
+}
+
+src_install () {
+ local WINEMAKEOPTS="prefix=${D}/usr/lib/wine"
+
+ ### Install wine to ${D}
+ cd ${S}
+ make ${WINEMAKEOPTS} install || die
+ cd ${S}/programs
+ make ${WINEMAKEOPTS} install || die
+
+ # Needed for later installation
+ dodir /usr/bin
+
+ ### Creation of /usr/lib/wine/.data
+ # Setting up fake_windows
+ dodir /usr/lib/wine/.data
+ cd ${D}/usr/lib/wine/.data
+ tar jxvf ${DISTDIR}/${P}-fake_windows.tar.bz2
+ chown root:root fake_windows/ -R
+
+ # Unpacking the miscellaneous files
+ tar jxvf ${DISTDIR}/${P}-misc.tar.bz2
+ chown root:root config
+
+ # moving the wrappers to bin/
+ insinto /usr/bin
+ dobin regedit-wine wine
+ rm regedit-wine wine
+
+ # copying the winedefault.reg into .data
+ insinto /usr/lib/wine/.data
+ doins ${WORKDIR}/${P}/winedefault.reg
+
+ # Set up this dynamic data
+ cd ${S}
+ insinto /usr/lib/wine/.data/fake_windows/Windows
+ doins documentation/samples/system.ini
+ doins documentation/samples/generic.ppd
+ ## Setup of .data complete
+
+ ### Misc tasks
+ # Take care of the documentation
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ # Manpage setup
+ cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man5/wine.conf.5
+ rm ${D}/usr/lib/${PN}/man/man5/wine.conf.5
+
+ # Remove the executable flag from those libraries.
+ cd ${D}/usr/lib/wine/lib/wine
+ chmod a-x *.so
+}
+
+pkg_postinst() {
+ einfo "Use /usr/bin/wine to start wine. This is a wrapper-script"
+ einfo "which will take care of everything else."
+ einfo ""
+ einfo "Use /usr/bin/regedit-wine to import registry files into the"
+ einfo "wine registry."
+ einfo ""
+}