summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-05-11 08:33:24 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-05-11 08:33:24 +0000
commit6c6aaee6da0af613eaaa55dfccaa2f4f73bf985e (patch)
tree83c10530acc2c8291ec711bb8f0a5096e044fcdc /app-emulation/winex
parentnew version (diff)
downloadgentoo-2-6c6aaee6da0af613eaaa55dfccaa2f4f73bf985e.tar.gz
gentoo-2-6c6aaee6da0af613eaaa55dfccaa2f4f73bf985e.tar.bz2
gentoo-2-6c6aaee6da0af613eaaa55dfccaa2f4f73bf985e.zip
initial version
Diffstat (limited to 'app-emulation/winex')
-rw-r--r--app-emulation/winex/ChangeLog9
-rw-r--r--app-emulation/winex/files/81winex4
-rw-r--r--app-emulation/winex/files/digest-winex-200205111
-rw-r--r--app-emulation/winex/files/winex4
-rw-r--r--app-emulation/winex/winex-20020511.ebuild108
5 files changed, 126 insertions, 0 deletions
diff --git a/app-emulation/winex/ChangeLog b/app-emulation/winex/ChangeLog
new file mode 100644
index 000000000000..d09a35925057
--- /dev/null
+++ b/app-emulation/winex/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-emulation/wine
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex/ChangeLog,v 1.1 2002/05/11 08:33:24 verwilst Exp $
+
+*winex-20020511 (11 May 2002)
+
+ 11 May 2002; B.Verwilst <verwilst@gentoo.org> ChangeLog :
+
+ Initial ebuild
diff --git a/app-emulation/winex/files/81winex b/app-emulation/winex/files/81winex
new file mode 100644
index 000000000000..7d55e9febff0
--- /dev/null
+++ b/app-emulation/winex/files/81winex
@@ -0,0 +1,4 @@
+PATH=/usr/winex/bin
+ROOTPATH=/usr/winex/bin
+LDPATH=/usr/winex/lib
+MANPATH=/usr/winex/man
diff --git a/app-emulation/winex/files/digest-winex-20020511 b/app-emulation/winex/files/digest-winex-20020511
new file mode 100644
index 000000000000..8e0faf98db46
--- /dev/null
+++ b/app-emulation/winex/files/digest-winex-20020511
@@ -0,0 +1 @@
+MD5 a535fe3a53722530e69065c974331e28 winex-20020511.tar.bz2 6043424
diff --git a/app-emulation/winex/files/winex b/app-emulation/winex/files/winex
new file mode 100644
index 000000000000..d48907e2bdfc
--- /dev/null
+++ b/app-emulation/winex/files/winex
@@ -0,0 +1,4 @@
+#!/bin/bash
+env LD_LIBRARY_PATH=/usr/winex/lib \
+ WINEPREFIX=~/.winex \
+/usr/winex/bin/wine ${*}
diff --git a/app-emulation/winex/winex-20020511.ebuild b/app-emulation/winex/winex-20020511.ebuild
new file mode 100644
index 000000000000..1d901006bfcb
--- /dev/null
+++ b/app-emulation/winex/winex-20020511.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Maintainer Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex/winex-20020511.ebuild,v 1.1 2002/05/11 08:33:24 verwilst Exp $
+
+S=${WORKDIR}/wine
+DESCRIPTION="WineX is a distribution of Wine with enhanced DirectX for gaming"
+SRC_URI="ftp:/www.ibiblio.org/gentoo/distfiles/${P}.tar.bz2"
+HOMEPAGE="http://www.transgaming.com/"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ dev-lang/tcl dev-lang/tk"
+
+src_compile() {
+
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ # there's no configure flag for cups, it's supposed to be autodetected
+
+ # the folks at #winehq were really angry about custom optimization
+ export CFLAGS=""
+ export CXXFLAGS=""
+
+ ./configure --prefix=/usr \
+ --exec_prefix=/usr/winex \
+ --sysconfdir=/etc/winex \
+ --mandir=/usr/winex/man \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
+
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ cd ${S}
+ make depend all manpages || die
+ cd programs && emake || die
+
+}
+
+src_install () {
+
+ local WINEXMAKEOPTS="prefix=${D}/usr \
+ mandir=${D}/usr/winex/man \
+ includedir=${D}/usr/winex/include \
+ exec_prefix=${D}/usr/winex"
+
+ cd ${S}
+ make ${WINEXMAKEOPTS} install || die
+ cd ${S}/programs
+ make ${WINEXMAKEOPTS} install || die
+
+ # these .so's are strange. they are from the make in programs/ above,
+ # and are for apps built with winelib (windows sources built directly
+ # against wine). Apparently the sources go into a <program name>.so file
+ # and you run it via a symlink <program name> -> wine. Unfortunately both
+ # the symlink and the .so apparently must reside in /usr/bin.
+ cd ${D}/usr/winex/bin
+ chmod a-x *.so
+
+ # bash script For users with both wine and winex
+ # TODO: find out why this doesn't work
+ DESTTREE=/usr/winex dobin ${FILESDIR}/winex
+
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ cd ${S}/documentation
+ DESTTREE=/usr/winex doman man3w/*
+ # sgml was being filtered without -a sgml
+ dohtml -a sgml *.sgml
+
+ insinto /etc/winex
+ doins samples/*
+ doins ${S}/winedefault.reg
+
+ dodir /etc/skel/.winex
+ dosym /etc/winex/config /etc/skel/.winex/config
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/81winex
+}
+
+pkg_postinst() {
+
+ einfo "If you are installing winex for the first time,
+copy /etc/winex/config (global configuration) to ~/.wine/config
+and edit that for per-user configuration. Otherwise, winex will
+not run.
+Also, run \"/usr/winex/bin/regapi setValue < /etc/winex/winedefault.reg\"
+to setup
+per-user registry for using winex. More info in
+/usr/share/doc/winex-${PV}."
+
+}
+