summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2004-05-12 21:58:37 +0000
committerLuca Barbato <lu_zero@gentoo.org>2004-05-12 21:58:37 +0000
commit0ec27f5de2315eccb9dca632e86d3465690047cd (patch)
tree10012747dc013aa70a1b3c60f75c0d8c5d344b03 /app-emulation
parentMoved spacetripper-demo and mutantstorm-demo (diff)
downloadgentoo-2-0ec27f5de2315eccb9dca632e86d3465690047cd.tar.gz
gentoo-2-0ec27f5de2315eccb9dca632e86d3465690047cd.tar.bz2
gentoo-2-0ec27f5de2315eccb9dca632e86d3465690047cd.zip
2.6.6 makefile fix
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/mol/ChangeLog7
-rw-r--r--app-emulation/mol/files/mol-0.9.70-makefile-fix.patch20
-rw-r--r--app-emulation/mol/mol-0.9.70.ebuild4
3 files changed, 28 insertions, 3 deletions
diff --git a/app-emulation/mol/ChangeLog b/app-emulation/mol/ChangeLog
index a91d30c05d6f..93ffbaf42766 100644
--- a/app-emulation/mol/ChangeLog
+++ b/app-emulation/mol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/mol
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.35 2004/03/21 23:01:54 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.36 2004/05/12 21:58:37 lu_zero Exp $
+
+ 12 May 2004; Luca Barbato <lu_zero@gentoo.org>
+ +files/mol-0.9.70-makefile-fix.patch, mol-0.9.70.ebuild:
+ Added a fix for 2.6.6 kernels, thanks to Benoit Chesneau
+ <benoitc@metavers.net> for pointing the Andreas Schwab <schwab@suse.de> patch.
*mol-0.9.70 (21 Mar 2004)
diff --git a/app-emulation/mol/files/mol-0.9.70-makefile-fix.patch b/app-emulation/mol/files/mol-0.9.70-makefile-fix.patch
new file mode 100644
index 000000000000..0ec3c9e0f892
--- /dev/null
+++ b/app-emulation/mol/files/mol-0.9.70-makefile-fix.patch
@@ -0,0 +1,20 @@
+--- src/kmod/Linux/Makefile.26-orig 2004-05-12 16:53:54.412715816 +0200
++++ src/kmod/Linux/Makefile.26 2004-05-12 16:56:08.325358000 +0200
+@@ -9,7 +9,7 @@
+ obj-m := _kuname.o mol.o
+
+ PERFOBJS = $(addprefix $(obj)/, $(PERFOBJS_))
+-MOL_ASMFLAGS = $(ASMFLAGS) $(INCLUDES) -D__ASSEMBLY__
++MOL_ASMFLAGS = $(CPPFLAGS) $(ASMFLAGS) $(INCLUDES) -D__ASSEMBLY__
+
+
+ $(obj)/hook.o: $(src)/reloc_table.h
+@@ -37,7 +37,7 @@
+ $(src)/asm_offsets.h: $(src)/archinclude.h $(src)/kernel_vars.h $(src)/mac_registers.h
+ $(src)/asm_offsets.h: $(src)/asm_offsets.c $(src)/asm_offsets.inc
+ @$(RM) $(src)/tmp-offsets.c $@ ; cat $^ > $(src)/tmp-offsets.c
+- @$(CC) $(CFLAGS) -I$(src) -Wall -S $(src)/tmp-offsets.c
++ @$(CC) $(CPPFLAGS) $(CFLAGS) -I$(src) -Wall -S $(src)/tmp-offsets.c
+ @echo "/* WARNING! Automatically generated from 'shared/asm_offsets.c' - DO NOT EDIT! */" > $@
+ @grep '^#' tmp-offsets.s >> $@
+ @$(RM) $(src)/tmp-offsets.*
diff --git a/app-emulation/mol/mol-0.9.70.ebuild b/app-emulation/mol/mol-0.9.70.ebuild
index 1a1a6cf2f076..a331a3a0e673 100644
--- a/app-emulation/mol/mol-0.9.70.ebuild
+++ b/app-emulation/mol/mol-0.9.70.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.70.ebuild,v 1.2 2004/03/22 01:39:51 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.70.ebuild,v 1.3 2004/05/12 21:58:37 lu_zero Exp $
inherit flag-o-matic
@@ -36,7 +36,7 @@ src_unpack() {
sed -i "s:prefix = /usr/local:prefix = /usr:" Makefile.top || die
sed -i "s#VENDOR :=#VENDOR := -gentoo#" Makefile.top || die
-
+ epatch ${FILESDIR}/${P}-makefile-fix.patch
}
src_compile() {