summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2003-05-25 00:00:02 +0000
committerLuca Barbato <lu_zero@gentoo.org>2003-05-25 00:00:02 +0000
commit3720b73eaf5256fbed083b7b47d70e8a21f4c1d0 (patch)
tree8856879f5453b3c6be422c48e314857bd014b73f /app-emulation
parentNew snapshot (diff)
downloadgentoo-2-3720b73eaf5256fbed083b7b47d70e8a21f4c1d0.tar.gz
gentoo-2-3720b73eaf5256fbed083b7b47d70e8a21f4c1d0.tar.bz2
gentoo-2-3720b73eaf5256fbed083b7b47d70e8a21f4c1d0.zip
New snapshot
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/mol/ChangeLog7
-rw-r--r--app-emulation/mol/Manifest4
-rw-r--r--app-emulation/mol/files/digest-mol-0.9.69_pre21
-rw-r--r--app-emulation/mol/mol-0.9.69_pre2.ebuild68
4 files changed, 77 insertions, 3 deletions
diff --git a/app-emulation/mol/ChangeLog b/app-emulation/mol/ChangeLog
index 4010f34ab6eb..f3c59c801f0f 100644
--- a/app-emulation/mol/ChangeLog
+++ b/app-emulation/mol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/mol
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.19 2003/04/10 20:14:10 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.20 2003/05/24 23:59:36 lu_zero Exp $
+
+*mol-0.9.69_pre2 (25 May 2003)
+
+ 25 May 2003; Luca Barbato <lu_zero@gentoo.org> mol-0.9.69_pre2.ebuild:
+ rsync snapshot of mol. Solves bug #21548
*mol-0.9.69_pre1 (10 Apr 2003)
diff --git a/app-emulation/mol/Manifest b/app-emulation/mol/Manifest
index ec8f55508f0d..a5c310489a3b 100644
--- a/app-emulation/mol/Manifest
+++ b/app-emulation/mol/Manifest
@@ -1,5 +1,5 @@
-MD5 568b1a4edd5a1fbeb08a7d357fac7294 ChangeLog 3495
-MD5 4891f6a26b817adc90619626a4db2247 mol-0.9.69_pre2.ebuild 2304
+MD5 1b92c01815dc789d00530cfa949528f3 ChangeLog 3497
+MD5 7c07d2eb1ebaae65ceaaa3913242d269 mol-0.9.69_pre2.ebuild 2306
MD5 84c32ed763ae9c3851d03607a6bd1684 mol-0.9.68-r4.ebuild 2217
MD5 c885b28272a4f8f5700afbf72c132c34 mol-0.9.69_pre1.ebuild 2302
MD5 105aff90cbe982385f05386a1b7acdd8 files/digest-mol-0.9.69_pre2 69
diff --git a/app-emulation/mol/files/digest-mol-0.9.69_pre2 b/app-emulation/mol/files/digest-mol-0.9.69_pre2
new file mode 100644
index 000000000000..48d6aa4c487c
--- /dev/null
+++ b/app-emulation/mol/files/digest-mol-0.9.69_pre2
@@ -0,0 +1 @@
+MD5 27262a8ca144fd17435b58bf8fd6a2eb mol-0.9.69_pre2.tar.bz2 2117117
diff --git a/app-emulation/mol/mol-0.9.69_pre2.ebuild b/app-emulation/mol/mol-0.9.69_pre2.ebuild
new file mode 100644
index 000000000000..6ceb360a64f0
--- /dev/null
+++ b/app-emulation/mol/mol-0.9.69_pre2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.69_pre2.ebuild,v 1.1 2003/05/24 23:59:36 lu_zero Exp $
+
+inherit flag-o-matic
+
+S=${WORKDIR}/${P}
+DESCRIPTION="MOL (Mac-on-Linux) lets PPC users run MacOS (X) under Linux (rsync snapshot)"
+SRC_URI="http://cvs.gentoo.org/~lu_zero/distfiles/${P}.tar.bz2"
+HOMEPAGE="http://www.maconlinux.net/"
+
+DEPEND=">=sys-kernel/ppc-sources-benh-2.4.20-r10"
+RDEPEND="net-misc/dhcp
+ net-firewall/iptables"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ppc -x86 -sparc -alpha -mips"
+IUSE=""
+
+src_compile() {
+
+ filter-flags -fsigned-char
+
+ # dhcp config fix and show dchpd messages on starting mol
+ cd ${S}
+ sed -i "s:#ddns-update-style:ddns-update-style:g" Doc/config/dhcpd-mol.conf || die
+ sed -i "s:DHCPD\ -q\ -cf:DHCPD\ -cf:g" Doc/config/tunconfig || die
+
+ ./autogen.sh
+ ./configure --prefix=/usr || die "This is a ppc-only package (time to buy that iBook, no?)"
+ make || die "Failed to compile MOL"
+ make libimport || die "Failed to compile MOL"
+
+}
+
+src_install() {
+
+ emake DESTDIR=${D} install || die "Failed to install MOL"
+
+ dodoc 0README BUILDING COPYING COPYRIGHT CREDITS Doc/*
+
+}
+
+pkg_postinst() {
+ echo
+ einfo "Mac-on-Linux is now installed. To run, use the command startmol."
+ einfo "You might want to configure video modes first with molvconfig."
+ einfo "Other configuration is in /etc/molrc. For more info see:"
+ einfo " www.maconlinux.net"
+ einfo "Also try man molrc, man molvconfig, man startmol"
+ echo
+ einfo "For networking and sound you might install the drivers in the"
+ einfo "folder \"MOL-Install\" on your Mac OS X-Desktop."
+ echo
+ einfo "If errors with networking occur, make sure you have the following"
+ einfo "kernel functions enabled:"
+ einfo "For the dhcp server:"
+ einfo " Socket Filtering (CONFIG_FILTER)"
+ einfo " Packet Socket (CONFIG_PACKET)"
+ einfo "For NAT:"
+ einfo " Network packet filtering (CONFIG_NETFILTER)"
+ einfo " Connection tracking (CONFIG_IP_NF_CONNTRACK)"
+ einfo " IP tables support (CONFIG_IP_NF_IPTABLES)"
+ einfo " Packet filtering (CONFIG_IP_NF_FILTER)"
+ einfo " Full NAT (CONFIG_IP_NF_NAT)"
+ einfo " MASQUERADE target support (CONFIG_IP_NF_TARGET_MASQUERADE)"
+ echo
+}