summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Veber <coronalvr@gentoo.org>2003-12-01 11:58:26 +0000
committerAlex Veber <coronalvr@gentoo.org>2003-12-01 11:58:26 +0000
commit37ccafcd46a607ae76ebd3df93709da65769f878 (patch)
tree8371ac0532f5e872dc0db9250aa4f1e5d261c5b0 /app-emulation
parentbug fixing are us. (diff)
downloadgentoo-2-37ccafcd46a607ae76ebd3df93709da65769f878.tar.gz
gentoo-2-37ccafcd46a607ae76ebd3df93709da65769f878.tar.bz2
gentoo-2-37ccafcd46a607ae76ebd3df93709da65769f878.zip
bug fixing are us.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog9
-rw-r--r--app-emulation/wine/Manifest4
-rw-r--r--app-emulation/wine/files/digest-wine-20031118-r14
-rw-r--r--app-emulation/wine/files/winearts-kdecvs-fix.patch11
-rw-r--r--app-emulation/wine/wine-20031118-r1.ebuild127
5 files changed, 152 insertions, 3 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 8f973289a1e8..9f3bd2264763 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/wine
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.58 2003/11/19 19:34:23 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.59 2003/12/01 11:58:19 coronalvr Exp $
+
+*wine-20031118-r1 (01 Dec 2003)
+
+ 01 Dec 2003; Alex Veber <coronalvr@gentoo.org> wine-20031118-r1.ebuild,
+ files/winearts-kdecvs-fix.patch:
+ revision bump, this fixes #32991, #32226, #31144
+ and the long and annoying #31557 yay! :)
*wine-20031118 (19 Nov 2003)
diff --git a/app-emulation/wine/Manifest b/app-emulation/wine/Manifest
index 5b8a080ddada..f69999c68316 100644
--- a/app-emulation/wine/Manifest
+++ b/app-emulation/wine/Manifest
@@ -1,8 +1,8 @@
MD5 9bf1cedbd74c942349dea043a5c457e6 wine-20031016.ebuild 3285
-MD5 afe7dd597e1af20451ef1fdfb98e648a wine-20031118-r1.ebuild 3361
+MD5 7f4cd16ddc0c267538fefef61936109c wine-20031118-r1.ebuild 3362
MD5 bf8a6ecb4897cb73eeac70260c40f136 wine-20031118.ebuild 3284
MD5 f81e7076a368cabf746a5bf2902b7331 wine-20030911.ebuild 3285
-MD5 e6026154ae19e636059d45acede45ce2 ChangeLog 10695
+MD5 0658f7590c52a36b7684f8ef169556ad ChangeLog 10935
MD5 6525c48ba09d08599432ea6c299e52f4 metadata.xml 354
MD5 1668a758aa2007cb99a773b3c5c844c9 files/winearts-kdecvs-fix.patch 325
MD5 f4c2e1af9760b436e551775c823b6bed files/digest-wine-20031118-r1 285
diff --git a/app-emulation/wine/files/digest-wine-20031118-r1 b/app-emulation/wine/files/digest-wine-20031118-r1
new file mode 100644
index 000000000000..8f6f87987c89
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20031118-r1
@@ -0,0 +1,4 @@
+MD5 5787e6b3205b54f2230b4c4c0d422c3c Wine-20031118.tar.gz 9539006
+MD5 fa4393cbc288ea89f761ad8d9258cc68 wine-20031118-xopenfont.patch 833
+MD5 af8da46a0e51578ff1e18e399141d628 wine-20031118-fake_windows.tar.bz2 500
+MD5 674d52c1985297ae269ff0af8df8e62b wine-20031118-r1-misc.tar.bz2 5154
diff --git a/app-emulation/wine/files/winearts-kdecvs-fix.patch b/app-emulation/wine/files/winearts-kdecvs-fix.patch
new file mode 100644
index 000000000000..de54336947a8
--- /dev/null
+++ b/app-emulation/wine/files/winearts-kdecvs-fix.patch
@@ -0,0 +1,11 @@
+--- tools/makedep.c 2003-06-20 21:31:13.000000000 +0000
++++ tools/makedepnew.c 2003-12-01 13:10:10.490498720 +0000
+@@ -504,6 +504,8 @@
+ if (opt[2]) SrcDir = opt + 2;
+ else SrcDir = NULL;
+ break;
++ case 'p':
++ break;
+ case 'f':
+ if (opt[2]) OutputFileName = opt + 2;
+ break;
diff --git a/app-emulation/wine/wine-20031118-r1.ebuild b/app-emulation/wine/wine-20031118-r1.ebuild
new file mode 100644
index 000000000000..f4c0003ed2c9
--- /dev/null
+++ b/app-emulation/wine/wine-20031118-r1.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20031118-r1.ebuild,v 1.1 2003/12/01 11:58:19 coronalvr Exp $
+
+inherit eutils base
+
+DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
+HOMEPAGE="http://www.winehq.com/"
+SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz
+ mirror://gentoo/${P}-xopenfont.patch
+ mirror://gentoo/${P}-fake_windows.tar.bz2
+ mirror://gentoo/${PF}-misc.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc"
+IUSE="nas arts cups opengl alsa tcltk nptl debug"
+
+DEPEND="sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ >=sys-libs/ncurses-5.2
+ >=media-libs/freetype-2.0.0
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tcl dev-lang/tk )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )"
+
+src_unpack() {
+ unpack Wine-${PV}.tar.gz
+ cd ${S}
+ epatch ${DISTDIR}/${P}-xopenfont.patch
+ epatch ${FILESDIR}/winearts-kdecvs-fix.patch
+}
+
+src_compile() {
+ # there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected
+
+ unset CFLAGS CXXFLAGS
+
+ ac_cv_header_jack_jack_h=no \
+ ac_cv_lib_soname_jack= \
+ ./configure \
+ --prefix=/usr/lib/wine \
+ --sysconfdir=/etc/wine \
+ --host=${CHOST} \
+ --enable-curses \
+ `use_enable opengl` \
+ `use_with nptl` \
+ `use_enable debug trace` \
+ `use_enable debug` \
+ || die "configure failed"
+
+ cd ${S}/programs/winetest
+ sed -i 's:wine.pm:include/wine.pm:' Makefile
+
+ # No parallel make
+ cd ${S}
+ make depend all || die
+ cd programs && emake || die
+}
+
+src_install() {
+ local WINEMAKEOPTS="prefix=${D}/usr/lib/wine"
+
+ ### Install wine to ${D}
+ make ${WINEMAKEOPTS} install || die
+ cd ${S}/programs
+ make ${WINEMAKEOPTS} install || die
+
+ # Needed for later installation
+ dodir /usr/bin
+
+ ### Creation of /usr/lib/wine/.data
+ # Setting up fake_windows
+ dodir /usr/lib/wine/.data
+ cd ${D}/usr/lib/wine/.data
+ tar jxvf ${DISTDIR}/${P}-fake_windows.tar.bz2
+ chown root:root fake_windows/ -R
+
+ # Unpacking the miscellaneous files
+ tar jxvf ${DISTDIR}/${PF}-misc.tar.bz2
+ chown root:root config
+
+ # moving the wrappers to bin/
+ insinto /usr/bin
+ dobin regedit-wine wine winedbg
+ rm regedit-wine wine winedbg
+
+ # copying the winedefault.reg into .data
+ insinto /usr/lib/wine/.data
+ doins ${WORKDIR}/${P}/winedefault.reg
+
+ # Set up this dynamic data
+ cd ${S}
+ insinto /usr/lib/wine/.data/fake_windows/Windows
+ doins documentation/samples/system.ini
+ doins documentation/samples/generic.ppd
+ ## Setup of .data complete
+
+ ### Misc tasks
+ # Take care of the documentation
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ # Manpage setup
+ cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man5/wine.conf.5
+ rm ${D}/usr/lib/${PN}/man/man5/wine.conf.5
+
+ # Remove the executable flag from those libraries.
+ cd ${D}/usr/lib/wine/lib/wine
+ chmod a-x *.so
+}
+
+pkg_postinst() {
+ einfo "Use /usr/bin/wine to start wine. This is a wrapper-script"
+ einfo "which will take care of everything else."
+ einfo ""
+ einfo "Use /usr/bin/regedit-wine to import registry files into the"
+ einfo "wine registry."
+}