summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-11-28 18:01:48 +0000
committerTilman Klar <phoenix@gentoo.org>2002-11-28 18:01:48 +0000
commit73955508c8f145bd308fedb4870b9e38be4be014 (patch)
tree732900ff34655790e7fbecb019261e99bf1b4108 /app-emulation
parentset -ppc in all xmms-arts builds (none work) (diff)
downloadgentoo-2-73955508c8f145bd308fedb4870b9e38be4be014.tar.gz
gentoo-2-73955508c8f145bd308fedb4870b9e38be4be014.tar.bz2
gentoo-2-73955508c8f145bd308fedb4870b9e38be4be014.zip
Version bump. This closes bug #11296.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog11
-rw-r--r--app-emulation/wine/files/digest-wine-200211251
-rw-r--r--app-emulation/wine/files/wine-20021125-fake_windows.tar.bz2bin0 -> 500 bytes
-rw-r--r--app-emulation/wine/files/wine-20021125-misc.tar.bz2bin0 -> 4591 bytes
-rw-r--r--app-emulation/wine/wine-20021125.ebuild117
5 files changed, 126 insertions, 3 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index c5217e96da67..02f08989d880 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,14 +1,19 @@
# ChangeLog for app-emulation/wine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.23 2002/11/08 15:14:44 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.24 2002/11/28 18:01:48 phoenix Exp $
+
+*wine-20021125 (28 Nov 2002)
+
+ 28 Nov 2002; phoen][x <phoenix@gentoo.org> wine-20021125.ebuild, ChangeLog,
+ files/wine-20021125-fake_windows.tar.bz2, files/wine-20021125-misc.tar.bz2 :
+ Version bump. This closes bug 11296 - thanks to Martin Holzer
+ <mholzer@gentoo.org>.
*wine-20021031 (04 Nov 2002)
08 Nov 2002; phoen][x <phoenix@gentoo.org> wine-20021031.ebuild :
-
Put this ebuild into the stable profile.
-
04 Oct 2002; phoen][x <phoenix@gentoo.org> wine-20021031.ebuild, ChangeLog,
files/wine-20021031-fake_windows.tar.bz2, files/wine-20021031-misc.tar.bz2 :
diff --git a/app-emulation/wine/files/digest-wine-20021125 b/app-emulation/wine/files/digest-wine-20021125
new file mode 100644
index 000000000000..68610ab763bb
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20021125
@@ -0,0 +1 @@
+MD5 f5bff967a281e29d2b29c447a0e529cc Wine-20021125.tar.gz 7914022
diff --git a/app-emulation/wine/files/wine-20021125-fake_windows.tar.bz2 b/app-emulation/wine/files/wine-20021125-fake_windows.tar.bz2
new file mode 100644
index 000000000000..d60f11e08ee3
--- /dev/null
+++ b/app-emulation/wine/files/wine-20021125-fake_windows.tar.bz2
Binary files differ
diff --git a/app-emulation/wine/files/wine-20021125-misc.tar.bz2 b/app-emulation/wine/files/wine-20021125-misc.tar.bz2
new file mode 100644
index 000000000000..90b963f8896c
--- /dev/null
+++ b/app-emulation/wine/files/wine-20021125-misc.tar.bz2
Binary files differ
diff --git a/app-emulation/wine/wine-20021125.ebuild b/app-emulation/wine/wine-20021125.ebuild
new file mode 100644
index 000000000000..e0e30dd18bf0
--- /dev/null
+++ b/app-emulation/wine/wine-20021125.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20021125.ebuild,v 1.1 2002/11/28 18:01:48 phoenix Exp $
+
+IUSE="nas arts cups opengl alsa"
+
+DESCRIPTION="Wine is a free implementation of Windows(tm) on Unix."
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-${PV}.tar.gz"
+HOMEPAGE="http://www.winehq.com/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc -sparc -sparc64"
+DEPEND="virtual/x11
+ sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ dev-lang/tcl dev-lang/tk
+ >=sys-libs/ncurses-5.2
+ >=media-libs/freetype-2.0.0
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )"
+
+src_compile() {
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ # there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected
+
+ # the folks at #winehq were really angry about custom optimization
+ export CFLAGS=""
+ export CXXFLAGS=""
+
+ ./configure --prefix=/usr/lib/wine \
+ --sysconfdir=/etc/wine \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
+
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ # No parallel make
+ cd ${S}
+ make depend all || die
+ cd programs && emake || die
+}
+
+src_install () {
+ local WINEMAKEOPTS="prefix=${D}/usr/lib/wine"
+
+ ### Install wine to ${D}
+ cd ${S}
+ make ${WINEMAKEOPTS} install || die
+ cd ${S}/programs
+ make ${WINEMAKEOPTS} install || die
+
+ # Needed for later installation
+ dodir /usr/bin
+
+ ### Creation of /usr/lib/wine/.data
+ # Setting up fake_windows
+ dodir /usr/lib/wine/.data
+ cd ${D}/usr/lib/wine/.data
+ tar jxvf ${FILESDIR}/${P}-fake_windows.tar.bz2
+ chown root:root fake_windows/ -R
+
+ # Unpacking the miscellaneous files
+ tar jxvf ${FILESDIR}/${P}-misc.tar.bz2
+ chown root:root config
+
+ # moving the wrappers to bin/
+ insinto /usr/bin
+ dobin regedit-wine wine
+ rm regedit-wine wine
+
+ # copying the winedefault.reg into .data
+ insinto /usr/lib/wine/.data
+ doins ${WORKDIR}/${P}/winedefault.reg
+
+ # Set up this dynamic data
+ cd ${S}
+ insinto /usr/lib/wine/.data/fake_windows/Windows
+ doins documentation/samples/system.ini
+ doins documentation/samples/generic.ppd
+ ## Setup of .data complete
+
+ ### Misc tasks
+ # Take care of the documentation
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ # Manpage setup
+ cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
+
+ # Remove the executable flag from those libraries.
+ cd ${D}/usr/lib/wine/lib/wine
+ chmod a-x *.so
+}
+
+pkg_postinst() {
+ einfo "Use /usr/bin/wine to start wine. This is a wrapper-script"
+ einfo "which will take care of everything else."
+ einfo ""
+ einfo "Use /usr/bin/regedit-wine to import registry files into the"
+ einfo "wine registry."
+ einfo ""
+ einfo "If you have further questions, enhancements or patches"
+ einfo "send an email to phoenix@gentoo.org"
+}