summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-10-06 06:45:59 +0000
committerMamoru Komachi <usata@gentoo.org>2004-10-06 06:45:59 +0000
commitde3adf3ddec776c14281ac861b4c64927cd82f18 (patch)
tree87a8b58f7ee9ae57d0fac3fbbc779b06da530a82 /app-i18n
parentFixed groups IFS in enewuser. Thanks to Joe Jezak <josejx@gmail.com>, bug #57... (diff)
downloadgentoo-2-de3adf3ddec776c14281ac861b4c64927cd82f18.tar.gz
gentoo-2-de3adf3ddec776c14281ac861b4c64927cd82f18.tar.bz2
gentoo-2-de3adf3ddec776c14281ac861b4c64927cd82f18.zip
Initial import.
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/qimhangul/ChangeLog10
-rw-r--r--app-i18n/qimhangul/Manifest2
-rw-r--r--app-i18n/qimhangul/files/digest-qimhangul-0.0.11
-rw-r--r--app-i18n/qimhangul/files/qimhangul-0.0.1-thread-gentoo.diff11
-rw-r--r--app-i18n/qimhangul/metadata.xml5
-rw-r--r--app-i18n/qimhangul/qimhangul-0.0.1.ebuild52
6 files changed, 81 insertions, 0 deletions
diff --git a/app-i18n/qimhangul/ChangeLog b/app-i18n/qimhangul/ChangeLog
new file mode 100644
index 000000000000..0b158e35e004
--- /dev/null
+++ b/app-i18n/qimhangul/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-i18n/qimhangul
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/qimhangul/ChangeLog,v 1.1 2004/10/06 06:45:59 usata Exp $
+
+*qimhangul-0.0.1 (06 Oct 2004)
+
+ 06 Oct 2004; Mamoru KOMACHI <usata@gentoo.org>
+ +files/qimhangul-0.0.1-thread-gentoo.diff, +qimhangul-0.0.1.ebuild:
+ Initial import.
+
diff --git a/app-i18n/qimhangul/Manifest b/app-i18n/qimhangul/Manifest
new file mode 100644
index 000000000000..d56bf43ad0e8
--- /dev/null
+++ b/app-i18n/qimhangul/Manifest
@@ -0,0 +1,2 @@
+MD5 4f6c8d0d19c04ea5acb8b304383d753c qimhangul-0.0.1.ebuild 1188
+MD5 3733fe5702155ef1ce0988b30a13e04b files/digest-qimhangul-0.0.1 67
diff --git a/app-i18n/qimhangul/files/digest-qimhangul-0.0.1 b/app-i18n/qimhangul/files/digest-qimhangul-0.0.1
new file mode 100644
index 000000000000..f87679b1dc0a
--- /dev/null
+++ b/app-i18n/qimhangul/files/digest-qimhangul-0.0.1
@@ -0,0 +1 @@
+MD5 64690cf4a1f3fe32d365369d5f06e4ba qimhangul-0.0.1.tar.gz 171386
diff --git a/app-i18n/qimhangul/files/qimhangul-0.0.1-thread-gentoo.diff b/app-i18n/qimhangul/files/qimhangul-0.0.1-thread-gentoo.diff
new file mode 100644
index 000000000000..e7a87c98941c
--- /dev/null
+++ b/app-i18n/qimhangul/files/qimhangul-0.0.1-thread-gentoo.diff
@@ -0,0 +1,11 @@
+--- qimhangul.pro.orig 2004-10-06 13:53:50.000000000 +0900
++++ qimhangul.pro 2004-10-06 15:27:52.000000000 +0900
+@@ -8,7 +8,7 @@
+ target.path = $(QTDIR)/plugins/inputmethods
+ INSTALLS += target
+
+-CONFIG += debug plugin qt
++CONFIG += debug plugin qt thread
+
+ # Input
+ HEADERS += \
diff --git a/app-i18n/qimhangul/metadata.xml b/app-i18n/qimhangul/metadata.xml
new file mode 100644
index 000000000000..2d5852c16c60
--- /dev/null
+++ b/app-i18n/qimhangul/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cjk</herd>
+</pkgmetadata>
diff --git a/app-i18n/qimhangul/qimhangul-0.0.1.ebuild b/app-i18n/qimhangul/qimhangul-0.0.1.ebuild
new file mode 100644
index 000000000000..e39996fc6625
--- /dev/null
+++ b/app-i18n/qimhangul/qimhangul-0.0.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/qimhangul/qimhangul-0.0.1.ebuild,v 1.1 2004/10/06 06:45:59 usata Exp $
+
+inherit eutils
+
+DESCRIPTION="Qt immodules input method framework plugin for UIM"
+HOMEPAGE="http://kldp.net/projects/qimhangul/"
+SRC_URI="http://kldp.net/download.php/1529/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/qt-3.3.3-r1"
+
+pkg_setup() {
+ if [ ! -e /usr/qt/3/plugins/inputmethods/libqimsw-none.so ] ; then
+ die "You need to rebuild >=x11-libs/qt-3.3.3-r1 with immqt-bc or immqt USE flag enabled."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-thread-gentoo.diff
+}
+
+src_compile() {
+ qmake -makefile || die "qmake failed"
+ emake -j1 || die "make failed."
+}
+
+src_install() {
+ make INSTALL_ROOT=${D} install || die
+
+ dodoc ChangeLog
+}
+
+pkg_postinst() {
+ einfo
+ einfo "After you emerged ${PN}, use right click to switch immodules for Qt."
+ einfo "If you would like to use qimhangul as default instead of XIM,"
+ einfo " set QT_IM_MODULE to hangul2."
+ einfo "e.g.)"
+ einfo " % export QT_IM_MODULE=hangul2"
+ einfo
+ ewarn
+ ewarn "qtconfig is no longer used for selecting input methods."
+ ewarn
+}