summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2004-09-02 16:50:21 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2004-09-02 16:50:21 +0000
commitcc1c09c596e310a6ad83ffbaccbf6a3418030146 (patch)
tree3e81ca022bdc6aa610d59adf2e25318600d03d9d /app-laptop/ibm-acpi
parentppc stable profile update (Manifest recommit) (diff)
downloadgentoo-2-cc1c09c596e310a6ad83ffbaccbf6a3418030146.tar.gz
gentoo-2-cc1c09c596e310a6ad83ffbaccbf6a3418030146.tar.bz2
gentoo-2-cc1c09c596e310a6ad83ffbaccbf6a3418030146.zip
Initial import. Fixes bug #62243. Ebuild by me.
Diffstat (limited to 'app-laptop/ibm-acpi')
-rw-r--r--app-laptop/ibm-acpi/ChangeLog10
-rw-r--r--app-laptop/ibm-acpi/Manifest2
-rw-r--r--app-laptop/ibm-acpi/files/digest-ibm-acpi-0.31
-rw-r--r--app-laptop/ibm-acpi/ibm-acpi-0.3.ebuild78
-rw-r--r--app-laptop/ibm-acpi/metadata.xml8
5 files changed, 99 insertions, 0 deletions
diff --git a/app-laptop/ibm-acpi/ChangeLog b/app-laptop/ibm-acpi/ChangeLog
new file mode 100644
index 000000000000..49d77b22d213
--- /dev/null
+++ b/app-laptop/ibm-acpi/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-laptop/ibm-acpi
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/ibm-acpi/ChangeLog,v 1.1 2004/09/02 16:50:21 brix Exp $
+
+*ibm-acpi-0.3 (02 Sep 2004)
+
+ 02 Sep 2004; Henrik Brix Andersen <brix@gentoo.org> +metadata.xml,
+ +ibm-acpi-0.3.ebuild:
+ Initial import. Fixes bug #62243. Ebuild by me.
+
diff --git a/app-laptop/ibm-acpi/Manifest b/app-laptop/ibm-acpi/Manifest
new file mode 100644
index 000000000000..3114f6f4e719
--- /dev/null
+++ b/app-laptop/ibm-acpi/Manifest
@@ -0,0 +1,2 @@
+MD5 0992e2f735573f75ac01e4fba3eccf40 ibm-acpi-0.3.ebuild 1667
+MD5 d3d4d8542e2fcc77d860f0942089bb8c files/digest-ibm-acpi-0.3 63
diff --git a/app-laptop/ibm-acpi/files/digest-ibm-acpi-0.3 b/app-laptop/ibm-acpi/files/digest-ibm-acpi-0.3
new file mode 100644
index 000000000000..e790d1c86bbe
--- /dev/null
+++ b/app-laptop/ibm-acpi/files/digest-ibm-acpi-0.3
@@ -0,0 +1 @@
+MD5 8da9bfb0305155dd85d5f1b1f54536ec ibm-acpi-0.3.tar.gz 17217
diff --git a/app-laptop/ibm-acpi/ibm-acpi-0.3.ebuild b/app-laptop/ibm-acpi/ibm-acpi-0.3.ebuild
new file mode 100644
index 000000000000..4374a64ceec3
--- /dev/null
+++ b/app-laptop/ibm-acpi/ibm-acpi-0.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/ibm-acpi/ibm-acpi-0.3.ebuild,v 1.1 2004/09/02 16:50:21 brix Exp $
+
+inherit kernel-mod
+
+DESCRIPTION="IBM ThinkPad ACPI extras"
+
+HOMEPAGE=""
+SRC_URI="http://bkernel.sf.net/tmp/ibm-acpi-0.3.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+src_unpack() {
+ if ! egrep "^CONFIG_ACPI=[ym]" ${ROOT}/usr/src/linux/.config >/dev/null
+ then
+ eerror ""
+ eerror "${PN} requires an ACPI (CONFIG_ACPI) enabled kernel."
+ eerror ""
+ die "Kernel ACPI support not detected."
+ fi
+
+ unpack ${A}
+
+ # let pkg_postinst() handle depmod
+ sed -i -e "s:depmod -a::" ${S}/Makefile
+
+ kernel-mod_getversion
+
+ if [ ${KV_MINOR} -gt 5 ] && [ ${KV_PATCH} -gt 5 ]
+ then
+ sed -i 's:SUBDIRS=:M=:g' ${S}/Makefile
+ fi
+}
+
+src_compile() {
+ if [ ${KV_MINOR} -gt 5 ] && [ ${KV_PATCH} -gt 5 ]
+ then
+ unset ARCH
+ fi
+
+ emake KDIR=${ROOT}/usr/src/linux || die
+}
+
+src_install() {
+ if [ ${KV_MINOR} -gt 5 ] && [ ${KV_PATCH} -gt 5 ]
+ then
+ unset ARCH
+ fi
+
+ emake MDIR=${D}/lib/modules/${KV}/acpi install || die
+
+ dodoc LICENSE README
+
+ docinto examples/etc/acpi/actions
+ dodoc etc/acpi/actions/*
+
+ docinto examples/etc/acpi/events
+ dodoc etc/acpi/events/*
+}
+
+pkg_postinst() {
+ einfo "Checking kernel module dependencies"
+ test -r "${ROOT}/usr/src/linux/System.map" && \
+ depmod -ae -F "${ROOT}/usr/src/linux/System.map" -b "${ROOT}" -r ${KV}
+
+ einfo ""
+ einfo "You may wish to install sys-apps/acpid to handle the ACPI events generated"
+ einfo "by ${P}. Example acpid configuration has been installed to"
+ einfo "/usr/share/doc/${PF}/examples/"
+ einfo ""
+ einfo "For further instructions please see /usr/share/doc/${PF}/README.gz"
+ einfo ""
+}
diff --git a/app-laptop/ibm-acpi/metadata.xml b/app-laptop/ibm-acpi/metadata.xml
new file mode 100644
index 000000000000..042b87179f01
--- /dev/null
+++ b/app-laptop/ibm-acpi/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>mobile</herd>
+<maintainer>
+ <email>brix@gentoo.org</email>
+</maintainer>
+</pkgmetadata>