summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-07-19 18:14:51 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-07-19 18:14:51 +0000
commit66f1d5fb959404620e3320c8539cc15d77cb1ed1 (patch)
treed911c80927fc074cbfdddc40c403022a765f2cf4 /app-laptop/pbbuttonsd
parentstyle fix (diff)
downloadgentoo-2-66f1d5fb959404620e3320c8539cc15d77cb1ed1.tar.gz
gentoo-2-66f1d5fb959404620e3320c8539cc15d77cb1ed1.tar.bz2
gentoo-2-66f1d5fb959404620e3320c8539cc15d77cb1ed1.zip
Added the latest version.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-laptop/pbbuttonsd')
-rw-r--r--app-laptop/pbbuttonsd/ChangeLog7
-rw-r--r--app-laptop/pbbuttonsd/Manifest4
-rw-r--r--app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.7.11
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.7.1.ebuild51
4 files changed, 61 insertions, 2 deletions
diff --git a/app-laptop/pbbuttonsd/ChangeLog b/app-laptop/pbbuttonsd/ChangeLog
index 4b36fac0da0a..b6eb2096b964 100644
--- a/app-laptop/pbbuttonsd/ChangeLog
+++ b/app-laptop/pbbuttonsd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/pbbuttonsd
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.28 2005/07/13 20:05:11 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.29 2005/07/19 18:14:51 josejx Exp $
+
+*pbbuttonsd-0.7.1 (19 Jul 2005)
+
+ 19 Jul 2005; Joseph Jezak <josejx@gentoo.org> +pbbuttonsd-0.7.1.ebuild:
+ Added latest version.
13 Jul 2005; Joseph Jezak <josejx@gentoo.org> -pbbuttonsd-0.7_pre1.ebuild,
-pbbuttonsd-0.7_pre2.ebuild:
diff --git a/app-laptop/pbbuttonsd/Manifest b/app-laptop/pbbuttonsd/Manifest
index 169a4d4d8767..6463f12ceb03 100644
--- a/app-laptop/pbbuttonsd/Manifest
+++ b/app-laptop/pbbuttonsd/Manifest
@@ -1,9 +1,11 @@
-MD5 f299b2851800161e39d14ee78e52e9da ChangeLog 8523
+MD5 4ea20e7bb37e6e051cb96cbf9e87d2a9 ChangeLog 8655
MD5 f0cdcf7c27493d60d25d76f479b82e63 pbbuttonsd-0.6.10.ebuild 1117
MD5 86caedd5742982169284b585959a54be pbbuttonsd-0.6.6.ebuild 1146
MD5 52f9d8e98c8931645c57a3de1c36727d metadata.xml 156
MD5 51ee7ac8050581e2e52d47aba02e285a pbbuttonsd-0.7.0.ebuild 1505
+MD5 920c4644ab134db5fb46e4a5015028e4 pbbuttonsd-0.7.1.ebuild 1506
MD5 e87049121a8371a7173cb9aa7c5b167d files/pbbuttonsd.rc6 444
MD5 af23b978a8a629ecc99e95f3505e8a74 files/digest-pbbuttonsd-0.6.10 69
+MD5 0d5e37ab33c0a4177affbe953a76f8f3 files/digest-pbbuttonsd-0.7.1 68
MD5 3d98fa10cb4dd979a3b80c36a1a83b4b files/digest-pbbuttonsd-0.7.0 68
MD5 72caa2adac6c8260c57c0ae15cc259f3 files/digest-pbbuttonsd-0.6.6 68
diff --git a/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.7.1 b/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.7.1
new file mode 100644
index 000000000000..3a490919e469
--- /dev/null
+++ b/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.7.1
@@ -0,0 +1 @@
+MD5 aa8421806a5875ba5c46341a1f2b57cb pbbuttonsd-0.7.1.tar.gz 398822
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.1.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.1.ebuild
new file mode 100644
index 000000000000..08b50b2be1a5
--- /dev/null
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.1.ebuild,v 1.1 2005/07/19 18:14:51 josejx Exp $
+
+inherit eutils linux-info
+
+DESCRIPTION="program to map special Powerbook/iBook keys"
+HOMEPAGE="http://pbbuttons.sf.net"
+SRC_URI="mirror://sourceforge/pbbuttons/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE=""
+
+DEPEND="virtual/libc
+ >=sys-apps/baselayout-1.8.6.12-r1"
+RDEPEND=""
+
+src_compile() {
+ if ! linux_chkconfig_present INPUT_EVDEV ; then
+ eerror "Please enable CONFIG_INPUT_EVDEV in your kernel"
+ eerror "pbbuttonsd will not work without it."
+ die "Kernel not compiled with CONFIG_INPUT_EVDEV support"
+ fi
+
+ econf || die "Sorry, failed to configure pbbuttonsd"
+ emake || die "Sorry, failed to compile pbbuttonsd"
+}
+
+src_install() {
+ dodir /etc/power
+ make DESTDIR=${D} install || die "failed to install"
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pbbuttonsd.rc6 pbbuttonsd
+ dodoc README
+}
+
+pkg_postinst() {
+ if linux_chkconfig_module INPUT_EVDEV ; then
+ ewarn "Ensure that the evdev kernel module is loaded otherwise"
+ ewarn "pbbuttonsd won't work."
+ fi
+
+ einfo
+ einfo "This version of pbbuttonsd can replace PMUD functionality."
+ einfo "If you want PMUD installed and running, you should set"
+ einfo "replace_pmud=no in /etc/pbbuttonsd.conf. Otherwise you can"
+ einfo "try setting replace_pmud=yes in /etc/pbbuttonsd.conf and"
+ einfo "disabling PMUD"
+}